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page 126
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Walls” on page 495
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“Non-disruptive Capacity Changes” on 
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Disruptive Partitioning” on page 260. 
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Preface

This guide is intended primarily for SL3000 library system administrators and 
operators. It can also be used by Sun StorageTek partners and support representatives. 

Most of the information pertains to the library hardware, the StorageTek Library 
Console, and related operations. For specific drive information or for client application 
software commands, see the appropriate drive or software documentation. 

Organization

Chapter 1 SL3000 Introduction. Overview of the Sun StorageTek SL3000 modular library system 
features and functions. 

Chapter 2 StorageTek Library Console. Topics and procedures for installing and using the 
SL Console graphical user interface. 

Chapter 3 SL3000 Automated Library Operations. Topics and procedures for using the 
SL Console to configure, manage, and monitor the SL3000 library in automated mode. 

Chapter 4 Licensing. Topics, procedures, and screen reference for installing and managing 
SL3000 feature licenses. 

Chapter 5 Capacity on Demand. Topics, procedures, and screen reference for installing and 
managing SL3000 licensed capacity.

Chapter 6 Library Partitioning. Topics, procedures, and screen reference for installing and 
managing SL3000 library partitions.

Chapter 7 SL Console Diagnostics and Utilities. Topics and procedures for using the 
SL Console to perform diagnostic and utility functions on the SL3000 library. 

Chapter 8 Manual Operations. Topics and procedures for safely using the SL3000 library in 
manual mode. 

Appendix A Library Resource Addresses. Reference information regarding storage cell, CAP, and 
drive addressing used with the SL3000 library. 

Appendix B Wall Diagrams. Detailed diagrams of storage cell, CAP, and drive layouts. 
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Alert Messages
Alert messages call your attention to information that is especially important or that 
has a unique relationship to the main text or graphic.

Note – A note provides additional information that is of special interest. A note might 
point out exceptions to rules or procedures. 

Caution – A caution informs the reader of conditions that might result in damage to 
hardware, corruption of data, corruption of application software, or long-term health 
problems in people. A caution always precedes the information to which it pertains.

Warning – Possible Physical Injury.  A warning alerts the reader to conditions 
that might result in injury or death. A warning always precedes the information 
to which it pertains.

Appendix C Cartridge Handling. Reference information on labeling and using cartridges in the 
SL3000 library. 

Appendix D Web-launched SL Console Server. Topics and procedures for installing and 
configuring the Web-launched SL Console server. 

Index Alphabetical list of topics in this manual.
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Conventions
Typographical conventions highlight special words, phrases, and actions in this 
publication.

Item Example Description of Convention

Buttons MENU Font and capitalization follows label 
on product

Commands Mode Select Initial cap

Document titles System Assurance Guide Italic font

Emphasis not or must Italic font

File names fsc.txt Monospace font

Hypertext links Figure 2-1 on page 2-5 Blue (prints black in hardcopy 
publications)

Indicators Open Font and capitalization follows label 
on product

Jumper names TERMPWR All uppercase

Keyboard keys <Y>  
<Enter> or  
<Ctrl+Alt+Delete>

Font and capitalization follows label 
on product; enclosed within angle 
brackets

Menu names Configuration Menu Capitalization follows label on 
product

Parameters and variables Device = xx Italic font

Path names c:/mydirectory Monospace font

Port or connector names SER1 Font and capitalization follows label 
on product; otherwise, all uppercase

Positions for circuit breakers, 
jumpers, and switches

ON Font and capitalization follows label 
on product; otherwise, all uppercase

Screen text (including screen 
captures, screen messages, 
and user input)

downloading Monospace font

Switch names Power Font and capitalization follows label 
on product

URLs http://www.sun.com Blue (prints black in hardcopy 
publications)
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Related Documentation

SL3000 Modular Library Publications Part Number

SL3000 Systems Assurance Guide 3161941xx

SNMP Guide for SL3000 Libraries 3161945xx

SL3000 Troubleshooting Guide 4186091xx

Tape Drive Documentation Part Number

Hewlett Packard Ultrium Tape Drive Manual CD included with drive 

IBM Ultrium Tape Drive Manual CD included with drive

T10000 Tape Drive Installation Manual 96173

T10000 Tape Drive Service Manual 96175

T10000 Virtual Operator’s Panel User’s Guide (for Service Representatives) 96180

T9840 Tape Drive User’s Reference Manual 95739

T9x40 Tape Drive Installation Manual 95879

T9x40 Tape Drive Service Reference Manual 95740

Tape Management Software Publications Part Number

Automated Cartridge System Library Software (ACSLS) 

ACSLS Administrator’s Guide 3161201xx

ACSLS Messages 3161202xx

ACSLS Quick Reference 3161204xx

Host Software Component (HSC) MVS Publications

HSC Configuration Guide 3126422xx 

HSC Messages and Codes Guide 3126425xx 

HSC Operator’s Guide 3126423xx 

HSC Reference Summary Guide 3126426xx 

HSC System Programmer’s Guide 3126424xx 

Other Publications Part Number

Product Regulatory and Safety Compliance Manual 3161956xx

American National Standard Dictionary for Information Processing Systems ANSI X3/TR-1-82

American National Standard Magnetic Tape and Cartridge for Information 
Interchange 

ANSI X3B5/87-009
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Magnetic Tape Labels and File Structure for Information Interchange ANSI X3.27-1978

SCSI-3 Parallel Interface (SPI) ANSI X3T9.2/91-010R7

Small Computer System Interface ISO 9316:1989

Fibre Optics User's Guide 9433

Publications Link

SunSolve or docs.sun.com
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Additional Information
Sun Microsystems, Inc. (Sun) offers several methods for you to obtain additional 
information. 

Sun’s external Web Site 
Sun’s external Web site provides marketing, product, event, corporate, and service 
information. The external Web site is accessible to anyone with a Web browser and an 
Internet connection.

The URL is: http://www.sun.com 

The URL for Sun StorageTek brand-specific information is: 

http://www.sun.com/storagetek 

SunSolve and Helpful Links
SunSolve and the Sun links below are Web sites that enable members to search from 
technical documentation, downloads, patches, features, articles, and the Sun Systems 
Handbook.

■ Library firmware and SL Console code downloads:

http://http://www.sun.com/download/index.jsp 

■ Drivers: http://www.sun.com/download/index.jsp 

■ Documentation (customer): http://docs.sun.com/app/docs 

■ General product information:

http://www.sun.com/storagetek/products.jsp 

■ SunSolve External site: http://sunsolve.sun.com 

■ Sun System Handbook (customer):

http://sunsolve.sun.com/handbook_pub/validateUser.do?target=
index 

■ Sun Learning Services – Training: http://www.sun.com/training 

Partners Site
TheSun StorageTek Partners site is for partners with a StorageTek Partner Agreement. 
This site provides information about products, services, customer support, upcoming 
events, training programs, and sales tools to support StorageTek Partners. Access to 
this site is restricted. On the Partners Login page, Sun employees nd current partners 
who do not have access can request a login ID and password, and prospective partners 
can apply to become StorageTek resellers. 

http://www.sun.com/partners 
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CHAPTER 1

SL3000 Introduction 

The SL3000 is the latest addition to the Sun StorageTek modular library family, which 
includes the SL500 and SL8500 modular library systems. 

FIGURE 1-1 SL3000 Modular Library System

This chapter introduces you to the SL3000 library and its components and 
configurations, including the following topics:

■ “SL3000 Features” on page 2

■ “Modular Design” on page 3

■ “Base Module” on page 7

■ “Drive Expansion Module” on page 10

■ “Cartridge Expansion Module” on page 13

■ “Parking Expansion Module” on page 14

■ “Access Expansion Module” on page 15

■ “Tape Drives” on page 17

■ “Cartridge Access Ports” on page 19

■ “Robotics Units” on page 20

■ “Power Options” on page 22

■ “Cooling” on page 23

■ “Interfaces” on page 24

■ “Library Management Software” on page 28

■ “Operating Modes” on page 30
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SL3000 Features 
The SL3000 library offers customers the benefits of: 

■ Scalability in storage capacity from 200 to 5821 storage cells 

■ Performance from 1 to 56 tape drives 

■ Support of a variety of tape drives

■ Any cartridge, Any slot™ support of mixed-media 

■ Heterogeneous attachments using standard interfaces 

■ Multiple library management software options and programs 

The SL3000 was designed to: 

■ Address medium to large open systems and entry-level mainframe markets. 

■ Occupy a standard datacenter footprint with measurements of approximately: 

■ Height: 198 cm (78 in.), 

■ Depth: 124 cm (48.8 in.), 

■ Length: varies from 91.5 cm (36 in.) with one module, to 478 cm (188 in.) with six 
modules 
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Modular Design 
The SL3000 library provides a modular design, which allows customers to meet the 
demands of a rapidly growing and constantly changing environment. 

Modules 
There are five types of modules in an SL3000 library. The Base Module is the only one 
that is required. 

■ Base Modulee – one only 

■ Drive Expansion Module (DEM) – one only, attached directly to the left side of the 
Base Module 

■ Cartridge Expansion Module (CEM) – up to eight total, with up to four on the left 
side of the Base Module (and optional DEM) and up to four on the right

■ Parking Expansion Module (PEM) – installed always in pairs, one on each end of the 
library configuration 

■ Access Expansion Module (AEM) – one or two, always installed on the end of the 
library configuration. 

Note – AEMs and PEMs cannot be installed in the same library. 

The modules consist of walls, columns, and rows that house cartridge storage cells, 
tape drives, cartridge access ports (CAPs), and robotics units (TallBots). 

CenterLine Technology
The SL3000 modular design uses CenterLine technology to help balance the work load 
and improve the performance of the library. The left side of the Base Module serves as 
the centerline. You can add other modules to the left and right of the Base Module. 
Columns to the right of the centerline have positive (+) numbers, while columns to the 
left have negative (–) numbers. 

FIGURE 1-2 on page 4 shows the library centerline and some possible module 
configurations, including: 
■ Base module only 

■ Base module and drive expansion module (DEM) 

■ Addition of cartridge expansion modules (CEMs) and parking expansion modules 
(PEMs) s 
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FIGURE 1-2 Library Configurations Around CenterLine 

Base Module Configurations Base and Drive Expansion Module Configurations
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Any cartridge, Any slot™ Technology
Mixed-media storage cells are used to hold the cartridges. This allows the SL3000 
library to support the Sun StorageTek Any cartridge, Any slot technology and accept a 
variety of media types without reconfiguring the library. 

Cartridges lie flat and are placed in the storage cells with hub down and parallel to the 
floor. To prevent slippage, cartridges are held in place by internal retainer clips. 

Physical Capacities 
The SL3000 is scalable, with physical storage capacities from 200 to 5821 storage cells. 
In addition, the Capacity on Demand feature allows you to pay for only the capacity 
you actually use and expand capacity with minimal disruption to library operations. 

See Chapter 5, “Capacity on Demand” on page 203 for details about installing and 
managing library storage capacity. 

See TABLE 1-1 on page 6 for detailed physical capacities for each module type. To 
calculate the total accessible physical storage cells for a configuration, start with the 
standard configuration cell count, outlined with a heavy border, and then make the 
appropriate adjustments for options and positioning. Following are some examples:

■ Base Module with operator’s panel, a module installed on the right, and three total 
drive arrays: 

320 + 0 + 13 – 55 – 60 = 218 

■ DEM, a module installed on the left, window arrays, a CAP, and four drive arrays: 

410 + 88 + 23 – 77 – 66 – 72 – 78 = 228

■ CEM installed to the left of CenterLine, a module installed on the left, and a CAP:

516 + 104 – 78 = 542

■ PEMs (always installed in pairs), one with a CAP, one without:

308 + 312 – 78 = 542 

Optional Fire/Smoke Detection
Access ports in the ceilings of the modules are provided for optional fire suppression or 
smoke detection equipment. Installation and maintenance of this equipment must be 
arranged by the customer.
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TABLE 1-1 Accessible Physical Cell Count Per Module

Standalone 
or 

Position-
Independent

Adjacent Module
Installed on the:

Module Options Right Left
Total 
Count

Base Module

Standard (with viewing window), 
standalone

320

+13 +88

With operator’s panel +0

With window storage arrays +23

With second drive array -55 -66

With third drive array -60 -72

Drive Expansion Module (DEM)

Standard (with viewing window 
and no CAP)

— 410 +88

With window storage arrays — +23

With CAP — -77

With second drive array — -55 -66

With third drive array — -60 -72

With fourth drive array — -65 -78

Cartridge Expansion Module (CEM)

Standard (no CAP), to the left of 
CenterLine 

516 +0 +104

Standard (no CAP), to the right of 
CenterLine 

620 +0 +0

With CAP -78

Parking Expansion Module (PEM)

Standard (no CAP), to the left of 
CenterLine

308

Standard (no CAP), to the right of 
CenterLine

312

With CAP -78

Access Expansion Module (AEM)

Cannot be used for long-term 
storage 

0

Total accessible storage cell count 
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Base Module 
The Base Module provides both cartridge storage and a minimum of eight tape drives. 
This module includes the power configurations, robotics, electronic modules, cartridge 
access port, cartridge storage cells, tape drives, and operator controls. It centralizes the 
infrastructure for all other modules in the library. 

One and only one Base Module is required for every library installation.

FIGURE 1-3 Base Module – Front View

Configurations Capacity 

8 drives 
16 drives 
24 drives 

8 drives, CAP 
16 drives, CAP 
24 drives, CAP 

See TABLE 1-1 
on page 6 

8 drives, CAP, and Operator panel/Window 
16 drives, CAP, and Operator panel/Window 
24 drives, CAP, and Operator panel/Window 

Dimensions Measurement 

Height 197 cm (77.625 in.) to 
200 cm (78.63 in.) fully adjusted 

Width  76.76 cm (30.22 in.) without covers1

91.5 cm (36 in.) with covers 

Depth 121.9 cm (48 in.) without handles
124 cm (49 in.) with handles 

Weight 265 kg (584 lb) frame only 

Service clearance 

Both doors open 

Front: 46 cm (18 in.) 
Rear: 81 cm (32 in.) 
262 cm (103 inches) 

Side clearance2 Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.) 

Notes: 
1. When additional modules are installed, the covers are 

removed from the Base Module and replaced on the ends of 
the last module in the string. 

2. Required to install or remove the sides covers; they swing out 
and lift off of brackets. 
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The front of the Base Module includes the following components: 

■ Single, 26-cartridge, dual-magazine cartridge access port (CAP) 

■ Service door for library access 

■ Front panel with three LEDs: Library Active, Service Required, and Wait. 

■ Standard viewing window, which can be replaced by either of the following options:

■ Touch-screen operator panel 

■ Cartridge storage cells

The Base Module can hold up to 24 tape drives in any combination that the library 
supports – see “Tape Drives” on page 17 for a list and description. The minimum 
configuration includes one drive bay that can hold from one to eight drives. Two 
additional drive bays can be added to accommodate either 8 or 16 more drives, for a 
maximum of 24 drives. 

Note – Adding a drive bay displaces approximately 55 to 72 additional storage cells, 
depending on the library configuration. See TABLE 1-1 on page 6 for the exact number. 

See FIGURE 1-4 on page 9 for a rear view of the Base Module. The rear door allows 
access to the following:

■ Electronics control module (ECM) 

■ Power distribution units (PDUs) 

■ DC power supplies 

■ Tape drives 

■ Two one-unit rack spaces (1 unit = 44.5 mm [1.75 in.]) for vertically mounting 
auxiliary equipment, such as Ethernet switches 

Note – The Base Module does not contain any general-purpose 19-inch rack space. 

See FIGURE B-1, “Base Module Walls” on page 490 for a detailed diagram of the wall 
layout. 
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FIGURE 1-4 Base Module – Rear View Drawing 

Description 

Robotics DC power supplies 
■ DCPS 1 and 2 or 3 

First drive bay (top)
The first drive bay is standard.
Drive bays are added from the top, 
down.  
 
 

Second drive bay (center) 

 
 
 

Third drive bay (bottom) 

Electronics control module 

HBC and HBT cards 
MPU2 Fibre Channel card (not 
shown)
Two cPCI power supplies 
Two cooling fans 
Two power switches (N+1 and 2N)

AC power distribution units (up to 
two)

■ PDU 1 and PDU 2 

Drive DC power supplies (up to eight) 
■ DCPS 4 through 11 
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Drive Expansion Module 
The optional Drive Expansion Module (DEM) provides the library with additional tape 
drives and cartridge storage capacity. One DEM can be included in a library 
installation, always to the left of the Base Module. 

FIGURE 1-5 Drive Expansion Module – Front View

Configurations Capacity 

8 drives 
16 drives 
24 drives 
32 drives 

8 drives, CAP 
16 drives, CAP 
24 drives, CAP 
32 drives, CAP 

See TABLE 1-1 
on page 6 

8 drives, CAP, and Operator panel/Window 
16 drives, CAP, and Operator panel/Window 
24 drives, CAP, and Operator panel/Window 
32 drives, CAP, and Operator panel/Window 

Dimensions1 Measurement 

Height 197 cm (77.625 in.) to 
200 cm (78.63 in.)

Width 
DEM only
Base and DEM 

 
76.76 cm (30.22 in.) 
168.2 cm (66.22 in.) with covers 2

Depth 121.9 cm (48 in.) without handles
124 cm (49 in.) with handles 

Weight 265 kg (584 lb) frame only 

Service clearance 

Both doors open 

Front: 46 cm (18 in.) 
Rear: 81 cm (32 in.) 
262 cm (103 inches) 

Side clearance3 Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.) 

Notes: 
1. The dimensions of the DEM are the same as the Base module. 
2. When additional modules are installed, the covers are 

removed from the Base Module and replaced on the ends of 
the last module in the string. 

3. Required to install or remove the side covers; they swing out 
and lift off of brackets. 
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The front of the DEM includes space for the following components: 

■ Service door for library access (standard) 

■ Front panel with three LEDs: Library Active, Service Required, and Wait 

■ Optional 26-cartridge, dual-magazine cartridge access port (CAP) 

■ Standard viewing window, which can be replaced by either of the following options:

■ Touch-screen operator panel, if not already in the Base Module 

■ Cartridge storage cells

The DEM comes standard with drive slots to support up to eight tape drives. DEM 
drive slots can optionally be increased, in increments of eight, to a maximum of 32. 

Note – Adding a drive bay displaces approximately 55 to 78 additional storage cells, 
depending on the library configuration. See TABLE 1-1 on page 6 for the exact number. 

There is an additional power system integral to the DEM to support the additional tape 
drives. 

See FIGURE 1-6 on page 12 for a rear view of the DEM. The rear door allows access to 
the following:

■ Tape drives 

■ Drive DC power supplies

■ AC power distribution units (PDUs)

See FIGURE B-2, “Drive Expansion Module Walls” on page 491 for a detailed diagram 
of the wall layout. 



Drive Expansion Module

12 SL3000 User’s Guide • May 2009 Revision AB • 316194401

FIGURE 1-6 Drive Expansion Module – Rear View Drawing 

Description 

 
 
First drive bay (top) 
The first drive bay is standard. 

Drive bays are added from the 
top, down. 

Second drive bay 
 
 
 
 
 

Third drive bay 
 
 
 

Fourth drive bay 
 
 
 

AC Power distribution units (up 
to two) 

■ PDU 3 and PDU 4 

Drive DC power supplies (up to 
eight) 

■ DCPS 15 through 22 
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Cartridge Expansion Module 
The optional Cartridge Expansion Module (CEM) provides additional storage cell 
capacity and growth. No tape drives are in this module. A maximum of eight CEMs are 
supported in a single library.

The following considerations will maximize library efficiency: 

■ As a best practice, CEMs should be alternated on either side of the Base Module 
and optional DEM, with the initial CEM installed directly to the right of the Base 
Module. This decreases the amount of robotics travel and provides the best use 
of cartridge storage cells. 

■ If redundant TallBots are installed, the two outside CEMs are converted to parking 
extension modules (PEMs). This provides areas for theTallBots to get out of the way 
of one another. 

Each CEM adds up to 620 data cartridge physical storage cells. The capacity varies 
depending on the direction of growth (left or right) and the presence of a CAP. 

See FIGURE B-3, “Cartridge Expansion Module Walls” on page 492 for a detailed 
diagram of the wall layout. 

FIGURE 1-7 Cartridge Expansion Module with Base Module 

         Base Module     |               CEM

Configuration  
(next to Base with 24 drives) Capacity 

CEM (expanded left) 
CEM with optional CAP (left) See TABLE 1-1 

on page 6 
CEM (expanded right) 
CEM with optional CAP (right) 

Dimensions Measurement

Height 197 cm (77.625 in.) to 
200 cm (78.63 in.) fully adjusted 

Width 76.75 cm (30.22 in.) without 
covers1

Cover adds 7.62 cm (3 in.) 

Depth 80 cm (31.5 in.) 

Weight 175 kg (385 lb) frame only

Side clearance2 Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.) 

Service clearance, 
front and rear 

None required 

Notes: 
1. When additional modules are installed, the covers 

are removed from the Base Module and replaced on 
the ends of the last module in the string. 

2. Required to install or remove the sides covers; they 
swing out and lift off of brackets. 
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Parking Expansion Module 
The optional Parking Expansion Modules (PEMs) provide additional storage cell 
capacity and growth, as well as space for defective TallBots to be “parked” for service. 
The parking space makes the three outer-most columns of storage cells on the front and 
rear walls inaccessible. The inaccessible cells can be left out of the module, or they can 
be installed to allow later conversion of the PEM to a CEM. PEMs do not include tape 
drives. 

PEMs are only used with redundant TallBots, and they are always installed in pairs. 
They must be the last modules on the right and left sides of the library string. 

Note – AEMs and PEMs cannot be installed in the same library. 

See FIGURE B-4, “Parking Expansion Module Walls” on page 494 for a detailed 
diagram of the wall layout. 

FIGURE 1-8 Parking Expansion Module 

Configuration Capacity 

PEM (expanded left) 308 cells
PEM (expanded right) 312 cells 
CAP –78 cells
Installed in pairs for the redundant TallBot 
feature. 

See TABLE 1-1 
on page 6 

Dimensions1 Measurement

Height: 197 cm (77.625 in.) to 
200 cm (78.63 in.) fully adjusted 

Width: 76.75 cm (30.22 in.) without covers
77.5 cm (30.5 in.) with covers2

Depth: 80 cm (31.5 in.) 

Weight: 103.4 kg (277 lb) frame only

Side clearance Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.)3

Service clearance 
front and rear 

None required

Notes: 
1. The dimensions of the PEM are the same as the cartridge 

expansion module. 
2. When additional modules are installed, the covers are 

removed from the Base Module and replaced on the ends of 
the last module in the string. 

3. Required to install or remove the sides covers; they swing out 
and lift off of brackets. 
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Access Expansion Module 
The optional Access Expansion Module (AEM) provides the following capabilities: 

■ Bulk loading and unloading of up to 234 cartridges at a time to and from the SL3000 
library through the AEM CAP. The AEM is essentially a very large CAP, with all the 
characteristics of a CAP, such as online/offline state, ability to be shared by 
partitions, etc. The cartridge slots in the AEM cannot be used for long-term cartridge 
storage. 

■ Non-disruptive robot maintenance through the use of a safety door (or “garage” 
door), which sections off a defective robot from the other library modules. A Sun 
service representative can safely access the disabled robot through the AEM access 
door while the library remains online. If redundant robots are installed, the library 
can continue normal operations through the remaining functional robot. 

The library can include one or two AEMs. The AEM must be installed at the very end 
of the library string. If the library includes redundant robots, then two AEMs must be 
installed, one on each end of the library.

Note – AEMs and PEMs cannot be installed in the same library. 

AEMs do not include tape drives. 

See “AEM Operations” on page 73 for additional details about AEM functions and 
usage. 
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FIGURE 1-9 Access Expansion Module 

Configuration Capacity 

AEM (expanded left) 234 CAP cells
AEM (expanded right) 234 CAP cells 
Installed in pairs for the redundant TallBot 
feature. 

See TABLE 1-1 
on page 6 

Dimensions Measurement

Height: 197 cm (77.625 in.) to 
200 cm (78.63 in.) fully adjusted 

Width: 91.5 cm (36.0 in.) without covers
96.5 cm (38.0 in.) with covers1

Depth: 80 cm (31.5 in.) 

Weight: 204.12 kg (450 lb.)

Side clearance Cooling: 5 cm (2 in.) 
Installation: 91 cm (36 in.)2

Service clearance Front: 58.7 cm (23.1 in.)
Rear: Need access for Ethernet; there is 
no cover. 

Notes: 
1. When additional modules are installed, the covers are 

removed from the Base Module and replaced on the ends of 
the last module in the string. 

2. Required to install or remove the side covers; they swing out 
and lift off of brackets. 
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Tape Drives 
See TABLE 1-2 for the tape drives, data path interfaces, and media types supported 
by the SL3000 library. 

You can install up to 56 drives within one library, as follows:

■ Up to 24 in the Base Module

■ Up to 32 in a DEM 

The actual number of drives varies, depending on the AC power option and the 
media types. See TABLE 1-3 for details. 

TABLE 1-2 Supported Tape Drives 

Vendor Drive Type Interface Type Media

Sun 
StorageTek1

T9840C 
T9840D (encryption 
capable) 

Fibre Channel
FICON
ESCON

9840 
VolSafe capable

Sun StorageTek T10000A, T10000B 
(encryption capable) 

2 Gb/4 Gb  
Fibre Channel 
FICON

T10000 Standard, Sport, 
and VolSafe 

HP LTO 3 
LTO 4 (encryption 
capable) 

Fibre Channel LTO 3
LTO 4 
WORM (LT) 
LTO 2 (read-only)4

IBM LTO 3 
LTO 4 

Fibre Channel LTO 3 
LTO 4 
WORM (LT) 
LTO 2 (read-only)2

Notes:
1. Sun StorageTek T9840 drives, models A & B, and T9940 drives, models A & B, are not 

supported.
2. LTO 2 media is supported for backward compatibility of LTO products (data migration).

TABLE 1-3 Power Options and Number of Drives

110–127 PDU 220–240 PDU

Base Module DEM Base Module DEM

T9840 12 14 24 32

T10000 13 16 24 32

LTO 3, 4 24 32 24 32

Mixed media varies any intermix
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Drive Trays 
In the SL3000, a single, universal drive tray accommodates all types of tape drives and 
interfaces. The SL3000 drive trays have two layers, as follows: 

■ The power supply and connections are on the top. 

■ The tape drive is under the power supply. 

Each drive tray slides into an eight-drive bay. 

Internal power supply cards and cabling are unique, depending on the drive type and 
interface within the drive tray. Cabling to the drive itself is out of the rear of the drive 
tray and library, then routed through the strain relief system. Both floor and ceiling 
cabling access is allowed. 

FIGURE 1-10 Drive Tray 

Measurements 

Height:  16.5 cm (6.5 in.)

Width:   16.5 cm (6.5 in.)

Depth:  45 cm (18.5 in.)
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Cartridge Access Ports 
The cartridge access port (CAP) is a vertically-mounted, rotating cylinder with two 
removable 13-slot magazines (26 cells total). CAPs are used to enter or eject 
cartridges from the library. 

The Base Module comes with one CAP as a standard feature. Optionally, one CAP can 
be installed in each expansion module, up to a maximum of ten CAPs for the library. 

Each CAP has its own set of controls, consisting of a small keypad and indicators. The 
CAP and its magazines rotate as a single unit. 

See “CAP Operations” on page 69 for details about using CAPs. 

FIGURE 1-11 Cartridge Access Port

1. Cartridge access ports 
2. Blank covers 

When a CAP is not installed, a blank cover is installed. This can always be upgraded in the future to include 
a CAP. 

3. Keypad and indicator user interface. 

1 2 1 2

3
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Robotics Units 
The robotics unit in an SL3000 library is called a TallBot. Each library can have either 
one (standard) or two (redundant) TallBots. 

TallBots are responsible for the movement and cataloging – or audit – of cartridges 
throughout the library. 

TallBot measurements are:

■ Width: 30 cm (11.84 in.)

■ Depth: 39 cm (15.36 in.)

■ Weight: 8.6 kg (19 lb)

FIGURE 1-12 TallBot 
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TallBots are driven along two rails on the rear wall of the library – one rail at the top 
and one attached to the floor. 

Two copper strips are inserted into the top rail to provide both power and signal paths 
for TallBot operation. 

■ Power comes from +48 VDC, 1200 Watt, load-sharing power supplies. 

■ Signals are received and transmitted between the TallBots and the library controller. 

■ A Rail Power Enable module is installed as a safety circuit for rail power.

Handling of the cartridges by the TallBots include: 

■ Retrieving cartridges from a CAP

■ Inserting cartridges into a CAP

■ Inserting and retrieving cartridges to and from storage cells 

■ Mounts and dismounts of cartridges to and from tape drives 

TallBots contain a laser bar code scanner that: 

■ Reads the configuration blocks in each module during library initialization. See 
FIGURE B-6 “Configuration Block” on page 496 for an example. 

■ Targets on cartridge storage/CAP cells and tape drives. Targets have the following 
shape, similar to the letter “N”: 

|\|

■ Identifies volume IDs (VOLIDs) of cartridges during: 

■ CAP entries

■ Audits

The TallBot reads cartridge VOLIDs during audits and CAP enters only. Each 
cartridge’s assigned location is stored in the library controller database, and the 
TallBot uses that location to retrieve the cartridge. 

Redundant (Dual) TallBots 
Redundant TallBots are offered as a high availability option. This affords:

■ A speed increase for library operations

■ A backup TallBot in case one should fail

This option requires PEMs at each end of the library. A defective TallBot will take itself 
offline and may move, or can be pushed, into one of the PEMs, allowing the library to 
continue operations with one TallBot until time can be scheduled to replace the 
defective TallBot. 

The requirements for redundant TallBot operation are:

■ A 240 VAC, 2N power configuration 

■ PEMs on each end of the library 

■ Dual TallBot license 
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Power Options 

AC Power Configurations 
The following AC power source options are available:

■ Limited features: 110 VAC, 50/60 Hz, at 20 Amps (range: 100–127 VAC, 50–60 Hz, 
16 Amps) 

■ Full features: 220 VAC, 50/60 Hz, at 30 Amps (range: 200–240 VAC, 50–60 Hz, 
24 Amps) 

Power Distribution Units (PDUs) are located at the rear of the Base Module and 
optional DEM. 

Power Redundancy
The SL3000 provides full redundancy for tape drives, robotics units, and electronics. 
The following redundancy options are available: 

■ N+1 – One AC PDU, with one extra DC power supply for DC power redundancy. 
This is the standard power configuration for the SL3000. This configuration requires 
at least a 20 Amp circuit breaker at the customer’s branch service panel. 

■ 2N – Two PDUs for AC redundancy; each PDU has a set of DC power supplies 
(N DC power supplies). This configuration requires a second, separate customer 
power source. 

■ 2N+1 – Two PDUs for AC redundancy; each PDU has extra DC power supplies for 
N+1 redundancy for each PDU. The second PDU does not have N+1 for the TallBot. 

DC Power  
Load sharing 1200 Watt DC power supplies are required for distribution of +48 VDC 
for TallBot and tape drive operation. The number of DC power supplies required 
depends on the power configuration and total number of drives in the library. 

A Rail Power Enable module is also installed as a safety circuit for rail power. Two 
cPCI power supplies (200 Watts each) distribute power to the Electronics Control 
Module. These power supplies are located below the HBT card – two on the left for 
N+1, or one on each side for 2N. 
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Cooling 
Cooling within the SL3000 is divided into three areas: 

■ Library electronics 

■ Tape drives 

■ DC power supplies 

Library Electronics 
There are two fans located to the right of the electronics control module that provide 
cooling for the electronics in the library. Air is drawn from the floor and sides of the 
library and flows through the fans to the rear of the library. 

■ These fans are monitored by the HBC card for proper operation. 

■ An amber Fault indicator is on the fan assembly to indicate a failure. 

While there are two dedicated fans, one fan is sufficient to provide adequate cooling for 
the library/electronics. Nevertheless, since the fans can be replaced without interfering 
with library operations, it is best to replace a defective fan when it is detected. 

Tape Drives
Each tape drive tray contains one or two fans for drive cooling. 

Power for the fans is supplied through the tape drives power converter card. Air is 
drawn from the front of the drive and flows through the fan to the rear of the 
drive/library. 

DC Power Supplies
Each 1200 Watt DC power supply contains a fan that pulls air from the front of the 
library, through the rear of the supply, and out the rear of the library. 
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Interfaces 
The SL3000 library supports the following types of interfaces: 
■ Library Control Path – Transfers library management commands, such as cartridge 

mounts and dismounts, between the host and the library components. No host data 
is present on this interface. 

■ Data Path – Transfers data between the host and the tape drives. 

■ Command Line Interface – Allows a Sun support representative to configure and 
diagnose the library.

■ SNMP – Allows system administrators to query the library and receive information 
about potential problems. 

■ SL Console – Allows library operators and administrators to configure and manage 
the library from a graphical user interface. 

Library Control Path 

Note – When a new library is integrated into a network, it is strongly recommended 
that the system/network administrator work closely with a Sun StorageTek 
representative to define the configuration. 

The control path provides for the transfer of library management commands between 
the host and the library. The SL3000 supports the following host connection types 
for the control path: 
■ TCP/IP Interface – TCP/IP protocol using Ethernet 10/100 Base-T and CAT-5 cables 

■ FC-SCSI Interface – Small Computer System Interface (SCSI) protocol and command 
set over a physical Fibre Channel interface 

A non-partitioned library can use only one interface type – either FC-SCSI or TCP/IP. 
Using the optional Partitioning feature, a library can connect to multiple hosts over a 
combination of the two interface types. See Chapter 6, “Library Partitioning” on page 
247 for details. 

Library addressing depends on the host connection type: 
■ TCP/IP hosts use a panel, row, column (PRC) numbering scheme. 
■ FC-SCSI hosts use a sequential element numbering scheme, with each element 

type (storage cells, tape drives, and CAPs) having its own sequential range. 

See Appendix A, “Library Resource Addresses” on page 471 for full details. 

TCP/IP Interface
The TCP/IP interface type uses the TCP/IP protocol over an Ethernet physical 
interface, (CAT-5, Ethernet, 10/100 BaseT cable). This interface enables either of the 
following host platforms to connect to and communicate with the library: 
■ Open system platforms with ACSLS (see “Automated Cartridge System Library 

Software (ACSLS)” on page 29 for details). 
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■ Enterprise-level mainframes with HSC (see “Host Software Component” on page 28 
for details). 

The library controller coordinates all component operations within the library and 
provides the interface connection with the host. 

Connections

There are two separate Ethernet connections on the library controller card for host-
to-library communications. 
■ Port 2A provides the Dual TCP/IP connection – this is an optional, licensed 

feature that provides built-in redundancy. 
■ Port 2B provides the primary host connection – this is the standard connection 

for SL3000 libraries.

Both ports comply with the Institute of Electrical and Electronics Engineers 
standard–IEEE 802.3–for Ethernet networks. Both ports are capable of auto-
negotiating the following functions: 
■ Method of transmission   

■ Half-duplex: Transmits data in just one direction at a time 

■ Full-duplex: Transmits data in two directions simultaneously 

■ Speed of the transmission 

■ 10Base-T: 10 megabits per second (Mbps)

■ 100Base-T: 100 megabits per second (Mbps)   

Network

Because the SL3000 is installed on a network, it is preferable that library activity be 
isolated from regular network traffic. Therefore, the following distinct networks are 
present: 

■ Public network – handling all customer-attached networking for the public system 
controller ports, such as:

■ Internet access 

■ Library-to-host commands 

■ Private network – handling all internal library networking for the private system 
controller ports, such as:

■ CAPs

■ Drive control path 

■ Local operator panel 

Note – A private network connection between the library and host management 
software, using an Ethernet hub or switch, is recommended for maximum throughput 
and minimum resource contention. 

If a shared network is required, these actions can help with the communication 
between the host and the library: 

■ Directly connect the library to a switch. 

■ Place the library on its own subnet. 
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■ Use a managed switch that can:

■ Set priorities on ports to give the host and library higher priority.

■ Provide dedicated bandwidth between the host and the library.

■ Create a VLAN between the host and the library. 

■ Use a virtual private network (VPN) to insulate host-to-library traffic. 

Sun StorageTek’s 9300 Control Path Adapter provides the hardware connection for 
mainframe hosts. This interface adapter is installed on the mainframe and converts data 
on the Ethernet network to compatible Host Library Interface (HLI) commands. 

FC-SCSI Interface
The FC-SCSI interface type uses the SCSI command set over a physical Fibre 
Channel connection. The Sun StorageTek implementation of Fibre Channel 
conforms to the following standards: 
■ American National Standards Institute (ANSI) 

■ National Committee for Information Technology Standards (NCITS) 

Applications supporting the SCSI-3 protocol are required for FC-SCSI hosts. 

The recommended Fibre Channel topology for the SL3000 is switched fabric. A 
switched fabric provides dynamic interconnections between nodes, and multiple, 
simultaneous Fibre Channel connections for the network.

If the SL3000 is connected to a Fibre Channel switch or fabric-capable host, it 
automatically configures itself as a switched topology and can support up to 16 million 
ports logged into the fabric. 

See the SL3000 Interface Reference Manual (PN 3161952xx) for complete information. 
This manual contains information about the SCSI command set, plus information 
about Fibre Channel operations, command implementations, topologies, cables, 
and connectors. 

Note – While the SL3000 supports the arbitrated loop topology, this topology is 
not recommended.

Note – The SL3000 does not support forcing arbitrated loop connection by setting Hard 
ALPAs (Arbitrated Loop Physical Addresses). 

Data Path
The data path, which is separate and distinct from the library control path supports the 
transfer of data between the host and the tape drive. Host data paths to the tape drives 
can be Fibre Channel, FICON, or ESCON, depending on the operational characteristics 
of the drive type. See “Tape Drives” on page 17 for details. 
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Command Line Interface 
The SL3000 command line interface (CLI) is a library interface for trained and 
qualified Sun support representatives only. This interface allows support 
representative to configure and diagnose problems with the library. 

Note – Customers do not have access to the CLI interface. 

SNMP
Simple Network Management Protocol (SNMP) allows system administrators and 
network managers to monitor and receive library status information, including the 
following: 

■ Operational state of the library (such as microcode level, serial number, 
online/offline status)

■ Status of the CAPs (such as open, closed, number of cells)

■ Library elements (number of TallBots, storage cells, CAPs) 

■ Number of storage cells and media types in the library 

■ Number and types of tape drives installed in the library

Note – By default, the SNMP agent is turned off and must be activated by your Sun 
support representative through the command line interface (CLI). 

The SL3000 supports the following SNMP versions: 

■ SNMPv2c – For machine status queries; the information transmitted is not secure.

■ SNMPv3 – For Sun Confidential: Internal Use Only information, since it supports 
encryption and strong user identification. SNMPv3, therefore, is the preferred 
protocol for proprietary data.

Note – See the SL3000 SNMP Guide (PN 3161945xx) for detailed information 
concerning SNMP and the setup procedures.

SL Console
The StorageTek Library Console (SL Console) is a Java-based software application that 
provides a graphical user interface (GUI) for monitoring and managing the StorageTek 
SL3000 library. See Chapter 2, “StorageTek Library Console” on page 33 for complete 
details. 
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Library Management Software
Library management software components control the library to perform activities such 
as mounts and dismounts, enters and ejects. They also manage their own cartridge 
databases, containing volume location and attribute information. 

Sun offers several software components depending on the platform, connection type, 
and operating system. These include the following: 

■ ACSLS

■ HSC (MVS) – using a TCP/IP interface only

■ Direct-attach SCSI – using a Fibre Channel interface only

■ ExLM 

■ ExHPDM 

■ ExPR

■ VSM 

■ VTL 

Note – See the appropriate library management software documentation for the 
version levels required to support the SL3000. 

Note – LibraryStation is not supported for the SL3000. 

Nearline Control Solutions
The SL3000 supports the following Sun Nearline Control Solutions (NCS) software 
products.

■ Host Software Component

■ Storage Management Component

■ Sun StorageTek HTTP Server

Host Software Component 
When an SL3000 library is connected to an MVS host, the host must run a version of 
Sun StorageTek’s Host Software Component (HSC) along with the Storage 
Management Component (SMC).

Together, Sun StorageTek’s HSC and SMC perform the following functions:

■ Influence allocations

■ Intercept mount and dismount messages

■ Receive host requests and translate them into library control commands

HSC resides within the MVS host, but is invisible to the actual operating system.
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Storage Management Component
Storage Management Component (SMC) is the interface between IBM’s OS/390 and 
z/OS operating systems and a Sun StorageTek library. SMC performs the allocation 
processing, message handling, and SMS processing for the NCS solution. SMC resides 
on the MVS host system with HSC, or on a remote system using the Sun StorageTek 
HTTP server to communicate with the HSC. SMC communicates with HSC to 
determine policies, volume locations, and drive ownership.

Note – SMC is a required NCS component.

Sun StorageTek HTTP Server
Sun StorageTek’s HTTP Server for OS/390 and z/OS optionally provides the 
middleware to allow communication between the SMC (client) and a remote HSC 
subsystem (server). The HTTP server executes as a separate subsystem on the MVS host 
where the remote HSC subsystem resides. 

Automated Cartridge System Library Software 
(ACSLS)
The ACSLS software manages library contents and controls library hardware for the 
mounting and dismounting of cartridges. 

ACSLS provides library management services, such as cartridge tracking, pooling, 
reports, and library control. It maintains a database that tracks data volume names and 
their current locations in the libraries. 
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Operating Modes
Four modes of operation are possible for the SL3000:

■ Automated Mode 

■ Manual Mode

■ Maintenance Mode

■ Degraded Mode

Automated Mode 
When in automated mode of operation, the library automatically mounts and 
dismounts cartridges without physical intervention by a person.

Automated operations include the following activities:

■ Mounting and dismounting cartridges
■ Entering and ejecting cartridges through the CAP
■ Logging library events
■ Drive cleaning 

See Chapter 3, “SL3000 Automated Library Operations” on page 63 for complete 
details. 

Manual Mode
Manual mode of operation occurs when the library is unavailable for system use and 
human intervention is required. An example of this situation would be when a library 
experiences an unrecoverable error, making automated mounts and dismounts 
impossible.

Another example would be where a library component cannot perform a mount to a 
drive for a particularly important job request. In this case, the library may require a 
person to enter a library, locate the cartridge, and manually mount it into the requested 
drive. 

Warning – Possible Physical Injury.  Anyone entering the library must be 
advised of the safety procedures required of them. 

See Chapter 8, “Manual Operations” on page 455 for complete details. 

Maintenance Mode
In the case of a failure in a non-redundant library component (for example, a single 
TallBot for the entire library), the library is said to be “unavailable” to the system. In 
this case, the entire library must be placed offline until the repair is accomplished.
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After the defective component has been repaired or replaced, the library can be placed 
in maintenance mode while verification tests are performed. 

Degraded Mode
When in degraded mode, the library is still operational and online, but its operational 
efficiency is degraded due to a failing component. Examples of degraded mode are: 

■ In a redundant TallBot configuration, one TallBot has failed; the other TallBot has 
assumed all mount and dismount operations for the entire library.

■ A single tape drive has experienced a failure and must be replaced.
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StorageTek Library Console 

Introduction 
The StorageTek Library Console (SL Console) is a Java-based software application that 
provides a graphical user interface (GUI) for monitoring and managing the StorageTek 
library. 

Following are some of the activities you can perform with the SL Console:

■ Manage available library storage capacity

■ Manage and configure library partitions (optional feature)

■ View and modify status and properties of the library and associated devices (drives, 
CAP, robots, and elevators)

■ Perform an audit on all or part of the library

■ Perform a self-test on the library or an associated device

■ Perform a diagnostic move (exercise a robot)

■ Locate a cartridge

■ Move a cartridge from one location to another

■ Display library logs

■ Display library status event messages

■ Display error explanations 

■ Download new library firmware while the library is in operation

■ Display context-sensitive help 

SL Console Modes
Depending on your needs, you can run the SL Console in any of the following modes. 
For details and procedures, see: 

■ “Local Operator Panel” on page 40 

■ “Standalone SL Console” on page 42

■ “Web-launched SL Console” on page 49 
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SL Console Security 
Security features built into the SL Console control both user authentication and user 
authorization. The security features include:

■ User IDs – User IDs control user authentication. Each user must have a valid, active 
user ID and password to log in to the SL Console.

■ Access permissions – Access permissions control user authorization. Each user ID is 
assigned a set of access permissions, which determine the types of requests the user 
can submit through the SL Console. For example, in order to modify the system 
properties of a drive, a user must log in with a user ID that has the proper access 
permissions.

When you log in to the SL Console with a valid user ID, password, and library name, 
the system authenticates your identity and then authorizes your access to the various 
SL Console functions. 

User IDs
To log in to the SL Console, you must have a valid, active user ID. Each user ID must be 
assigned a password.

There are a fixed set of user IDs at a site. The user IDs include admin (customer 
administrator), service (Sun Customer Services Engineer), and oem (third-party field 
service technician). When you log in successfully, the SL Console displays your user ID 
in the status bar of the screen.

Only one user at a time can be logged in to the local operator panel, but any number of 
users can connect to a library through the standalone SL Console or Web-launched 
SL Console. 

Activation Password 
Before any users at your site can use the SL Console for the first time, your library 
administrator must activate the “admin” userid with a special activation password. 
Your Sun support representative provides your administrator with the activation 
password, which is valid for one-time use only. 

After logging in with the activation password, the administrator must change the 
admin user ID password to ensure system security. 

For details about this process, see the appropriate library Installation Guide. 
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SL Console Usage Tasks
■ Log in to the SL Console

■ The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the 
library has fully initialized. You may see warnings that configuration data is not yet 
available, in which case you need to exit and log in again at a later time. 
Additionally, if an audit is performed as part of initialization, until the audit is 
complete, any configuration data displayed may not be completely up-to-date and 
accurate.

■ Change a User Password

▼ Log in to the SL Console
Login procedures depend on the SL Console mode being used. For detailed 
instructions, see the following topics:

■ “Log in to the Local Operator Panel” on page 41

■ “Log in to the Standalone SL Console” on page 48

■ “Log in to the Web-launched SL Console Using a Browser or Command Line” on 
page 50

■ “Log in to the Web-launched SL Console Using an Icon” on page 56

Note – The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet available, 
in which case you need to exit and log in again at a later time. Additionally, if an audit 
is performed as part of initialization, until the audit is complete, any configuration data 
displayed may not be completely up-to-date and accurate. 

▼ Log Off the SL Console

Note – Before you log off, make sure all operations for the current SL Console session 
have completed (for example, code loads, audits, diagnostic moves). 

1. From any SL Console screen, select Tools > Log Off.

2. In the Confirm popup, do one of the following:

■ Click Cancel to remain logged in to the SL Console.

■ Click OK to terminate the current SL Console session. 

The Login screen appears. 

3. Click Exit to close the SL Console.
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▼ Change a User Password 
1. Select Tools > User Mgmt.

2. On the User tree, expand the Permanent folder. 

3. Click the user account you want to modify. 

4. Complete the following fields: Current Password, New Password, and 
Retype Password. 

5. Click Modify.
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SL Console Screen Display 
The following figure and table explain the components of the SL Console screen. 

Component Name Description

1 Menu bar – includes the 
Tools Menu and the 
Help Menu 

Tools menu provides access to System Detail, Reports, 
Monitors, Utilities, Partitioning, User Management, and 
Log off functions. 
Help menu provides access to the table of contents of the help 
system. It also identifies the version of the SL Console in use.

2 Title bar Displays the title of the current screen. 

3 Function tabs Identifies the available functions for a screen. 

4 Options bar Location of buttons related to the screen (for example, Apply, 
Refresh, Print). Always includes the SL Console Help button 
(?). See “Synchronizing the Display With the Controller 
Database” on page 38 for details on using the Apply and 
Refresh buttons. 

1 2 43

5

78 6

9
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Synchronizing the Display With the Controller 
Database
When you first bring up an SL Console screen, the display reflects the most recently 
saved data from the library controller database. If you use the screen to modify the 
library contents or configuration, your changes do not update the controller database 
until you commit your changes by clicking the Apply button. Multiple users can access 
the library at the same time, using the SL Console, command line interface, and various 
host applications to make their own changes to the library contents and configuration. 
If other users make changes and apply them to the controller database, you will not see 
these changes until you click Apply or Refresh on your screen. Therefore, the display 
you see on the SL Console may not reflect the actual saved library configuration at a 
given point in time.

For these reasons, if you are making major modifications to the library configuration –
 adding modules, defining partitions, etc. – it is important that you coordinate these 
changes with other library users. Failure to do so could result in conflicts within the 
controller database. 

5 Work area Location of the screen data. 

6 Library health indicator Identifies the library to which the SL Console is connected, 
and displays a graphical representation of the library health. 

7 UserID indicator Displays the user ID currently logged in to the SL Console.

8 Server communication 
health indicator

Displays a graphical heartbeat monitor indicating the state of 
server communication health.

9 Device tree Lists the devices included in the library.

Component Name Description
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Modifying the Screen Layout 

Note – This feature is available starting with SL Console version FRS_3.30. It is 
available on selected screens only. 

You can modify the layout and display of selected SL Console screens as follows. 

Display Option Instructions

Sort the display by any 
column

Click the heading of the column you want to sort by. 
Initially the sort will be in ascending order. Click the 
heading again to switch between ascending and descending 
order.

Arrange the columns 
in any order

Click and drag a column heading horizontally to any 
position in the heading row. 

Resize the columns Click the border of the column heading and drag it left or 
right to change the column width. 
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Local Operator Panel 
The local operator panel is an optional feature of the library, which is built in to the 
Base Module on the SL500 and SL3000. It enables you to run most of the SL Console 
application directly at the library from a flat-screen display with a touch-screen 
interface. 

The local operator panel has the following features:

■ Flat-panel display, resident within the library (12.1-inch on the SL3000 and SL8500, ) 

■ Touch-screen interface, allowing alphanumeric data entry; pen and stylus available 

■ No keyboard or mouse option

LEDs located directly below the local operator panel provide the following status 
information:

■ LIB ACTIVE – Library processor is working. 

■ WAIT – Library firmware is loading. 

■ SVC REQ – Library is rebooting. 

▼ Enter Data Using the Keypad 
1. Click on the keyboard icon associated with the desired field.

A popup containing a graphical keyboard and display area appears. 

2. Click the graphical keys necessary to enter the desired data.

3. Click Enter to save your entry. 

The popup is closed and the data is displayed in the associated field.

▼ Modify Data Using the Keypad 
1. Use the navigational keys to position the cursor next to the characters to be modified.

The existing text remains on the display, but is changed to normal text.

2. Click the navigational, editing, and text keys to make the desired changes.

3. Click Enter to save the changes or Cancel to restore the original text to the field. 
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▼ Log in to the Local Operator Panel 

Note – Only one user at a time can log in to the local operator panel. 

Note – If the touch-screen panel is blank, touch the screen anywhere to activate the 
Login screen. 

1. Use the keypad to enter your login information (see “Enter Data Using the Keypad” 
on page 40 for detailed instructions). 

User ID: SLC_login  
Password: password 

where:

■ SLC_login is the SL Console user ID.

■ password is the password assigned to this user ID. 

Note – The user ID you use determines the screens you can access. See “SL Console 
Security” on page 34. 

2. Click Log on. 
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Standalone SL Console 
The standalone SL Console is a standard feature of the StorageTek library. It enables 
you to run the SL Console application remotely from a PC or workstation that has a 
network connection to the library. Using the standalone SL Console you can connect to 
any library for which you have a valid user ID. 

Security Considerations
The SL Console application interfaces with the primary library interface (PLI) over a 
security software layer (SSL). The SSL provides a secure communication path between 
the library and the customer’s operator panel; this prevents an unauthorized network 
user from monitoring library activity.

Installation Requirements
You can install the standalone SL Console on a computer meeting the following 
requirements:  

The standalone SL Console software is available for download at the following Sun 
Microsystems, Inc. sites:

Note – You must have a valid login ID and password for the download site you are 
using. Contact your Sun support representative for assistance. 

Platform Solaris 9 – SPARC
Solaris 10 – SPARC
Windows 2003 Server – 32 bit
Windows XP Client – 32 bit
Windows Vista – 32 bit

Other Ethernet connection to the library

User Location Name URL

Sun Customers Sun Download Center http://www.sun.com/download/ind
ex.jsp

Sun Partners 
and OEMs

Sun Partner Exchange https://spe.sun.com/spx/control
/Login 
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Standalone SL Console Installation

Note – Your StorageTek CSE may have performed these procedures for you during 
library installation.

To install the standalone SL Console on your PC or workstation, you must use the 
following procedures:

1. “Download and Initiate the Standalone SL Console Installer from the Sun Download 
Site” on page 43. 

2. “Install the Standalone SL Console” on page 43. 

▼ Download and Initiate the Standalone SL Console Installer 
from the Sun Download Site
Use this procedure to download the standalone SL Console installer program and 
initiate it on your PC or workstation. 

Note – You must have a valid login ID and password for the download site you are 
using. Contact your Sun support representative for assistance. 

1. Start a Web browser on your PC or workstation. 

2. In the Address or Location Bar, enter the URL of the appropriate Sun download site. 
See“Installation Requirements” on page 42 for details. 

3. Log in to the Sun download site using your assigned login ID and password.

4. Navigate to the standalone SL Console installer file. 

5. Select the SL Console code level you want.

6. Select the appropriate installer file for your platform:

■ Microsoft Windows: SLConsoleWindowsSTK.exe 

■ Sun Solaris: SLConsoleSolarisSTK.bin 

7. Save the file to your PC or workstation. 

8. Double-click the SL Console installer file icon on your PC or workstation to start the 
installation. 

9. To complete the installation, see “Install the Standalone SL Console” on page 43. 

▼ Install the Standalone SL Console 
Use this procedure to install the standalone SL Console on your PC or workstation. 
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1. Start the installer program according to the instructions in “Download and Initiate the 
Standalone SL Console Installer from the Sun Download Site” on page 43. 

The License Agreement screen appears. 

2. Review the information, and click I accept. 

The Introduction screen appears.
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3. Review the information, and click Next. 

The Choose Install Folder screen appears. 

4. Enter the location where you want to install the file, and click Next.

The Choose Shortcut Folder screen appears. 

5. Enter the location where you want to create the shortcut icon, and click Next. 
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Note – On Solaris, the default location for shortcuts is the user’s home directory. 
However, shortcuts cannot be created in /, which is the root user’s home, so if you are 
installing on a Solaris platform as root you must choose something other than the 
default location. In this case, it is recommended that you choose /usr/bin or a similar 
location. 

The Pre-Installation Summary screen appears.

6. Review the information, and click Install. 

The installation begins, and the Installing SL Console screen appears. 
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7. When the installation finishes, the Install Complete screen appears. 

8. Review the information and click Done to exit the installation program. 
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▼ Log in to the Standalone SL Console 

Note – Using the standalone SL Console you can connect to any library for which you 
have a valid user ID. 

1. Start the SL Console application on your PC or workstation by doing either of the 
following:

■ Double-click the SL Console icon on the desktop.

■ Select Start > RunSLConsole or Launch > RunSLConsole 

The SL Console starts and the Login screen appears. 

2. Enter your login information.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

■ SLC_login is the SL Console user ID.

■ password is the password assigned to this user ID. 

■ library_ID is the library to which you want to connect, expressed in either of the 
following ways:

■ IP address of the library, in dotted decimal notation (nnn.nnn.nnn.nnn) 

■ DNS alias of the library

Note – The user ID you use determines the screens you can access. See “SL Console 
Security” on page 34. 

3. Click Log on. 

Standalone SL Console Updates 

Note – Before you can install a new version of the standalone SL Console, you must 
uninstall the previous version. See your PC or workstation documentation for detailed 
instructions. Running multiple versions of the SL Console on the same PC or 
workstation can cause problems such as inconsistent data on reports. 

Once you have uninstalled the previous version of the SL Console, see “Standalone 
SL Console Installation” on page 43 for detailed instructions on upgrading the software. 
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Web-launched SL Console
The Web-launched SL Console is a standard feature of the library. It enables the 
SL Console to be installed on a centralized Web server. Individual clients can then use 
a supported Web browser to download the Web-launched SL Console. Using the Web-
launched SL Console you can connect to any library for which you have a valid user ID.

The Web-launched SL Console is delivered to clients as a Java Web Start process, which 
executes outside the browser. 

Security Considerations
The Web-launched SL Console software is digitally signed, which guarantees that it has 
been issued by Sun Microsystems, Inc. and has not been altered or corrupted since it 
was created. As a Java Web Start process, the Web-launched SL Console includes the 
security features provided by the Java 2 platform.

The customer is responsible for implementing all appropriate additional security 
systems, including firewalls, user access, etc.

Client Requirements
You can download the Web-launched SL Console to clients meeting the following 
requirements:  

Web-launched SL Console Updates
Updates to the Web-launched SL Console only need to be installed on the centralized 
Web server. Once the updates are installed on the server, they are downloaded 
automatically to all clients whenever the application is started on the client. 

Platform Solaris 9 – SPARC (Firefox 2.x)
Solaris 10 – SPARC (Firefox 2.x)
Windows 2000 – 32 bit (IE 5, IE 5.5, Firefox 2.x)
Windows XP – 32 bit (IE 6, IE 7, Firefox 2.x)
Windows Vista – 32 bit (IE 7, Firefox 2.x)

Other ■ Java 1.5 Plug-in (the browser will install this 
automatically if it is not present already)

■ Ethernet connection to the library
■ Ethernet connection to the Web-launched SL Console 

server 
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Starting the Web-launched SL Console on a Client
You can use either of the following methods to start and log in to the Web-launched 
SL Console on a client: 

■ From a command line (Solaris only) or supported browser. See “Log in to the Web-
launched SL Console Using a Browser or Command Line” on page 50. 

■ By double-clicking the slc.jnlp icon on your client. In order to use this method 
from a client, you must use the browser method at least once and save the 
slc.jnlp file locally. See “Log in to the Web-launched SL Console Using an Icon” 
on page 56. 

▼ Log in to the Web-launched SL Console Using a 
Browser or Command Line 

Note – Before you perform this activity, you must obtain the DNS alias or IP address 
of the SL Console server. Depending on how your Web-launched SL Console server has 
been set up, it may be accessible only by IP address. See your library administrator for 
assistance. 

Note – The command line option is available on Solaris platforms only. 

On Windows 2000, you may need to install a Java plugin for your Web browser before 
performing this procedure. You can download the plugin from the following location: 
http://java.sun.com/products/archive/j2se/5.0_04/index.html 

On Solaris platforms, it is easier to log in to the Web-launched SL Console using the 
command line. If you prefer to log in using a Web browser, however, you need to 
download a recent version of the Firefox Web browser from the following location:  
www.mozilla.com

1. Choose your login method:

■ Command line – available on Solaris only. Proceed to Step 2. 

■ Web browser – available on either Windows or Solaris. Proceed to Step 3. 

2. Open a terminal window, and type the following command:

javaws http://server_ID/opel/slc.jnlp 

where:

■ server_ID is either of the following:

■ IP address of the SL Console server (in nnn.nnn.nnn.nnn format)

■ DNS alias of the SL Console server

■ opel is the name (context root) of the Web-launched SL Console application on the 
server. 

Proceed to Step 4. 
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3. Start a supported Web browser on your client PC or workstation (see “Client 
Requirements” on page 49 for a list of supported browsers), and in the Location Bar 
or Address field, enter the URL of the SL Console Web Start application: 

http://server_ID/opel

where:

■ server_ID is either of the following:

■ IP address of the SL Console server (in nnn.nnn.nnn.nnn format)

■ DNS alias of the SL Console server

■ opel is the name (context root) of the Web-launched SL Console application on the 
server. 

Note – You can bookmark this URL for future logins. 

4. The SL Console Launch screen appears. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates are downloaded automatically. 
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5. The Opening slc.jnlp popup appears. 

Complete the popup as follows:

a. Specify the action you want to take with the slc.jnlp file:

■ Click the Open with Java(TM) Web Start Launcher radio button if you want to 
start the SL Console directly. 

■ Click the Save to Disk radio button if you want to save the slc.jnlp file to your 
client and log in to the SL Console later. See “Log in to the Web-launched 
SL Console Using an Icon” on page 56 for login instructions. 

b. Optionally click the “Do this automatically for files like this from now on” 
checkbox. If you make this selection, this popup will not appear during future 
logins. 

c. Click OK. 
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6. If this is the first time you are running the Web-launched SL Console, a digital 
signature warning popup appears. 

Complete the popup as follows:

a. Verify the Publisher. 

b. Optionally click the “Always trust content from the publisher” checkbox. If you 
make this selection, this popup will not appear during future logins. 

c. Click Run.



 

Web-launched SL Console

54 SL3000 User’s Guide • May 2009 Revision AB • 316194401

7. If this is the first time you are running the Web-launched SL Console, the License 
Agreement popup appears. 

Scroll down to read the complete license agreement. Click, “I accept the terms of the 
License Agreement”, and then click OK.
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8. The SL Console Login screen appears. 

Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

■ SLC_login is the SL Console user ID.

■ password is the password assigned to this user ID. 

■ library_ID is the library to which you want to connect, expressed in either of the 
following ways:

■ IP address of the library, in dotted decimal notation (nnn.nnn.nnn.nnn) 

■ DNS alias of the library 
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▼ Log in to the Web-launched SL Console Using an 
Icon

Note – In order to perform this activity, you must first save the Web-launched 
SL Console slc.jnlp file to your client. See “Log in to the Web-launched SL Console 
Using a Browser or Command Line” on page 50 for details. 

1. Double-click the slc.jnlp desktop icon on your client. 

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates are downloaded automatically. 

■ IP address of the library, in dotted decimal notation (nnn.nnn.nnn.nnn) 

■ DNS alias of the library 
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2. The SL Console Launch screen appears. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates are downloaded automatically. 

3. If this is the first time you are running the Web-launched SL Console, a security 
warning popup appears. 

Complete the popup as follows:

a. Verify that the Publisher is Sun Microsystems, Inc. 
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b. Optionally click the “Always trust content from the publisher” checkbox. If you 
make this selection, this popup will not appear during future logins. 

c. Click Yes.

4. If this is the first time you are running the Web-launched SL Console, the License 
Agreement popup appears. 

Scroll down to read the complete license agreement. Click, “I accept the terms of the 
License Agreement”, and then click OK.
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5. The SL Console Login screen appears. 

Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

■ SLC_login is the SL Console user ID.

■ password is the password assigned to this user ID. 

■ library_ID is the library to which you want to connect, expressed in either of the 
following ways:

■ IP address of the library, in dotted decimal notation (nnn.nnn.nnn.nnn) 

■ DNS alias of the library 
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SL Console Help  
The SL Console Help displays information for library operators, system programmers, 
system administrators, and service representatives. 

Note – The information relates specifically to the SL Console only. For information 
about library hardware, tape drives, or host software, see the appropriate product 
publication.

Following is a sample SL Console Help screen. 

▼ Access the SL Console Help 
You can display the SL Console Help from any SL Console screen. Use either of the 
following methods: 

■ To display context-sensitive help for the current SL Console screen, click the ? button 
in the Options bar. 

■ To display general help information, click Help > Contents in the Menu bar. 

Help Navigation
The left panel of the SL Console Help screen displays either of the following:

■ Table of contents (TOC) – An outline of topics and subtopics

■ Index – A list of terms and topics, in alphabetical order

The right panel displays the Help topic itself. 
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The top of the SL Console Help screen includes the following navigation buttons. 

Tips for Using the SL Console Help
■ You can minimize, maximize, or resize the Help screen to accommodate your needs.

■ You can resize the left and right panels of the Help screen by clicking the border 
between them and dragging it left or right. 

■ Most topics include a Related Topics button at the bottom of the page. Click on this 
button to display and navigate to help topics containing related information. 

Button Action

 Back Retraces your steps, going backward one topic at a time. 

 Forward Retraces your steps, going forward one topic at a time. 

 Print Displays the Print popup, which allows you to print one or 
more topics:
■ To print the current topic, click the Print button.
■ To print a different topic, click the topic title in the 

SL Console Help table of contents, and click the Print button.
■ To print more than one topic, highlight the topics in the 

SL Console Help table of contents by pressing Shift-Click or 
Ctrl-Click, and then click the Print button. 

 Print Setup Displays the Page Setup popup, which allows you to modify 
your print page layout.

 TOC Displays the SL Console Help table of contents. 

 Index Displays the SL Console Help index. 
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SL3000 Automated Library 
Operations

Automated Mode of Operation
When in automated mode of operation, the library automatically mounts and 
dismounts cartridges without physical intervention by a person.

Automated operations include the following activities:

■ Mounting and dismounting cartridges

■ Entering and ejecting cartridges through a rotational or optional AEM CAP 

■ Logging library events

■ Drive cleaning 

Cartridge Mount and Dismount Activities
The primary function of the library is the automated mounting and dismounting of 
cartridges. Host mount and dismount commands are accepted by the library controller 
and translated into robotic commands that are performed by the TallBots. 

Mount Sequence
A simplified mount sequence involves the following steps:

1. A host requests that a specific volume serial number (VOLID) be mounted in a drive.

2. The library controller transmits to the host that the VOLID is located within the 
library and a drive is available to satisfy the mount request.

3. The library assumes responsibility for the mount.

4. The host command is translated by the library controller into motion commands for 
the TallBot.

5. The cartridge is taken from its storage cell and placed in the drive.

6. The library returns status to the host that the mount operation is completed.
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7. The drive performs the read/write activity directed by the host.

Dismount Sequence
A simplified dismount sequence involves the following steps:

1. A host requests that a specific VOLID be dismounted from a drive.

2. The library controller transmits to the host that the VOLID is located in the drive and 
the library is available to satisfy the dismount request.

3. The library assumes responsibility for the dismount.

4. The host command is translated by the library controller into mechanical commands 
for the TallBot.

5. The cartridge is taken from the drive and placed into its home cell.

6. The library returns status to the host that the dismount operation is completed.

Determining When the Library is Not in Automated 
Mode 
The library is not in automated mode when it is not able to accept host requests. The 
following conditions indicate that the library is not in automated mode:

■ A library main access door is open. 

■ The TallBot does not automatically mount and dismount cartridges. 

■ The device tree in the SL Console indicates that there is a problem with the library.
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Library and Device Status
The SL Console screen displays health indicators for each of the following devices:

■ Library 

■ Drives

■ Rotational and AEM CAPs 

■ Power supplies

■ Robots(s) 

■ AEM safety doors

21 3

4
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The following table describes the health monitor indicators. 

The library health indicator (3) also reflects status alerts, which are messages about 
significant issues with the library firmware or configuration status. These messages can 
be displayed and managed on the Status Module screen, if the Service license is active 
on the library. See “Status Alert Messages” on page 68 for details. 

If there are multiple problems with a device or status alert conditions, the health 
indicator reflects the one that is most severe. For example, if a license is due to expire 
(a “yellow” condition) and a CAP has experienced a failure (a “red” condition), the 
library health indicator will be red. Fixing the CAP problem will cause the library 
health indicator to change to yellow. The indicator will not return to green until the 
license issue has also been resolved or the alert message cleared manually. 

Communications Failures
If the SL Console loses communication with the library controller, after about 30–60 
seconds, the heartbeat monitor turns gray, then red, and the following error message 
appears:
Heartbeat message not received from the library controller.

You must log off from the SL Console and then log on again to restore communication.

Indicator Description

1 Comm 
Status

Current status of the communication channel between the SL Console and 
the library controller. Possible icons are:

Normal communications. The heartbeat monitor flashes 
periodically when the SL Console is communicating normally 
with the library controller. 

A warning. This icon appears when the server response takes 
longer than 10 seconds.

An error. This icon appears when the server response takes 
longer than 30 seconds. 

2 Userid Userid currently logged in to the SL Console. 

3 Library Library to which the SL Console is connected, and a graphical 
representation of the current health of the library and its devices. Possible 
icons are:

All library devices are functioning normally. 

A warning. One or more devices in the library is offline or 
operating in a degraded state. 

An error. One or more devices in the library has experienced a 
failure. 

4 Device 
health 
icon

Current status of the indicated device. If a device type indicator is yellow 
or red, you can expand the device folder to display the individual device 
health icons and then display details on the specific devices that are 
experiencing abnormal conditions. 
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Library Reports 
The library reports provide information on the library and its associated devices (for 
example, drives, robots, and CAPs), events, and tape cartridges. You can use the library 
reports to monitor library activity and identify potential problems. In addition to 
displaying the reports on-screen, you can save the report data to a file, which you can 
then print or include in e-mail. 

All report output is a static display of information sent from the library controller at the 
time the report is generated. The SL Console does not update the information 
dynamically unless you explicitly select the Update button on the Options bar.

Note – Running multiple instances of the standalone SL Console or Web-launched 
SL Console on the same PC or workstation can cause problems such as inconsistent 
data on reports. It is recommended that only one user at a time produce SL Console 
reports on a PC or workstation, unless all instances of the SL Console are the same 
version.

Report Types
The SL Console provides the following types of reports:

■ Log – detailed system event logs

■ Statistics – statistical information on library operations 

■ Status Detail – details on the status of the library and associated devices, such as 
CAPs, drives, and robots

■ Status Summary – summary information on the status of the library and associated 
devices

■ Version – details about library hardware and software versions

Report Options Bar
The Options bar on each report allows you to perform the following functions:

■ Search a Library Report

■ Update the report with current data

■ Save Library Report Data to a File 
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Status Alert Messages 

Note – This feature is available only if the Service license is active on the library. 

The library Status Module provides a centralized mechanism for displaying and 
managing library status alerts, which are messages about significant issues with the 
library firmware or configuration. Status alerts also appear in the library Event Log, but 
they may become “buried” in the volume of messages there. The Status Module screen 
highlights significant messages, making it easier for you to identify and resolve certain 
problems. 

Following are examples of status alert messages that may appear on the Status Module 
screen:

■ Redundant robots have been installed, but the Dual Robot license is not active

■ A licensed feature is due to expire

■ An invalid partition configuration has been detected 

The Status Module screen does not include messages about device issues, because 
details about them are displayed in the respective device status screens (CAP Status, 
Drive Status, etc.) 

A status alert message also causes the library health indicator to change to yellow or 
red, depending on the severity of the issue. See “Library and Device Status” on page 65 
for details. 

See the following procedures for details about managing status alert messages:

■ “Display Library Status Alerts” on page 89

■ “Clear Library Status Alerts” on page 91
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CAP Operations

Note – Most CAP functions described in this section apply to AEMs as well as regular 
CAPs. In cases where there is a distinction between the two, the term “rotational CAP” 
is used to refer to regular CAPs. 

CAPs (cartridge access ports) allow a library operator to enter or eject cartridges to or 
from the library. You can use the CAPs only when the library is in automated mode. 

Rotational CAPs
One rotational CAP is always present in the base module. Optionally, the drive 
expansion module and cartridge expansion module can also each have one rotational 
CAP. 

Each rotational CAP contains two removable 13-slot magazines, allowing for a total of 
26 cartridges to be imported or exported at one time through each CAP. 

AEM CAPs
See “AEM Operations” on page 73 for a detailed description of AEM CAPs. 

CAP Open Sequence
Opening a CAP involves the following steps:

1. A host issues a command to unlock the CAP. 

2. The CAP status is updated to “unlocked.”

3. The library operator presses the CAP button on the key pad.

4. The CAP status is updated to “open.”

5. The CAP motor is activated, and the CAP rotates outward to expose the magazines 
(rotational CAPs). For AEM CAPs, once the Enter LED is illuminated, the library 
operator can lift the latch and open the AEM access door (AEM CAPs). 

CAP Close Sequence
Closing a CAP involves the following steps:

1. The library operator presses the CAP button on the key pad. 
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2. The CAP motor is activated, and the CAP rotates inward to close the CAP (rotational 
CAPs). The library operator can close the AEM access door and secure the latch 
(AEM CAPs). 

3. The library operator presses the CAP button again to start the close sequence. 

4. The CAP is status is updated to “closed” and “locked.”

5. The TallBot audits all CAP slots.

Auto Enter Mode
CAP auto enter mode allows a library operator to open a rotational or AEM CAP and 
initiate an enter operation without issuing an explicit enter request and without an 
explicit reservation from a host application. When a CAP is in auto enter mode it is 
unlocked by default, and its LED is lit. The CAP is locked only during cartridge enter, 
eject, or audit operations. 

Auto enter mode is managed by the host applications. See the appropriate tape 
management software documentation for details. To place a CAP in auto enter mode, 
you must enter the appropriate system command to unlock the CAP 

To initiate an enter operation using an automatic CAP, you only need to press the CAP 
Open button on the key pad. Auto enter mode does not affect CAP operations for 
ejecting cartridges, so you must issue an explicit eject command to eject cartridges 
through a CAP in auto enter mode.

Manual CAP Mode 
Manual mode is the most secure method of CAP operations. 

When in manual mode, a rotational or AEM CAP is locked by default and its LED is 
not lit. To initiate an enter or eject operation using a manual CAP, you must enter an 
explicit enter or eject request before pressing the CAP Open button on the key pad. 

CAP Priorities for Cartridge Ejects by FC-SCSI 
Hosts
When you initiate an eject operation from an HLI host, you are able to specify the CAP 
to use. The SCSI interface, however, does not provide this level of control. The interface 
essentially aggregates all CAPs and AEMs in the library and treats them as one large 
CAP. When you initiate an eject operation from an FC-SCSI host, the TallBot places 
cartridges in CAPs, working from left to right, starting first with rotational CAPs, and 
then moving to AEMs, if applicable. 

For example, assume an FC-SCSI library with the following configuration:

■ Base module, with standard rotational CAP

■ Two CEMs, with optional rotational CAPs
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■ Two AEMs 

Note – The following example assumes either a non-partitioned library, or a 
partitioned library in which all CAPs and AEMs are shared by all hosts. For partitioned 
libraries, the CAP priority is dependent on how CAPs are allocated to partitions. 

For an eject operation of 350 cartridges, the TallBot would fill CAP cells in the 
following order:

Using CAPS in a Partitioned Library

Note – This topic applies to partitioned libraries only. See “Partitioning Task 
Summary” on page 265 for details about defining library partitions. 

A rotational or AEM CAP is a shared library resource – that is, it can be used by all 
partitions in the library. A CAP can be used by only one partition at a time, however. 
While a partition is using a CAP for enters or ejects, the CAP is reserved to that 
partition and unavailable to all others. 

In order for a partition to reserve a CAP, all of the following conditions must be met:

■ The CAP must be available – that is, not reserved by any other partition. 

■ The CAP must be empty.

Module
Number of 
Cartridges

Total 
Cartridges

1 Left CEM 26 26

2 Base Module 26 52

3 Right CEM 26 78

4 Left AEM 234 312

5 Right AEM 38 350
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■ The CAP must be closed and locked.

For additional details, see “CAP “Ownership”” on page 256. 

Additional CAP Information
See the following sections of this manual for complete details about rotational and 
AEM CAPs. 

Section Type of Information Page

“AEM Operations” Usage information that applies specifically to 
AEM CAPs

73

“Rotational and AEM CAP 
Management Tasks”

Procedures for displaying rotational CAP 
status and properties

114

“Cartridge Management 
Tasks”

Procedures for using rotational CAPs to load 
and unload cartridges

126

“Partitions and Rotational 
and AEM CAPs”

Partition configuration information relating 
to rotational CAPs

255
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AEM Operations 
The AEM (access expansion module) allows a library operator to perform bulk loads or 
unloads of up to 234 cartridges at a time to or from the library. The AEM also allows 
for non-disruptive maintenance of a library TallBot. 

Note – AEMs share many of the same features and functions as rotational CAPs, but 
they also have some unique characteristics. This section describes what is unique to 
AEMs. 

AEM Access Door 
The AEM access door is the external door you open to bulk load or unload cartridges to 
or from the library. The front panel of the access door includes the following 
components: 

■ Three LEDs: Wait, Enter, and Unlocked

■ Two locks: 

■ Service Access – Can be opened only by a Sun StorageTek CSE. Opening this lock 
releases the access door deadbolt.

■ Deadbolt Override – For “fast access” to the inside of the AEM by a library 
operator. This action has the same effects on library operations as opening the 
main library access door. 

■ “Operator Request CAP” button – For normal access to the inside of the AEM, to 
load or unload cartridges. Pressing this button releases the access door deadbolt. 

■ Latch – Opens and closes the access door. The latch can be opened only after you 
release the deadbolt or use the deadbolt override. 

AEM Safety Door
The safety door is the internal “garage” door, which lowers to separate the AEM from 
the rest of the library. This door allows for safe access to the inside of the AEM, either 
for a library operator to load or unload cartridges, or for a Sun StorageTek CSE to 
perform service on the TallBot or other AEM components. 

The safety door is lowered when you press the “Operator Request CAP” button on the 
AEM access door or when a Sun StorageTek CSE uses the Service Access lock. The 
safety door is not lowered if you perform an AEM “fast access” by unlocking the 
Deadbolt Override lock. 

The safety door is automatically raised when you close the AEM access door. The 
TallBot then enters the AEM and conducts an audit of all AEM cells. A full audit of an 
AEM should take less than three minutes. 
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AEM CAP Functions
Each AEM CAP contains 18 removable 13-slot cartridge magazines on the front and 
back walls, for a total of 234 cartridge slots. The magazines are arranged in a 3 X 3 
configuration on each wall. The magazines are the same as those used in rotational 
CAPs.

In terms of cartridge loads and unloads, the library controller treats each AEM as a 
very large CAP. See “CAP Operations” on page 69 for information on CAP functions 
that apply to AEMs. 

Partitions and AEMs
With regard to library partitioning, AEM CAPs are subject to the same rules and 
restrictions as rotational CAPs. They can be allocated for exclusive use by one partition, 
or they can be shared by multiple partitions with the same host interface type. See 
“Partitions and Rotational and AEM CAPs” on page 255 for details. 

Non-disruptive Maintenance
The AEM allows a Sun StorageTek CSE to safely access and service a library TallBot 
without having to take the library offline. If a TallBot is defective, it parks itself in the 
AEM. The library remains online, and if redundant TallBot are installed, the library can 
continue normal operations through the remaining functional TallBot. 

A Sun StorageTek CSE can use a special key to unlock the Service Access lock on the 
access door. This causes the AEM safety door to lower, sectioning off the AEM from the 
rest of the library. Once the safety door is fully down, the Sun StorageTek CSE can open 
the AEM access door and safely perform maintenance on the defective TallBot or other 
AEM components, while the library remains online. The AEM itself is taken offline 
during the maintenance period, causing cartridge load/unload functions to be 
suspended. 

When maintenance is complete, the StorageTek CSE closes the access door, the safety 
door raises, the TallBot is reinitialized and performs an audit of the AEM CAP 
cartridge slots, and then the AEM is brought back online. 

Additional AEM Information
See the following sections of this manual for complete details about AEMs. 

Section Type of Information Page

“CAP Operations” Usage information that applies to both 
rotational CAPs and AEM CAPs

69

“Rotational and AEM CAP 
Management Tasks”

Procedures for displaying AEM CAP status 
and properties

114

“Cartridge Management 
Tasks”

Procedures for using AEM CAPs to load and 
unload cartridges

126
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“AEM Safety Door 
Management Tasks”

Procedures for displaying status and 
properties of the AEM safety door (“garage” 
door) 

177

“Partitions and Rotational 
and AEM CAPs”

Partition configuration information relating 
to both rotational and AEM CAPs

255

“AEM Safety Door Utility 
Tasks”

Procedures for rebooting the AEM safety 
door (“garage” door) 

451

“Manual Operation Tasks” Procedures for “fast access” to the AEM 458

FIGURE B-5, “Access 
Expansion Module Walls” on 
page 495

Detailed diagram of the wall layouts 495

Section Type of Information Page
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Cartridge Management 
All library cartridges must have a readable external label.  See Appendix C, “Cartridge 
Handling” for details. 

The HSC and ACSLS host software applications do not support unlabeled cartridges 
and will not allow them to be entered through the CAP. If you place an unlabeled 
cartridge in a CAP, the host leaves it there and you must remove it from the CAP. 

If you place an unlabeled cartridge into a storage cell manually, the TallBot leaves it 
there during a hardware audit and does not attempt to place another cartridge into the 
slot. During an ACSLS or HSC audit, however, the host moves the cartridge to the CAP 
for ejection from the library. 

The library controller will not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 

Entering Cartridges
You can enter up to 26 cartridges at one time through each rotational CAP. You can 
bulk load up to 234 cartridges through each AEM CAP. 

Before entering a cartridge into the library, you must verify that it is labeled properly. 
Insert each cartridge in a CAP slot so that the customer label (if present) is facing you, 
the hub gear is facing down, and the VOLID label is facing you. Cartridges may be 
placed in any CAP slot, in any order; the TallBot audits all CAP slots when the CAP 
door is closed. 

Note – The CAP design prevents you from placing a T9x40 or T10000 cartridge in the 
CAP, upside-down. It does not, however, prevent you from placing an LTO cartridge in 
the CAP upside-down. 

The TallBot’s bar-code scanner reads cartridge VOLIDs only during enter operations, 
since the VOLIDs are new and must be added to the library controller database. The 
TallBot does not need to read cartridge VOLIDs during ejects. 

When a cartridge is entered into the library, it is either assigned a home cell by the host 
or mounted on a drive, depending on the reason why it was entered. The location of a 
stored cartridge is recorded in the library controller database, using the library internal 
address format (see “Library Internal Address” on page 473). The location is also 
transmitted to the host for inclusion in the host’s cartridge database.

Ejecting Cartridges
You can eject up to 26 cartridges at one time through each rotational CAP. You can bulk 
unload up to 234 cartridges through each AEM CAP.

To eject a cartridge, you must specify the VOLID of the cartridge you want to remove 
from the library. The TallBot moves to the storage location indicated in the library 
controller database, removes the cartridge from the slot, and places the cartridge in a 
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CAP slot. See “CAP Priorities for Cartridge Ejects by FC-SCSI Hosts” on page 70 for 
details on the order in which CAPs are used in FC-SCSI libraries. After the CAP is 
opened, the cartridge and its location are deleted from the library controller database 
and the host database. 

Note – The TallBot does not read cartridge VOLIDs during eject operations. 

Locating Cartridges
The SL Console allows you to display the library internal address of any cartridge. You 
can locate a cartridge based on any of the following criteria:

■ VOLID

■ Library internal address

■ HLI-PRC address 

This utility is especially useful when you need to perform a manual mount of a 
cartridge. The library management software (for example, HSC or ACSLS) provides the 
VOLID and the HLI-PRC or FC-SCSI address of the cartridge and the drive bay address 
of an available drive. Before you enter the library, write down the VOLID, cartridge 
location, and the drive slot location. 

Recovery Moves 
Using the recovery move diagnostic function, you can move a cartridge from one 
location to another. For example:

■ You can return a cartridge to its original location from a CAP cell, drive, or another 
storage cell location. 

■ You might decide to group cartridges by data type or to move them closer to their 
assigned drives. 

■ You can eject a cleaning or diagnostic cartridge that has expired.

■ You can enter a new cleaning or diagnostic cartridge and move it to a reserved 
storage cell. 

A cartridge currently in a storage cell can be moved only to a CAP, a reserved cell, or 
another storage cell, not to a drive. A cartridge currently in a drive, CAP, or reserved 
cell can be moved to any other unoccupied location in the library. See the following 
procedures for complete details:

■ “Move a Specified Cartridge by VOLID” on page 138

■ “Move a Cartridge From a Specified Location” on page 140

Before moving any cartridge, it is helpful to generate a Cartridge Summary Report, 
which lists the contents of library storage cells. See “List Library Cartridges” on 
page 133 for details. This report helps you determine where cartridges are currently 
located and which storage cells are unoccupied. 
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Drives
You can install up to 56 drives within one library, as follows:

■ Up to 24 in the Base Module

■ Up to 32 in a drive expansion module (DEM)

See “Tape Drives” on page 17 for a list of supported tape drives. 

Drive Identification
The library uses the following addressing schemes for each library drive:

■ Library internal address – For all drives. Assigned by the library controller based on 
the library, rail, column, side, and row location of the drive. 

■ HLI-PRC address (Host LMU Interface-Panel, Row, Column) – For TCP/IP host 
connections only. Assigned by host applications. 

■ Host SCSI element address – For FC-SCSI host connections only. Assigned by host 
applications. 

■ Drive bay address – For all drives. Assigned by the library controller based on the 
physical slot in which the drive is installed. 

■ dynamic World Wide Name – For Fibre Channel connections only. Assigned by the 
library controller, according to the slot into which the drive is installed. 

See Appendix A, “Library Resource Addresses” on page 471 for details on drive 
identification and addressing schemes. 

Drive States
A drive can be in either of the following states:

■ Online – The drive is available for read/write operations.

■ Offline – The drive is not available for read/write operations. 

Additional Inforation
For detailed drive procedures, see “Drive Management Tasks” on page 144. 
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Drive Cleaning 
The library tape drives require periodic cleaning to prevent read and write errors. The 
library supports two methods of drive cleaning:

■ Managing Automatic Cleaning Through the SL Console 

■ Manual Cleaning 

Cleaning Cartridges

Note – You must use cleaning cartridges whose media types are compatible with the 
drive types in the library. 

Cleaning cartridges have a limited life span. Refer to your tape drive publications to 
determine the maximum usage count, or threshold, for each type of cleaning cartridge.

When you enter a cleaning cartridge into the library, the library controller considers the 
cartridge to be new and sets the usage count to zero. It is therefore important to enter 
only new cleaning cartridges into the library. 

Whenever a cleaning cartridge is used to clean a drive, its usage count is incremented. 
When a cleaning cartridge’s usage count exceeds its threshold, the cartridge must be 
replaced. 

You can use the SL Console to display the status of a cleaning cartridge at any time. 
The following statuses are possible:

■ OK – The cartridge is still within the threshold.

■ Warning – The cartridge has reached the threshold.

■ Expired – The cartridge has exceeded the threshold.

Ejecting Expired Cleaning Cartridges 
You must use care when ejecting expired cleaning cartridges from the library. If you 
move an expired cleaning cartridge to a CAP and open the CAP, you must remove the 
cartridge. If you close the CAP without removing the cleaning cartridge first, the 
TallBot will re-enter the expired cartridge into the library, and the library controller 
will reset the usage count to zero. 



 

Drive Cleaning

80 SL3000 User’s Guide • May 2009 Revision AB • 316194401

Managing Automatic Cleaning Through the 
SL Console 
The SL3000 automatic cleaning function (or “auto clean”) allows you to manage 
automatic drive cleaning through the SL Console. This function should be enabled only 
for partitions or whole libraries controlled by FC-SCSI hosts. 

For all other partitions and whole libraries—those controlled by the ACSLS or HSC 
tape management software—you should disable the automatic cleaning function in the 
SL Console. (See “Configure Drive Auto Clean” on page 162 for details.) ACSLS or HSC 
will manage the automatic cleaning function for these partitions and libraries, and the 
SL3000 automatic cleaning function prevents HSC and ACSLS from being notified 
when drives need cleaning. See the ACSLS and HSC documentation for details. 

The SL3000 automatic cleaning function currently does not support the following 
functionality:

■ Automatic importing of cleaning cartridges through the CAP and placement of these 
tapes within the reserved cells dedicated for cleaning and diagnostic cartridges. 

■ Automatic exporting of expired cleaning cartridges through the CAP. 

When auto clean is enabled, the library controller automatically initiates a cleaning 
operation whenever a drive requires cleaning. The TallBot retrieves an appropriate 
cleaning cartridge (based on drive type) from the reserved cells, mounts the cartridge 
onto the drive, and returns the cartridge to its assigned storage cell after cleaning is 
complete.

Manual Cleaning 

Note – Manual drive cleaning is initiated through the library management software. 
Refer to the ACSLS or HSC documentation for command syntax.

If auto clean is disabled, you must initiate drive clean operations manually. To verify 
whether a drive needs cleaning, you can use the SL Console to display a drive’s 
cleaning status and the date when it was last cleaned. 

If auto clean is enabled, you may still be able to initiate a manual clean, depending on 
the drive type. Some drive types allow manual cleaning at any time, while others do 
not allow cleaning to be initiated unless a usage threshold has been met. In the latter 
case, the library may allow you to mount a cleaning cartridge on a drive, but the drive 
will not actually perform the cleaning operation. Refer to your tape drive publications 
for details. 

To locate the correct type of cleaning cartridge for a particular drive, you can use the 
SL Console to generate a cartridge summary and drive details report. 
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TallBots 
The library TallBot moves cartridges throughout the library storage slots, tape drives, 
and CAPs. It also performs audits of the library. 

The TallBot is included with the Base Module and is accessible from the front of the 
rack. The three main components of the TallBot are:

■ X table assembly – Provides 180-degree lateral motion. 

■ Z drive assembly – Provides vertical motion. 

■ Hand assembly – Includes the following components:

■ Grippers to carry cartridges. 

■ Laser bar-code scanner to calibrate position and read cartridge labels. 

■ Proximity sensor to detect empty storage cells and unlabeled cartridges. 

See “Robot and Power Supply Monitoring Tasks” on page 171 for details about 
displaying and managing TallBot status and other information. 
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Power Supplies
The SL3000 provides full redundancy for tape drives, robotics units, and electronics. 
The following redundancy options are available: 

■ N+1 

■ 2N 

■ 2N+1 

The following power source options are available:

■ 120–127 VAC, single phase

■ 200–240 VAC, single phase

See “Power Options” on page 22 for additional details. 
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Host Interface Type
The SL3000 supports the following control path interface options: 

■ HLI (TCP/IP) – TCP/IP protocol using Ethernet 10/100 Base-T and CAT-5 cables 

■ FC-SCSI – SCSI-3 protocol and command set over a physical Fibre Channel interface

See “Library Control Path” on page 24 for details. 

Non-Partitioned Libraries
In non-partitioned libraries, all hosts must use the same interface type to connect to the 
library. 

You can display the interface type on the System Detail > Status > General screen. 

You can change the interface type through the Select Active Cells > Select Active Cells 
screen. 

Partitioned Libraries
In partitioned libraries, both the FC-SCSI and HLI host interface types can be used; 
each partition must use one or the other. When you create a new partition, you specify 
which interface type it uses. All hosts within a partition use the same interface type. 
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For complete details, see “Host-Partition Connections” on page 249. 
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Automated Operation Tasks 
Library automated operation tasks are divided into the following categories:

■ “Library Management Tasks” on page 87

■ “Rotational and AEM CAP Management Tasks” on page 114

■ “Cartridge Management Tasks” on page 126

■ “Drive Management Tasks” on page 144

■ “Drive Cleaning Tasks” on page 161

■ “Robot and Power Supply Monitoring Tasks” on page 171

■ “AEM Safety Door Management Tasks” on page 177
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Library Management Tasks

Task Page

Display Library Status 88

Display Library Status Alerts 89

Clear Library Status Alerts 91

Display HLI Port Status 93

Display Library Configuration Information 95

Display Library Controller Properties 96

Display Drive Controller Properties 98

Display Drive Controller Properties 98

Change the Library Interface Type (Non-Partitioned Libraries) 99

Display a Library Report 102

Search a Library Report 104

Save Library Report Data to a File 106

Display the “Last 24 Hours” Library Energy Monitor Report 108

Display the “Last Month” Library Energy Monitor Report 110

Display the “Last Year” Library Energy Monitor Report 112
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▼ Display Library Status 
View the current operational state of the library. These values are updated whenever 
there is host activity, background operations, or operator activity.

Note – This information is also available through Reports > Library Details. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail, and click the Library folder.

2. Click the Status tab, and then the General tab.

The screen displays the current status of the library. 
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▼ Display Library Status Alerts  

Note – This feature is available only if the Service license is active on the library. 

Note – If the Service license is not active on the library, then this screen will be blank 
except for a message indicating that the “Service license is not valid.” 

Use this procedure to display library status alerts, which can help you to identify 
whether there are any current or pending issues with the library firmware or 
configuration. You might perform this procedure whenever the library health indicator 
has changed from green, to yellow or red, indicating a warning or error. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the Status Module tab. 

The screen displays all library status alerts. 

Screen Fields
Clear Alert Number 

Optional.
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Status alert message you want to clear from the display. 

The pull-down menu displays numbers 0–20. Although you can select any one of 
these, only the numbers that correspond to clearable alert messages shown in the 
display will actually cause a message to be cleared. 

Alert #

Display only.

Sequential number assigned to the status alert message. 

Level

Display only.

Severity level of the status alert message. Options are: 

■ OK – The firmware module is functioning normally. 

■ Information – Information message; the firmware module is functioning normally. 

■ Warning – The firmware module is operating in a degraded state; may indicate a 
future failure is possible. 

■ Error – The firmware module has experienced a failure. 

Module Name

Display only.

Library controller firmware module that is affected by the message. 

Clearable? 

Display only.

Indicates whether the status alert message can be manually cleared from the display. 
Options are:

■ Yes – Message can be cleared, and the firmware module status will be returned to 
OK. 

■ No – Message cannot be cleared. Generally, OK and Information messages cannot 
be cleared. 

Description

Display only.

Full description of the status alert message. 

Buttons
Apply

Click to clear the selected alert message from the Status Module display. The 
firmware module status is returned to OK, and the library health indicator is 
updated. 

Note – If the alert message is updated periodically, it will reappear with the next 
update cycle.

Refresh 

Click to refresh the display with current data from the library controller database. 
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▼ Clear Library Status Alerts  

Note – This feature is available only if the Service license is active on the library. 

Use this procedure to clear a library firmware status alert. Not all alerts can be cleared.

Note – Clearing an alert only removes it from this screen display. It does not resolve 
the underlying issue. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the Status Module tab. 

The screen displays all library status alerts. 

3. On the Clear Alert Number pull-down, select the alert number that you want to clear 
from the display, and Click Apply. 
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Note – Although you can select any alert number, only alerts marked as “Clearable” 
can actually be cleared. 

The alert is removed from the Status Module display. The library health indicator 
returns to green if there are no other device or status alerts. 

Note – If the alert is subject to periodic updates, it will reappear at the next update 
cycle.
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▼ Display HLI Port Status 
Use this procedure to display the current status of all host LMU (library management 
unit) HLI interface ports on the library. Information includes the local TCP/IP socket, 
local IP, connection status, port status, transmission sent and received from the time of 
connection.

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the HLI tab. 

The screen displays the current status and activity of all HLI ports on the library. 
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▼ Display FC-SCSI Port Status 
Use this procedure to display the current status of all host FC-SCSI interface ports on 
the library. Information includes the port number, speed, and status, loop ID, World 
Wide Node Name, World Wide Port Name, and topology. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the SCSI tab. 

The screen displays the current status and activity of all FC-SCSI ports on the library. 
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▼ Display Library Configuration Information 
Use this procedure to display the physical, mechanical, and logical configuration of the 
library. Some of the information can is set up automatically during library initialization, 
while other information can be defined by the user. 

Note – This information is also available through Reports > Library Information. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the General tab.

The screen displays detailed information about the library. 



 

Library Management Tasks

96 SL3000 User’s Guide • May 2009 Revision AB • 316194401

▼ Display Library Controller Properties 
View details of the library controller, including the serial number and firmware 
versions.

Note – This information is also available through Reports > Library Information. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the Library Controller tab.
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▼ Display Drive Controller Properties 
View details of the drive controller, including the serial number and current firmware 
versions.

Note – This information is also available through Reports > Library Information. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the Drive Controller tab.

The Drive Controller screen appears. 
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▼ Change the Library Interface Type (Non-
Partitioned Libraries)
Use this procedure to change the interface type that all hosts use to connect to the 
library. 

Note – This procedure applies to non-partitioned libraries only. To change interface 
types in a partitioned library, see “Modify the Interface Type of a Host-Partition 
Connection” on page 287. “Modify the Interface Type of a Host-Partition Connection” 
on page 287

1. Select Tools > Select Active Cells. 

The Module Map screen appears.
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2. Click the Select Active Cells tab.

The Select Active Cells screen appears, displaying the interface type currently assigned 
to the library.

3. In the Interface Type pull-down, select the interface type you want to assign. Click 
Apply. 

The Confirm Apply popup appears. 

4. Click Yes to update the library controller database. 

The Commit Success popup appears. 
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5. Click OK to return to the Select Active Cells screen. 

The new interface type is active immediately; the library does not need to be rebooted. 
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▼ Display a Library Report 
Use this procedure to display library reports available from the Tools > Reports menu.

Note – All report output is a static display of information sent from the library 
controller at the time the report is generated. The SL Console does not update the 
information dynamically unless you explicitly select the Update button on the Options 
Bar.

If you want to search the report data or save it to a file, see the following procedures:

■ “Search a Library Report” on page 104 

■ “Save Library Report Data to a File” on page 106

Additional reports are available from the following menus:

■ Tools > Partitions

■ Tools > Select Active Cells 

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.
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3. Click the report you want to display. 

The selected report is displayed. 
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▼ Search a Library Report 
Use this procedure to search a library report for a specified text string. This procedure 
can be performed on any of the library report screens.

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report is displayed. All report screens include the Search button on the 
Options Bar. 

4. Click Search. 

The Search Text popup appears. 

5. Enter the text string you want to search for, and click Search. 
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Note – The search is case-sensitive, and wildcards are not supported. 

6. The Search Results popup appears, displaying the number of occurrences of the text 
string. All instances of the text string in the report are highlighted. 

7. Click OK to dismiss the popup. 
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▼ Save Library Report Data to a File
Use this procedure to display a library report and save the data to a file. Depending on 
the report, you can save to in text (.txt), HTML, XML, or comma-separated values 
(.csv) format. This procedure can be performed from any of the library report screens.

Once the file is saved, you can print it or include it in e-mail. This may be useful for 
communicating about library issues with your Sun support representative. Also, you 
can import a .csv file into a spreadsheet or charting application in order to better 
understand and interpret the data. 

1. Select Tools > Reports. 

The reports Display screen appears. All library report options are listed in the 
navigation bar.

2. In the navigation bar, expand a report category to see the report options.
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3. Click the report you want to display. 

The specified report is displayed. All report screens include the Save button on the 
Options Bar. 

4. Click Save. 

The Save popup appears. 

5. Browse to the directory where you want to save the file. In the File Name field, you 
can accept the default entry or enter a different file name. 

6. In the Files of Type pull-down, select the format in which you want to save the data 
(HTML, Text, XML, .csv). 

7. Click Save. 

The data is saved to the specified file. 

Note – If the file exists already, a popup appears prompting you whether you want to 
replace the file. 
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▼ Display the “Last 24 Hours” Library Energy 
Monitor Report

Note – This feature is available starting with SL3000 firmware version FRS_2.30 and 
SL Console version FRS_4.30. 

The Last 24 Hours Energy Monitor Report displays minute-by-minute energy and 
average power usage for the entire library over the last 24 hours. This report helps you 
to monitor your power and energy usage and identify periods of peak and low usage 
during the day.

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen Layout” 
on page 39. 

To create a chart from this report, you can save the data to a comma-separated (.csv) 
file and then import the .csv file into a charting application. For details, see “Save 
Library Report Data to a File”. 

For related reports, see the following:

■ “Display the “Last Month” Library Energy Monitor Report” on page 110

■ “Display the “Last Year” Library Energy Monitor Report” on page 112 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Energy Monitor - Last 24 Hours. 
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Screen Fields
Date 

Date and time of the measurements. 

kWh

Energy used by the entire library during the identified one-minute interval, 
measured in kilowatt-hours. 

kW

Average power used by the entire library during the identified one-minute interval, 
measured in kilowatts. 
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▼ Display the “Last Month” Library Energy Monitor 
Report

Note – This feature is available starting with SL3000 firmware version FRS_2.30 and 
SL Console version FRS_4.30. 

The Last Month Energy Monitor Report displays energy and average power usage for 
the entire library, measured in 15-minute intervals over the last 32 days. This report 
helps you to analyze your power and energy usage and identify periods of peak and 
low usage during the last month. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen Layout” 
on page 39. 

To create a chart from this report, you can save the data to a comma-separated (.csv) 
file and then import the .csv file into a charting application. For details, see “Save 
Library Report Data to a File”. 

For related reports, see the following:

■ “Display the “Last 24 Hours” Library Energy Monitor Report” on page 108

■ “Display the “Last Year” Library Energy Monitor Report” on page 112 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Energy Monitor - Last Month. 
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Screen Fields
Date 

Date and time of the measurements. 

kWh

Energy used by the entire library during the identified 15-minute interval, measured 
in kilowatt-hours. 

kW

Average power used by the entire library during the identified 15-minute interval, 
measured in kilowatts. 
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▼ Display the “Last Year” Library Energy Monitor 
Report

Note – This feature is available starting with SL3000 firmware version FRS_2.30 and 
SL Console version FRS_4.30. 

The Last Year Energy Monitor Report displays energy and average power usage for the 
entire library, measured in one-day intervals over the last 365 days. This report helps 
you to analyze your power and energy usage and identify periods of peak and low 
usage during the year. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen Layout” 
on page 39. 

To create a chart from this report, you can save the data to a comma-separated (.csv) 
file and then import the .csv file into a charting application. For details, see “Save 
Library Report Data to a File”. 

For related reports, see the following:

■ “Display the “Last 24 Hours” Library Energy Monitor Report” on page 108

■ “Display the “Last Month” Library Energy Monitor Report” on page 110 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Energy Monitor - Last Year. 
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Screen Fields
Date 

Date of the measurements. 

Total kWh

Total energy used by the entire library during the day, measured in kilowatt-hours. 

Avg kW

Average power used by the entire library during the day, measured in kilowatts. 

Max kWh

Maximum 15-minute-period energy value for the day. 

Min kWh

Minimum 15-minute-period energy value for the day. 

Avg kWh

Average of all 15-minute-period energy values for the day. 

Max kW

Maximum 15-minute-period power value for the day. 

Min kW

Minimum 15-minute-period power value for the day. 

Avg kW

Average of all 15-minute-period power values for the day. 
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Rotational and AEM CAP Management 
Tasks

Task Page

Display Rotational and AEM CAP Summary Information 115

Display Current Rotational or AEM CAP Status 116

Display Rotational or AEM CAP Properties 119

Unlock a CAP or AEM Access Door 122

Lock a CAP or AEM Access Door 124
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▼ Display Rotational and AEM CAP Summary 
Information
Use this procedure to display summary information for all rotational and AEM CAPs in 
the library. 

Note – This information is also available through Reports > CAP Summary. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail, and click the CAP folder. 

The screen lists all the library rotational and AEM CAPs and their locations.    
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▼ Display Current Rotational or AEM CAP Status 
Use this procedure to display the current operational state of a rotational or AEM CAP. 

Note – This information is also available on the CAP Details report. See “Display a 
Library Report” on page 102 for detailed instructions. 

Note – Status information on the AEM safety door, which is the internal “garage” door 
that lowers to separate the AEM from the rest of the library, is displayed on the 
Safety Door Status screen. See “Display AEM Safety Door Status” on page 178 for 
detailed instructions. 

Note – This screen is used for both rotational and AEM CAPs. Throughout this section, 
the term “CAP” refers to both types of CAPs. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to display. 

Note – AEM CAPs are identified as follows: column “–31” for a left AEM CAP, and 
column “31” for a right AEM CAP. 

3. Click Status.

The screen displays the current status of the selected CAP. 
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■ For rotational CAPs: 
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■ For AEM CAPs: 
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▼ Display Rotational or AEM CAP Properties
Use this procedure to display static information for a rotational or AEM CAP, including 
the serial number and number of cells. 

Note – This information is also available through Reports > CAP Details. See “Display 
a Library Report” on page 102 for detailed instructions. 

Note – For AEM CAPs, this information is also displayed on the 
Safety Door Properties screen. See “Display AEM Safety Door Properties” on page 179 
for detailed instructions. 

Note – This screen is used for both rotational and AEM CAPs. Throughout this section, 
the term “CAP” refers to both types of CAPs. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to display. 

Note – AEM CAPs are identified as follows: column “–31” for a left AEM CAP, and 
column “31” for a right AEM CAP. 

3. Click Properties. 

The CAP Properties screen appears. 
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■ For rotational CAPs:
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■ For AEM CAPs: 
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▼ Unlock a CAP or AEM Access Door 
Normally a CAP or AEM access door is unlocked from a host. Use this procedure when 
you need to perform the unlock operation manually at the SL Console. 

Note – This screen is used for both rotational and AEM CAPs. Throughout this section, 
the term “CAP” refers to both types of CAPs. 

1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

Note – AEM CAPs are identified as follows: column “–31” for a left AEM CAP, and 
column “31” for a right AEM CAP. 

3. Click the Access tab. 

The Access screen appears.
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4. In the Locked pull-down, click false. Click the Apply button. 

The Confirm popup appears. 

5. Click OK.

The CAP door unlocks, and the CAP button light turns on.

Note – The CAP status changes to “unlocked” in the host library management 
software.

Note – The CAP or AEM is reserved by the library and inaccessible to all library hosts 
until you close and lock the CAP or AEM access door. See “Lock a CAP or AEM Access 
Door” on page 124 for details. 



 

Rotational and AEM CAP Management Tasks

124 SL3000 User’s Guide • May 2009 Revision AB • 316194401

▼ Lock a CAP or AEM Access Door 
Normally a CAP or AEM access door is locked from a host. Use this procedure when 
you need to perform the lock operation manually at the SL Console. 

Note – This procedure applies only to HLI CAPs. 

Note – This screen is used for both rotational and AEM CAPs. Throughout this section, 
the term “CAP” refers to both types of CAPs. 

Note – If you unlock a CAP or AEM access door (see “Unlock a CAP or AEM Access 
Door” on page 122 for details.), the CAP or AEM is reserved by the library and 
unavailable to all hosts until you perform this procedure. 

1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

Note – AEM CAPs are identified as follows: column “–31” for a left AEM CAP, and 
column “31” for a right AEM CAP. 
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3. Click the Access tab. 

The Access screen appears.

4. In the Locked field, click True. Click the Apply button. 

The CAP locks, and the CAP button light turns off.
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Cartridge Management Tasks

Task Page

Enter Cartridges Through a Rotational CAP 127

Eject Cartridges Through a Rotational CAP 128

Bulk Load Cartridges Through an AEM CAP 129

Bulk Unload Cartridges Through an AEM CAP 128

List Library Cartridges 133

Locate a Cartridge by VOLID 134

Locate a Cartridge by Address 136

Move a Specified Cartridge by VOLID 138

Move a Cartridge From a Specified Location 140

Display the Media Events Report 142
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▼ Enter Cartridges Through a Rotational CAP
Use this procedure to enter cartridges into the library through a rotational CAP. 

Note – This procedure applies to non-partitioned libraries. For partitioned libraries, 
see “Enter Cartridges Into a Partition” on page 306. 

Note – For detailed instruction on loading cartridges through an AEM CAP, see “Bulk 
Load Cartridges Through an AEM CAP” on page 129. 

1. Initiate the enter operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

Note – If the CAP is in auto enter mode, you can skip this step and proceed directly to 
Step 2. 

2. Push the CAP button to open the CAP. 

The CAP door opens. 

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

3. Place the cartridges in the CAP.

Insert the cartridges so that the customer label (if present) is facing up, the hub gear is 
facing down, and the VOLID label is facing you. 

You can enter the cartridges directly into the magazines while the magazines are in the 
CAP; or you can remove the magazines from the CAP, insert cartridges into the 
magazines, and then replace the cartridge-filled magazines into the CAP.

Note – Cartridges may be placed in any CAP slot, in any order; the TallBot audits all 
CAP slots when the CAP door closes.

Caution – Possible Media Damage. While cartridges that do not contain external labels 
or are placed upside-down can be entered, this is not advisable. It presents problems 
when an audit is performed. Likewise, cartridges that contain unreadable or damaged 
labels should not be entered. 

4. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

5. The TallBot audits the CAP and then moves the cartridges from the CAP to storage 
slots within the appropriate partition. 

When all cartridges have been moved from the CAP, the library recognizes that the 
CAP is empty and the CAP is returned to its default state. 
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▼ Eject Cartridges Through a Rotational CAP 
Use this procedure to eject cartridges from the library through a rotational CAP. 

Note – This procedure applies to non-partitioned libraries. For partitioned libraries, 
see “Eject Cartridges From a Partition” on page 307. 

Note – For detailed instruction on unloading cartridges through an AEM CAP, see 
“Bulk Unload Cartridges Through an AEM CAP” on page 131. 

1. Initiate the eject operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

You must specify the VOLIDs of the cartridges you want to remove from the library. 
For HLI hosts, you can specify the CAPs to use. For FC-SCSI hosts, the library uses 
CAPs in a pre-defined order; see “CAP Priorities for Cartridge Ejects by FC-SCSI 
Hosts” on page 70 for details. 

2. The TallBot places the cartridges into the CAPs.

When all the requested cartridges have been placed in CAPs, or all CAPs are full, the 
CAPs are unlocked. 

3. Push the CAP button to open the CAP. 

The CAP door opens. 

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

4. Remove the cartridges from the CAP.

You can remove the cartridges directly from the magazines while the magazines are in 
the CAP; or you can take the magazines out of the CAP, remove the cartridges from the 
magazines, and then replace the empty magazines in the CAP.

Note – If you do not replace the magazines in the CAP, the cells will be marked 
“absent” by the library controller. 

5. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

If more cartridges need to be exported, the TallBot continues filling the necessary CAPs. 
Wait until the CAP door is unlocked and repeat Step 3 through Step 5. 

The eject operation ends automatically when all specified cartridges have been ejected. 

6. The TallBot audits the CAP to verify that it is empty.

The CAP is then returned to its default state. 
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▼ Bulk Load Cartridges Through an AEM CAP
Use this procedure to load cartridges into the library through an AEM CAP. You can 
load up to 234 cartridges at a time. 

Note – This procedure applies to non-partitioned libraries. For partitioned libraries, 
see “Enter Cartridges Into a Partition” on page 306. 

Note – For detailed instruction on entering cartridges through a rotational CAP, see 
“Enter Cartridges Through a Rotational CAP” on page 127. 

1. Initiate the enter operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

Note – If the AEM CAP is in auto enter mode, you can skip this step and proceed 
directly to Step 2. 

The Unlocked light on the AEM access door is lit. 

2. Push the AEM CAP button. 

The Wait light on the AEM access door starts blinking as all in-process jobs are 
finished. The robot is cleared from the AEM, and the safety door comes down. 
Depending on the level of activity in the library, this may take several minutes.

Once the safety door is completely down and the AEM is sealed, the Wait light stops 
blinking and the Enter light goes on solid.

3. Lift the latch, and open the door.

Caution – Possible Equipment Damage. DO NOT force the AEM access door to open or 
close.

4. Place the cartridges in the AEM CAP.

Insert the cartridges so that the customer label (if present) is facing up, the hub gear is 
facing down, and the VOLID label is facing you. 

You can enter the cartridges directly into the magazines while the magazines are in the 
CAP; or you can remove the magazines from the CAP, insert cartridges into the 
magazines, and then replace the cartridge-filled magazines into the CAP.

Note – Cartridges may be placed in any CAP slot, in any order; the TallBot audits all 
CAP slots when the CAP door closes.

Caution – Possible Media Damage. While cartridges that do not contain external labels 
or are placed upside-down can be entered, this is not advisable. It presents problems 
when an audit is performed. Likewise, cartridges that contain unreadable or damaged 
labels should not be entered. 
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Caution – Possible Equipment Damage. When replacing magazines on the AEM walls, 
make sure you seat them correctly.

5. Close and latch the access door.

Caution – Possible Equipment Damage. DO NOT force the AEM access door to open or 
close.

6. Push the AEM CAP button .

The Enter light goes off, and the Wait light starts blinking. 

The safety door goes up.

7. The robot moves into the AEM, audits the AEM CAP, and then moves the cartridges 
from the AEM CAP to available storage cells . 

When all cartridges have been moved from the AEM CAP, the library recognizes that 
the AEM is empty and it is returned to its default state. 
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▼ Bulk Unload Cartridges Through an AEM CAP
Use this procedure to unload cartridges from the library through an AEM CAP. You 
can unload up to 234 cartridges at a time. 

Note – For eject operations initiated from an FC-SCSI host, AEM CAPs are used only 
after all rotational CAPs have been filled. See “CAP Priorities for Cartridge Ejects by 
FC-SCSI Hosts” on page 70 for complete details. 

Note – This procedure applies to non-partitioned libraries. For partitioned libraries, 
see “Eject Cartridges From a Partition” on page 307. 

Note – For detailed instruction on ejecting cartridges through a rotational CAP, see 
“Eject Cartridges Through a Rotational CAP” on page 128. 

1. Initiate the eject operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

You must specify the VOLIDs of the cartridges you want to remove from the library. 
For HLI hosts, you can specify the AEM CAPs to use. For FC-SCSI hosts, the library 
uses rotational and AEM CAPs in a pre-defined order; see “CAP Priorities for Cartridge 
Ejects by FC-SCSI Hosts” on page 70 for details.

2. The TallBot places the cartridges into the AEM cells. 

When all the requested cartridges have been placed in the AEM, the AEM is unlocked 
and the Unlocked light on the AEM access door is lit. 

3. Push the AEM CAP button. 

The Wait light on the AEM access door starts blinking as all in-process jobs are 
finished. The TallBot is cleared from the AEM, and the safety door comes down. 
Depending on the level of activity in the library, this may take several minutes.

Once the safety door is completely down and the AEM is sealed, the Wait light stops 
blinking and the Enter light goes on solid.

4. Lift the latch, and open the door.

Caution – Possible Equipment Damage. DO NOT force the CAP to open or close.

5. Remove the cartridges from the AEM CAP.

You can remove the cartridges directly from the magazines while the magazines are in 
the AEM; or you can take the magazines out of the AEM, remove the cartridges from 
the magazines, and then replace the empty magazines in the AEM. 

Caution – Possible Equipment Damage. When replacing magazines on the AEM walls, 
make sure you seat them correctly.
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Note – If you do not replace the magazines in the AEM, the cells will be marked 
“absent” by the library controller. 

6. Close and latch the AEM access door.

Caution – Possible Equipment Damage. DO NOT force the AEM access door to open or 
close.

7. Push the AEM CAP button .

The Enter light goes off, and the Wait light starts blinking. 

The safety door goes up.

8. If more cartridges need to be exported, the TallBot continues filling the necessary 
AEMs. Wait until the AEM Unlocked light is lit and repeat Step 3 through Step 6. 

The eject operation ends automatically when all specified cartridges have been ejected. 

The TallBot moves into the AEM and audits the AEM CAP to verify that it is empty. 
The AEM CAP is then returned to its default state. 

Note – The audit of the AEM CAP should take less than three minutes. 
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▼ List Library Cartridges
Use this procedure to display information about all library cartridges, including their 
VOLIDs, locations, and media types. 

1. Select Tools > Reports. 

All library report options are listed in the navigation bar. 

2. Expand the Status Summary folder.

All Status Summary reports are listed. 

3. Click Cartridge Summary. 

The Cartridge Summary Report is displayed. 

4. If you want to search the report data or save it to a file, see the following procedures:

■ “Search a Library Report” on page 104 

■ “Save Library Report Data to a File” on page 106
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▼ Locate a Cartridge by VOLID
Use this procedure to display the current location of a cartridge with a specified 
volume ID. The location can be displayed in one of the following formats:

■ Library internal address

■ HLI-PRC address (HLI hosts only)

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the Search tab.

The Library Search screen appears. 

3. In the Search Type pull-down, click VOLID. 

4. Enter the VOLID, Requester, and Cartridge Type. 

The Requester field controls the address format that will be displayed for the cartridge 
location. 

■ To display the library internal address, click default.

■ To display the HLI-PRC address, click hli0 or hli1. 

Note – You can use wildcards in the VOLID field. 
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5. Click Search. 

The screen displays all cartridges meeting the search criteria. 
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▼ Locate a Cartridge by Address
Use this procedure to display detailed information for cartridges with a specified 
location. Wildcards allow you to display all cartridges in a specified general area (for 
example, in a specified panel, row, or column). You can specify the location using one 
of the following formats:

■ Library internal address

■ HLI-PRC address (HLI hosts only)

■ FC-SCSI address (FC-SCSI hosts only) 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the Search tab.

The Library Search screen appears. 

3. In the Search Type pull-down, click Location. 

Note – The default Search Type is VOLID. 

The screen is updated to display fields allowing you to search by location. 

4. In the Location pull-down, select the type of match you want to perform in the 
search.

5. In the Requester pull-down, select the type of address format you want to use for the 
search. 

6. In the Location field, enter the parameters for the search. 

The format you use must correspond to the Requester you have specified. For example:

■ Use the library internal address format if Requester is “default”.

■ Use the HLI-PRC address if Requester is an HLI host.

■ Use the FC-SCSI address if Requester is an FC-SCSI host. 

Note – You cannot use wildcards in this field. 
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7. Click the Search button. 

The screen displays all locations meeting the search criteria. 

8. To see details about a cartridge or to view a location mapping, click the ... button in 
the Details column. 

The Location Details screen appears. 

9. Click Close to dismiss the popup. 
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▼ Move a Specified Cartridge by VOLID
Use this procedure to move a cartridge with a specified VOLID to a specified location 
within the library. 

Note – This procedure updates the cartridge’s location in the library controller 
database, but not in the host database. Therefore after performing this procedure, you 
must perform an audit from the host software to update the host database. Failure to 
do so will cause future mount requests from the host software to fail. 

Caution – Use caution when performing this procedure in partitioned libraries. You 
could inadvertently move a cartridge from one partition to another, allowing the new 
partition to overwrite data on the cartridge. 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the RcvrMove tab. 

The Recovery Move screen appears. 

3. In the Source Location Mode field, click VOLID. 

The screen is updated with the appropriate Source Location fields. 

4. In the VOLID field, specify the VOLID of the cartridge you want to move. 

5. In the Destination Location Type pull-down menu, select the type of location where 
you want to move the cartridge to. Options are:

■ CAP

■ Storage Slots 

■ Drive

■ Reserved Slots

The following restrictions apply:

■ The destination can be a drive only if the source is a CAP or reserved slot. 

■ For you to move a a cartridge to a drive, the cartridge media type must be 
compatible with the drive type. 

■ You cannot move a cartridge to a location that is already occupied. 

■ Although not strictly enforced, it is recommended that only diagnostic or cleaning 
cartridges be moved to reserved slots. 

6. In the Destination Location table, specify the library internal address of the 
destination location by making the appropriate selections in the following pull-
down menus:

The following special selections are available on the pull-down menus:

■ Min—First element of that location type——in the library 

■ Max—Last element of that location type——in the library 
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Caution – If the library is partitioned, make sure to keep the cartridge in the same 
partition it is currently allocated to. Moving a cartridge to a cell allocated to a different 
partition could result in a host treating the cartridge as scratch and overwriting the 
data. Moving the cartridge to an unallocated cell will result in the cartridge being 
inaccessible to all hosts. 

7. Click the Start button in the Options Bar.

The robot moves the cartridge. A success message popup appears when the operation 
is complete. 

8. Click OK.

9. To verify the new location, you can display a Cartridge Summary Report. See “List 
Library Cartridges” on page 133 for details. For example: 

10.To update the new cartridge location in the host database, initiate a library audit 
from the host software. See the appropriate tape management software 
documentation for the procedures and commands.
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▼ Move a Cartridge From a Specified Location
Use this procedure to move a cartridge from one specified location to another within 
the library. 

Note – This procedure updates the cartridge’s location in the library controller 
database, but not in the host database. Therefore after performing this procedure, you 
must perform an audit from the host software to update the host database. Failure to 
do so will cause future mount requests from the host software to fail. 

Caution – Use caution when performing this procedure in partitioned libraries. You 
could inadvertently move a cartridge from one partition to another, allowing the new 
partition to overwrite data on the cartridge. 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the RcvrMove tab. 

The Recovery Move screen appears. 

3. In the Source Location Mode field, click Location. 

The screen is updated with the appropriate Source Location fields. 

4. In the Source Location Type pull-down menu, select the cartridge’s current location 
type. Options are:

■ CAP

■ Slot

■ Drive

■ Reserved Slots

5. In the Source Location table, specify the library internal address of the source 
location by making the appropriate selections in the following pull-down menus:

The following special selections are available on the pull-down menus:

■ Min—First element of that location type——in the library 

■ Max—Last element of that location type——in the library 

6. In the Destination Location Type pull-down menu, select the type of location where 
you want to move the cartridge to. Options are:

■ CAP

■ Storage Slots 

■ Drive

■ Reserved Slots

The following restrictions apply:

■ The destination location can be a drive only if the source is a CAP or reserved slot. 

■ For you to move a a cartridge to a drive, the cartridge media type must be 
compatible with the drive type. 

■ You cannot move a cartridge to a location that is already occupied. 

■ Although not strictly enforced, it is recommended that only diagnostic or cleaning 
cartridges be moved to reserved slots. 
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7. In the Destination Location table, specify the library internal address of the 
destination location by making the appropriate selections in the following pull-
down menus:

The following special selections are available on the pull-down menus:

■ Min—First element of that location type——in the library 

■ Max—Last element of that location type——in the library 

Caution – If the library is partitioned, make sure to keep the cartridge in the same 
partition it is currently allocated to. Moving a cartridge to a cell allocated to a different 
partition could result in a host treating the cartridge as scratch and overwriting the 
data. Moving the cartridge to an unallocated cell will result in the cartridge being 
inaccessible to all hosts. 

8. Click the Start button in the Options Bar.

The robot moves the cartridge, and then a success message popup appears.

9. Click OK.

10.To verify the new location, you can display a Cartridge Summary Report. See “List 
Library Cartridges” on page 133 for details. For example: 

11.To update the new cartridge location in the host database, initiate a library audit 
from the host software. See the appropriate tape management software 
documentation for the procedures and commands.
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▼ Display the Media Events Report

Note – This feature is available starting with SL3000 firmware version FRS_2.30 and 
SL Console version FRS_4.30. 

The Media Events Report summarizes library cartridge media events. The report is 
updated whenever a media event or error occurs on any drive. You can use the report 
to help identify and diagnose faulty cartridges. 

For each cartridge that has experienced media events, the report lists the VOLID of the 
cartridge, the type of event, the number of occurrences, and the date and time of the 
last such event. The report can display up to 2000 entries.

By default, the report is sorted in VOLID order. Optionally, you can change the sort 
order, and rearrange and resize the columns. See “Modifying the Screen Layout” on 
page 39. 

Note – For cartridge events associated with particular drives, see “Display the Drive 
Media Events Report” on page 159. 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Media Events. 



 

Cartridge Management Tasks

316194401 • Revision AB SL3000 Automated Library Operations 143

Screen Fields
Cartridge Label 

VOLID of the cartridge that has experienced an event. 

Event Type

Type of media event being tracked. Options are:

■ Media Error – The drive indicated there was a problem with the media; this could 
possibly also indicate a problem with the drive.

■ Misbuckle Error – The drive was unable to grab the buckle of the media and could 
not thread the tape. The media is likely damaged. 

Number of Events

Total number of events of this type that have been recorded for this cartridge. 

Last Seen

Date and time of the most recent occurrence of the event. 



 

Drive Management Tasks

144 SL3000 User’s Guide • May 2009 Revision AB • 316194401

Drive Management Tasks

Task Page

Display Drive Summary Information 145

Display Drive Status 147

Display Drive Properties 148

Display Drive VOP 149

Display Drive VOP 149

Display Drive LED Status 153

Display Drive Tray Status 156

Display the Drive Events Report 157

Display the Drive Media Events Report 159
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▼ Display Drive Summary Information
Use this procedure to display summary information for all drives in the library. 

If you need to perform a manual mount to a drive, this procedure displays a mapping 
of all addresses for each library drive:

■ Firmware (internal address)

■ Host software (HLI-PRC address)

■ Hardware (drive bay)

The following information is also displayed:

■ Access State – online, offline

■ Drive State:

■ Empty

■ Unloaded – cartridge is present 

■ Ready – cartridge is loaded

■ NotCommunicating

■ rewindUnload –drive is busy rewinding and unloading 

■ Drive Type

■ Drive serial number

■ Current code version

■ Drive interface type

Note – This information is also available through Reports > Drive Summary. See 
“Display a Library Report” on page 102 for detailed instructions. 
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1. Select Tools > System Detail, and click the Drive folder. 

The screen lists the library drives and displays their locations.The internal address, 
drive bay, and HLI-PRC address are detailed. 
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▼ Display Drive Status 
Use this procedure to display the current operational state of a drive. The information 
includes:

■ Current drive and drive tray status information 

■ Whether the drive is loaded

■ Cartridge VOLID if the drive is loaded

■ Drive cleaning information

■ Host activity

Note – This information is also available through Reports > Drive Details. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Status.

The screen displays the current status of the selected drive. 
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▼ Display Drive Properties 
View detailed drive configuration information, including the drive type and serial 
number and port configuration.

Note – This information is also available through Reports > Drive Details. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Properties. 

The Drive Properties screen appears. 
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▼ Display Drive VOP

Note – This procedure is for Sun StorageTek T10000 and T9840D drives only. 

Use this procedure to display the Virtual Operator Panel (VOP) for T10000 and T9840D 
drives. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click Display.

The drive VOP information appears in the Drive Virtual Op Panel section. 
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▼ Display Drive Network Data
Use this procedure to display IP and MAC address data for a library drive. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 
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3. Click Display.

The data appears in the Network Data section. 
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▼ Display Drive LED Status
Use this procedure to display current statuses of a selected drive’s LEDs, including 
loaded, online, cleaning, and trace available statuses. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 
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3. Click Display.

The data appears in the Drive Led Status section. 
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▼ Display Drive Tray Status
Use this procedure to display the current status of a drive tray. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to display. 

3. Click DriveTray.

The Status screen appears. 
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▼ Display the Drive Events Report

Note – This feature is available starting with SL3000 firmware version FRS_2.30 and 
SL Console version FRS_4.30. 

The Drive Events Report summarizes drive events and errors that have occurred on 
library drives. The report is updated whenever there is a drive event not related to 
media. You can use the report to help identify and diagnose faulty drives.

For each drive that has experienced events, the report lists the type of drive, type of 
error, the number of occurrences, and the date and time of the last such event. The 
report can display up to 70 entries. 

By default, the report is sorted in drive serial number order. Optionally, you can 
change the sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 39. 

Note – For media errors associated with drives, see “Display the Drive Media Events 
Report” on page 159. 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Drive Events. 
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Screen Fields
Serial Number

Serial number of the drive.

Drive Type

Brand and model of the drive.

Event Type

Type of event being tracked. All of these events indicate problems with the drive, 
not the media. Options are:

■ Drive Error – Drive had a general problem. 

■ Load Error – Drive was unable to load the cartridge. 

■ Load Retry – Drive required retries to load the cartridge. 

Number of Events

Total number of events of this type that have been recorded for this drive. 

Last Seen

Date and time of the most recent occurrence of the error. 
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▼ Display the Drive Media Events Report

Note – This feature is available starting with SL3000 firmware version FRS_2.30 and 
SL Console version FRS_4.30. 

The Drive Media Events Report summarizes media events that have occurred on 
library drives. The report is updated whenever a media event or error occurs. You can 
use the report to help identify and diagnose faulty drives or cartridges.

For each drive that has experienced media events, the report lists the VOLID of the 
cartridge, the type of event, the number of occurrences, and the date and time of the 
last such event. The report can display up to 500 entries. 

By default, the report is sorted in drive serial number order. Optionally, you can 
change the sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 39. 

Note – For cartridge errors not necessarily associated with drives, see “Display the 
Media Events Report” on page 142. 

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Drive Media Events. 
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Screen Fields
Serial Number

Serial number of the drive.

Drive Type

Brand and model of the drive.

Cartridge Label 

VOLID of the cartridge that has experienced an event. 

Event Type

Type of media event being tracked. Options are:

■ Media Error – The drive indicated there was a problem with the media; this could 
possibly also indicate a problem with the drive.

Number of Events 

Total number of events of this type that have been recorded for this cartridge on this 
drive. 

Last Seen

Date and time of the most recent occurrence of the event. 
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Drive Cleaning Tasks

Note – The drive cleaning tasks apply only to drives managed by FC-SCSI attached 
hosts. They do not apply to drives managed by HSC or ACSLS. 

Task Page

Configure Drive Auto Clean 162

Enter Cleaning or Diagnostic Cartridges 164

Eject Cleaning or Diagnostic Cartridges 166

Display Cleaning Cartridges 168

Display Drive Cleaning Status 169

Clean a Drive Manually 170
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▼ Configure Drive Auto Clean
Use this procedure to enable or disable the drive auto clean feature. If the library is 
partitioned, auto clean can be enabled or disabled for individual partitions. 

Note – This procedure applies only to drives that are not managed by HSC or ACSLS. 
See the HSC and ACSLS documentation for details about how they manage automatic 
cleaning operations. 

1. Select Tools > System Detail, and select the library folder on the device tree.

2. Click Auto Clean and then Configure.

The Configure Auto Clean screen appears. 
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3. Complete the Auto Clean Configuration section as follows:

For SL3000 partitions or whole libraries controlled by the ACSLS or HSC tape 
management software, automatic cleaning should always be disabled on this screen. 
ACSLS or HSC will manage the automatic cleaning function. See the ACSLS or HSC 
documentation for details. 

For SL3000 partitions or whole libraries controlled by FC-SCSI hosts, you can select 
“enable” to manage automatic cleaning through the SL Console, or you can select 
“disable” to manage drive cleaning manually. 

If the library is partitioned, you can use the individual pull-downs to enable or disable 
auto-cleaning separately for each partition. If the library is not partitioned, you only 
need to set the first pull-down (Partition 1 (Or None)); the other pull-downs will be 
ignored. 

4. In the Auto Clean Configuration section, specify the warning thresholds for each 
cartridge type.

5. Click Apply.
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▼     Enter Cleaning or Diagnostic Cartridges
Use this procedure to enter new cleaning or diagnostic cartridges to the library through 
a CAP. 

Note – This procedure applies to non-partitioned libraries only.  

Before beginning this procedure, verify that all the following conditions are met:

■ The required number of reserved cells are empty. 

■ The CAP Prevent/Allow state is set to Allow (see your SCSI Reference Manual for 
syntax).

■ The CAP does not contain any data cartridges. 

Note – If the CAP is in auto enter mode, you can proceed directly to Step 5. 

1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, click the CAP you want to use, and click the Access tab. 

The Access screen appears.
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3. In the Locked pull-down, click false. Click the Apply button. 

The Confirm popup appears. 

4. Click OK.

The library controller unlocks the CAP door and the CAP Open LED is turned on.

5. Push the CAP button to open the CAP. 

The CAP door opens. 

6. Place the cleaning or diagnostic cartridges in the CAP.

7. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

8. Manually move each cartridge to a reserved cell. See “Move a Cartridge From a 
Specified Location” on page 140 for detailed instructions. 

When all cartridges have been moved from the CAP, the library recognizes that the 
CAP is empty and the CAP is returned to its default state. 

Note – To display a list of cleaning and diagnostic cartridges in the reserved slots, see 
“Display Cleaning Cartridges” on page 168. 
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▼ Eject Cleaning or Diagnostic Cartridges
Use this procedure to eject expired cleaning or diagnostic cartridges through the CAP.

Note – This procedure applies to non-partitioned libraries only.  

Note – Before beginning this procedure, verify that all slots are empty in the CAP you 
want to use.

1. Manually move each diagnostic or cleaning cartridge you want to eject, from a 
reserved cell to a CAP. See “Move a Cartridge From a Specified Location” on page 140 
for detailed instructions. 

Note – To display a list of cleaning and diagnostic cartridges in the reserved slots, see 
“Display Cleaning Cartridges” on page 168. 

2. Select Tools > Diagnostics. 

3. Expand the CAP Folder, click the CAP you want to use, and click the Access tab. 

The Access screen appears.
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4. In the Locked pull-down, click false. Click the Apply button. 

The Confirm popup appears. 

5. Click OK.

The library controller unlocks the CAP door and the CAP Open LED is turned on.

6. Push the CAP button to open the CAP. 

The CAP door opens. 

7. Remove all the cartridges from the CAP.

You must use care when ejecting expired cleaning cartridges from the library. If you 
move an expired cleaning cartridge to a CAP and open the CAP, you must remove the 
cartridge. If you close the CAP without removing the cleaning cartridge first, the 
TallBot will re-enter the expired cartridge into the library, and the library controller 
will reset the usage count to zero. 

8. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns off.

9. The TallBot audits the CAP to verify that it is empty.

The CAP is then returned to its default state. 
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▼ Display Cleaning Cartridges
1. Select Tools > System Detail, and select the library folder on the device tree.

2. Click Auto Clean and then Cleaning Cartridges.

The Library Cleaning Cartridges screen appears. 

The list displays the following details for each cleaning cartridge:

■ Cartridge location (reserved cells)

■ VOLID 

■ Usage Count 

■ Status (OK, warning, expired)

■ Cartridge Type (for example, LTO, SDLT)
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▼ Display Drive Cleaning Status 
Use this procedure to display the current cleaning status of a drive. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and select the drive you want to display. 

3. Click Status.

The screen displays the following cleaning details:

■ Drive needs cleaning

■ Drive Last Cleaned or Drive Last Autocleaned

Note – You can schedule manual drive cleaning by monitoring the “Drive needs 
cleaning” status. 
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▼ Clean a Drive Manually
Use this procedure to clean a drive. The SL3000 does not offer a dedicated manual 
drive cleaning function. Essentially, you must perform a manual mount of a cleaning 
cartridge on the drive. 

You can initiate a manual clean at any time, even if the drive is not due for cleaning. 

1. Display a list of cleaning cartridges. See “Display Cleaning Cartridges” on page 168 
for detailed instructions. 

Your library could contain more than one type of drive. So verify that the reserved cells 
have the appropriate cleaning cartridges for the drive being cleaned. 

2. Manually move a cleaning cartridge from a reserved cell to the drive that needs 
cleaning. See “Move a Cartridge From a Specified Location” on page 140 for detailed 
instructions. 

3. Display the status of the cleaning operation on the Drive Clean Status Console. See 
“Display Drive Cleaning Status” on page 169 for detailed instructions. 

4. When the cleaning operation is complete, move the cleaning cartridge from the drive 
back to a reserved cell. See “Move a Cartridge From a Specified Location” on page 140 
for detailed instructions.
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Robot and Power Supply Monitoring 
Tasks

Task Page

Display Robot Summary Information 172

Display Robot Status 173

Display Robot Properties 174

Display Power Supply Summary Information 175

Display Power Supply Detail 176

Display Power Supply Summary Information 175

Display Power Supply Detail 176
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▼ Display Robot Summary Information
Use this procedure to display summary information for the library TallBots. 

Note – This information is also available through Reports > Robot Summary. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail. 

2. Click the Robot folder on the device tree.

The Robot Data screen appears. 
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▼ Display Robot Status 
Use this procedure to display the current operational state of a TallBot. 

Note – This information is also available through Reports > Robot Details. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to display. 

3. Click Status.

The screen displays the current status of the selected TallBot. 
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▼ Display Robot Properties 
View detailed TallBot configuration information, including the serial number and 
current firmware levels.

Note – This information is also available through Reports > Robot Details. See 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to display. 

3. Click Properties. 

The Robot Properties screen appears. 
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▼ Display Power Supply Summary Information
The Power Supply Data screen displays summary information for all power supplies in 
the library. You can use this screen to monitor the status of the power supplies. 

By default, the display is sorted by power supply internal address. Optionally, you can 
change the sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 39. 

1. Select Tools > System Detail.

2. On the Library tree, click the Power Supply Folder.

3. The Power Supply Data screen is displayed. 
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▼ Display Power Supply Detail 
The Power Supply Status screen displays detailed information for a selected power 
supply. You can use this screen to determine whether the power supply is in need of 
maintenance or replacement. 

1. Select Tools > System Detail.

2. On the Library tree, expand the Power Supply Folder.

3. Click the power supply you want to display.

4. The Power Supply Status screen is displayed. 
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AEM Safety Door Management Tasks

Task Page

Display AEM Safety Door Status 178

Display AEM Safety Door Properties 179
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▼ Display AEM Safety Door Status 
Use this procedure to display the current state of an AEM safety door. The safety door 
is the internal “garage” door, which lowers to separate the AEM from the rest of the 
library. 

Note – Status information on the AEM access door, which is the door you open to bulk 
load or unload cartridges to or from the library, is displayed on the CAP Status screen. 
See “Display Current Rotational or AEM CAP Status” on page 116 for detailed 
instructions. 

1. Select Tools > System Detail. 

2. Expand the Safety Door Folder, and click the safety door you want to display. 

3. Click Status.

The Safety Door Status screen appears. 

"Door open” indicates that the safety door is up and the TallBot is free to move in and 
out of the AEM. “Door closed” indicates that the safety door is down and it is safe for 
you to open the AEM access door. 
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▼ Display AEM Safety Door Properties
Use this procedure to display detailed information for an AEM safety door, including 
the serial number and current firmware versions. The safety door is the internal 
“garage” door that lowers in preparation for you to open the AEM access door.

Note – This information is also available through the CAP Properties screen and the 
CAP Details report. See “Display Rotational or AEM CAP Properties” on page 119 and 
“Display a Library Report” on page 102 for detailed instructions. 

1. Select Tools > System Detail. 

2. Expand the Safety Door Folder, and click the safety door you want to display. 

3. Click Properties.

The Safety Door Properties screen appears. 
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CHAPTER 4

Licensing

The licensing utility allows you to install selected optional features on the SL3000 
library. 

License Key File
A license key file can be delivered to you in the following ways:

■ Via e-mail from Sun Microsystems, Inc.

■ Installed by your Sun support representative

The license key file is a digitally signed Java Archive (.jar) file containing one or more 
license keys for features you have purchased. In order to ensure that features are 
installed on the correct library, the license key file includes the serial number of the 
target library and can only be installed on that library. 

All licensed SL3000 features you have purchased for a library are included in a single 
license key file. 

Caution – When you install a new license key file, it overlays any previously installed 
license on the library. Therefore, it is essential that you verify the contents of a new 
license key file before installing it, in order to ensure that it contains all features you 
have purchased over the life of the library. If it does not contain all the features you 
have purchased, when you install the new file you could potentially remove features 
that have previously been installed on the library. If a license key file is inaccurate in 
any way, you should request a new one from your Sun support representative. 
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License Expirations

Note – Most SL3000 licenses do not expire. The only license that expires is “Service.” 

For licenses that expire, it is important to manage the expirations in order to prevent 
unintended loss of library features and function.

You can use the License Management > Current License screen to display the 
expiration dates and time remaining. 

In addition, when a license is close to expiring, the library controller sends messages to 
the SL Console Event Log. For example, if a Service license is due to expire within 
30 days, an information message is sent every 12 hrs, and if the Service license has less 
than 10 days remaining, a warning message is sent every 12 hours. You can use either 
of the following methods to view these messages:

■ Through the Tools > Reports menu option. See “Library Reports” on page 67 for 
details. 

■ Through the Status Module screen. See “Status Alert Messages” on page 68 for 
details. 



Licensing Tasks

316194401 • Revision AB Chapter 4 Licensing 183

Licensing Tasks 
This section provides detailed instructions for all tasks involved in installing and 
managing library feature licenses. 

License Installation Process
Following is a summary of the license installation process. Optionally, you can choose 
to have this process done by your Sun support representative. 

1. You purchase one or more features for a specific Sun StorageTek library from Sun 
Microsystems, Inc. 

2. Sun sends you an e-mail with an attached license key file. 

3. You download the license key file to a system accessible to the SL Console session.

4. You use the SL Console to display and verify the contents of the license key file. 

5. You use the SL Console to install the license key file on the target library.

6. See the following topics for detailed information about implementing specific 
licensed features:

■ “Capacity on Demand” on page 203

■ “Library Partitioning” on page 247
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Licensing Task Summary

Task Page

Receive a New License Key File 185

Display and Verify New License Contents 186

Install a New License on the Target Library 189

Display Current Library License 192
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▼ Receive a New License Key File
Use this procedure to receive a license key file, which licenses features for a specific 
Sun StorageTek library. 

Note – This procedure is not performed at the SL Console. 

1. Purchase one or more features from Sun Microsystems, Inc. 

See your Sun support representative for assistance. 

2. Receive the license key file from Sun, via e-mail. 

Following is a sample of the e-mail header: 
Subject:     SL3000 License Key CR6636975 
Date:     Wed, 05 Dec 2007 19:24:41 -0700 (MST) 
From:     siks-devoffshore@sun.com

3. Download the license key file to a system accessible to the SL Console session.

Use the standard method for saving e-mail attachments. 
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▼ Display and Verify New License Contents
Use this procedure to display a new license key file before installing it on a target 
library. 

Prior to performing this procedure, you must download a new license key file to a 
system accessible to the SL Console session. See “Receive a New License Key File” on 
page 185. 

1. Use the SL Console to log in to the target library. 

See “Log in to the SL Console” on page 35 for details. 

2. Select Tools > License Management, and click the Install License tab. 

The Install License screen appears.
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3. In the File Name field, enter the full path of the license key file you want to display, 
and press Enter. Optionally, you can click Browse and navigate to the file location. 

The License File details appear in the lower part of the screen. 

Note – If the library serial number in the specified license key file does not match the 
serial number of the library you are logged in to, a warning appears and the license key 
file detail is not displayed. 
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4. Review the license key file details, and then click Compare. 

The Compare Licenses popup appears. 

5. Review the license information.

Note – Changes that will be installed by the new license key file, such as expiration 
date changes or features that will be removed, are highlighted in red. 

If there are problems with the new file, contact your Sun support representative to 
resolve the problems before installing the file on the target library. 

Caution – There is no license “rollback” function to restore removed features once a 
new license key file is installed. 

6. Click OK to dismiss the popup. 
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▼ Install a New License on the Target Library
Use this procedure to install a new license key file on the target library. 

Prior to performing this procedure, you must download a new license key file to a 
system accessible to the SL Console session. See “Receive a New License Key File” on 
page 185. 

1. Use the SL Console to log in to the target library. 

See “Log in to the SL Console” on page 35 for details. 

2. Select Tools > License Management, and click the Install License tab. 

The Install License screen appears.

3. In the File Name field, enter the full path of the license key file you want to install, 
and press Enter. Optionally, you can click Browse and navigate to the file location.

The License File details appear in the lower part of the screen. 
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Note – If the library serial number in the specified license key file does not match the 
serial number of the library you are logged in to, a warning appears and the license key 
file detail is not displayed. 

4. Review the license key file details, and then click Install in the Options Bar. 

The License Installation Warning popup appears.

5. Review the Features to be Installed and verify that the new license key file is 
accurate. 

Note – Changes that will be installed by the new license key file, such as expiration 
date changes or features that will be removed, are highlighted in red. 

If there are problems with the new file, click No to cancel the installation. Contact your 
Sun support representative to resolve the problems before continuing with the 
installation. 

Caution – There is no license “rollback” function to restore removed features once a 
new license key file is installed. 

6. If the new license key file is accurate, click Yes to begin installing the license on the 
target library. 

7. The library controller verifies the license key file and proceeds as follows:

■ If there are no problems, the features included in the file are installed. 
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■ If the new license key file is older than the one currently installed on the library, the 
following popup appears and the new license is not installed. 

8. You can verify that the license has been installed successfully by displaying the 
current licenses. See “Display Current Library License” on page 192 for details. 

9. Depending on the features included in the license key file, you may need to perform 
additional tasks in order to use the new features. 

■ See “Increasing Licensed Capacity” on page 209 and “Decreasing Licensed Capacity” 
on page 209 for special considerations that apply when you install a license key file 
that changes the licensed capacity of the library.

■ See “Installing the Partitioning Feature” on page 248 for special considerations that 
apply when you install a license key file with the Partitioning feature. 
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▼ Display Current Library License 
Use this procedure to display the features currently installed on the library you are 
logged in to. 

1. Select Tools > License Management, and click the Current License tab. 

The Current License screen appears, listing the currently installed features. See 
“License Management > Current License” on page 194 for detailed information about 
the screen fields. 
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Licensing Screen Reference
This section includes detailed descriptions of all SL Console licensing screens, arranged 
by screen navigation path. For example, License Management > Install License— 
Compare indicates the screen accessed by clicking Tools and then License 
Management from the Menu Bar, and then clicking the Install License tab, and then 
the Compare button. 

Note – You can access the licensing screens only from the standalone SL Console or the 
Web-launched SL Console. They are not available on the local operator panel. 

Screen Page

License Management > Current License 194

License Management > Install License 196

License Management > Install License—Compare 199

License Management > Install License—Install 201
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License Management > Current License

Sample Screen

Description
Displays the contents of the license key file currently installed on the library you are 
logged in to. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 39 for details. 

Screen Fields
Feature 

Display only.

Name of the feature installed on the library. 

Expiration 

Display only.
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Number of days until the feature is due to expire or has expired. If there is no 
expiration date, the field displays “noExpiration.” 

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity feature, this 
field displays the total capacity the license provides. Depending on the feature, the 
field may be blank or indicate “None”. 

Time Remaining

Display only.

Amount of time remaining until the expiration of the feature. If there is no 
expiration date, the field is blank. 

Buttons
Refresh

Click to refresh the display with current data from the library controller database. 

? (Help) 

Click to display online help for the screen. 

See Also
■ License Management > Install License 



Licensing Screen Reference

196 SL3000 User’s Guide • May 2009 Revision AB • 316194401

License Management > Install License

Sample Screen

Description
Allows you to display the contents of a new license key file. 

Also includes buttons that allow you to initiate any of the following activities:

■ Compare the new license key file with the one currently installed on the library. 

■ Install the new license key file on the library. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 39 for details. 

Screen Fields
File Name

Required.



Licensing Screen Reference

316194401 • Revision AB Chapter 4 Licensing 197

Enter the full path of the license key file you want to install on the library. 
Optionally, you can click Browse and navigate to the file location. The file must be 
located on a system accessible to the SL Console session, and the serial number 
specified in the file must match the serial number of the library you are logged in to. 

Product

Display only.

Type of library the license key file is for. For example, SL3000, SL8500, SL500. 

Serial Number

Display only.

Serial number of the library the license key file is for. This entry must match the 
serial number of the library you are logged in to in order for the license key file to be 
valid for this library. 

Generated On

Display only.

Date when the license key file was created. 

Comment Line 1

Display only.

Optional comment concerning the license key file, from Sun Microsystems, Inc. 

Comment Line 2

Display only.

Optional comment concerning the license key file, from Sun Microsystems, Inc. 

Feature

Display only.

Name of a feature included in the license key file.

Expiration

Display only.

Number of days until the feature is due to expire. If there is no expiration date, the 
field displays “noExpiration.” 

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity feature, this 
field displays the total amount of storage capacity the license provides. Depending 
on the feature, the field may be blank. 

Buttons
Install

Click to install the displayed license key file on the library you are logged in to.The 
License Management > Install License—Install popup appears. 

Browse

Click to navigate to the license key file you want to display and install.
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Note – If the library serial number in the specified license key file does not match the 
serial number of the library you are logged in to, a warning appears and the license key 
file detail is not displayed. 

Compare

Click to compare the new license key file with the one currently installed on the 
library. The License Management > Install License—Compare popup appears. 

? (Help) 

Click to display online help for the screen. 

See Also
■ License Management > Current License 

■ License Management > Install License—Compare 

■ License Management > Install License—Install 
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License Management > Install License—Compare 

Sample Screen

Description
Allows you to compare the following sets of license information: 

■ Features currently installed on the library you are logged in to. 

■ Features included in the new license key file you have specified in the License 
Management > Install License screen. 

Note – Changes that will be installed by the new license key file, such as expiration 
date changes or features that will be removed, are highlighted in red. 

This screen is a popup that appears when you click Compare on the License 
Management > Install License screen. 

Screen Fields
Current Features

Display only.

List of features, expiration dates, and values for all features currently installed on the 
library you are logged in to. 
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Features to be Installed

Display only.

List of features, expiration dates, and values for all features included in the specified 
new license key file. Changes that will be installed by the new license key file, such 
as expiration date changes or features that will be removed, are highlighted in red. 

Buttons
OK

Click to dismiss the popup and return to the previous screen. 

See Also
■ License Management > Install License 

■ License Management > Install License—Install 
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License Management > Install License—Install 

Sample Screen

Description
Allows you to compare the following sets of license information: 

■ Features currently installed on the library you are logged in to. 

■ Features included in the new license key file you have specified in the License 
Management > Install License screen. 

Warning messages are displayed if installation of the new license key file will result in 
features being removed from the library. 

After comparing the license information, you can install the new license key file on the 
library by clicking the Yes button. 

Caution – It is very important that you carefully verify the accuracy of the new license 
key file before installing it, as there is no “rollback” function to restore removed 
features. 

This screen is a popup that appears when you click Install on the License 
Management > Install License screen. 
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Depending on the features included in the license key file, you may need to perform 
additional tasks in order to use the new features.

■ See “Increasing Licensed Capacity” on page 209 and “Decreasing Licensed Capacity” 
on page 209 for special considerations that apply when you install a license key file 
that changes the licensed capacity of the library.

■ See “Installing the Partitioning Feature” on page 248 for special considerations that 
apply when you install a license key file with the Partitioning feature. 

Screen Fields
Current Features

Display only.

List of features, expiration dates, and values for all features currently installed on the 
library you are logged in to. 

Features to be Installed

Display only.

List of features, expiration dates, and values for all features included in the specified 
new license key file. Warning messages are displayed if installation of the license 
key file will result in features being removed from the library. 

Buttons
Yes

Click to install the specified license key file on the library. The library controller 
verifies the validity of the license key file and installs it. 

No 

Click to cancel the update and return to the previous screen. 

See Also
■ License Management > Install License 

■ License Management > Install License—Compare 
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CHAPTER 5

Capacity on Demand

The SL3000 library includes RealTimeGrowth™ and Capacity on Demand features. 
RealTimeGrowth allows you to install physical storage capacity beyond your current 
needs. Capacity on Demand separates physical from licensed capacity and allows you 
to pay only for the capacity you need. Then as your needs grow, you can expand 
storage capacity with minimal disruption to library operations. To activate additional 
capacity, you need only purchase and install a license key file for the new capacity.

Note – Library storage capacity must be installed through the SL3000 licensing utility. 
See Chapter 4, “Licensing” for details. 

Note – This feature controls cartridge storage cells only. All installed CAPs and tape 
drives are active by default. 

Capacity on Demand Features and 
Restrictions
This section describes important features and restrictions of Capacity on Demand that 
will help you to plan for and use the feature in your SL3000 library. 

■ The minimum licensed capacity is 200 storage cells. 

■ The maximum licensed capacity is equal to the physical capacity of the library, 
which is 5821 cells. 

■ You can purchase additional licensed capacity in increments of 1, 100, 200, 500, or 
1000 cells. 

■ Installation of additional licensed capacity results in minimal disruption to library 
operations. Once verified by the library controller, the additional storage cells are 
available immediately; you do not need to reboot the library. Depending on the host 
interface (HLI or FC-SCSI), there may be a brief interruption in host operations as 
the hosts update the new resource information. See “Non-disruptive Capacity 
Changes” on page 207 for details. 

■ A library’s current licensed storage capacity is equal to the capacity specified in the 
most recently installed license key file. 
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■ Changes to active capacity can be made with minimal disruptions to library 
operations. See “Non-disruptive Capacity Changes” on page 207 for details.

Terminology
The following terms are used to describe library capacity management:

■ Physical or installed capacity – The number of storage cells physically present in the 
library.

■ Licensed capacity – The number of storage cells the library is licensed to use. This 
cannot exceed the installed capacity. 

■ Active capacity – The number of licensed storage cells that are activated for use. By 
default, this is the same as the licensed capacity. You can optionally de-activate 
selected storage cells, making this less than the licensed capacity. 

■ Active storage region – A rectangular area of storage cells that are activated for use. 
An active storage region can be as small as a single storage cell or as large as the 
total licensed capacity for the library. 

■ Active cell – A storage cell that is activated for use. Only activated cells can be used 
for cartridge storage.

■ Inactive cell – A storage cell that is explicitly de-activated and therefore cannot be 
used for cartridge storage. 

■ Selected cell – A storage cell that is not currently active, but will be activated 
automatically by the library controller when licensed capacity is increased. 

Active Storage Region Configuration
Active storage regions can be assigned automatically by the library controller or 
manually by the user. Automatic assignment by the library controller provides 
balanced growth of library modules.

Individual storage cells can be in either of the following states:

■ Active – The cell can be used for cartridge storage. 

■ Inactive – The cell has been de-activated, and therefore cannot be used for cartridge 
storage. You can monitor the cell on library displays and reports, but requests to 
move cartridges to the cell are rejected by the library controller. 

■ Selected – The cell is not currently active, but will be activated automatically by the 
library controller when licensed capacity is increased. This state applies to non-
partitioned libraries only. 

Only active storage cells can be used for tape cartridge storage. Inactive storage cells 
cannot be used for cartridge storage, nor can they be accessed by any hosts. 
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Cell Activation Rules
The library controller uses the following rules when adding cells to active storage 
regions:

■ Cell activation starts in the left upper rear of the active storage region and moves to 
the right lower front. 

■ All cells within a column are activated from top to bottom before moving to the next 
column. 

■ Columns within a panel are activated from left to right. 

Non-Partitioned Libraries
Within a non-partitioned library, the library controller automatically selects all physical 
cells, but only activates a number of cells up to the total licensed capacity of the library. 
Selected cells that cannot be activated due to licensed capacity limits remain selected 
and will be activated automatically whenever additional licensed capacity is installed.

When activating cells, the library controller begins at the back of the library, starting 
with the left-most module and working to the right. Then it moves to the front of the 
library, starting with the left-most module and working to the right. 

To optimize cartridge placement, you can optionally designate active storage regions in 
the library, within which the library controller applies the rules above. 

Partitioned Libraries
In partitioned libraries, the total number of storage cells allocated to all library 
partitions cannot exceed the licensed capacity of the library.

In partitioned libraries, there is no default active storage region. You must explicitly 
assign storage cells to partitions, thereby configuring the active storage regions for each 
partition. See “Partitioning Process” on page 263 for details. 

When placing cartridges in storage cells, the library controller applies the predefined 
cell activation rules separately to each partition. See “Cell Activation Rules” on 
page 205 for details. 

De-activating Storage Capacity 
You can optionally reduce the size of an active storage region by de-activating 
designated storage cells. A warning message is displayed if cartridges will be orphaned 
due to the capacity reduction.



Active Storage Region Configuration

206 SL3000 User’s Guide • May 2009 Revision AB • 316194401

Orphaned Cartridges in Non-Partitioned Libraries

Note – For a discussion of orphaned cartridges in partitioned libraries, see “Orphaned 
Cartridges in Partitioned Libraries” on page 253. 

In non-partitioned libraries, an orphaned cartridge is a cartridge located in an inactive 
storage cells. Orphaned cartridges are inaccessible to all hosts. 

A cartridge can become orphaned for a variety of reasons. Following are some possible 
causes:

■ Active storage capacity has been reduced.

■ The cartridge has been moved to an inactive or inaccessible cell through manual 
intervention. 

If the SL Console identifies an orphaned cartridge, it displays a warning message. You 
can then use the following tools to help you resolve and disposition the orphaned 
cartridge:

■ Generate a report of orphaned cartridges. 

■ Perform an audit of the library. 

■ Perform a recovery move on a cartridge. 

For detailed instructions on checking for and resolving orphaned cartridges, see the 
following procedures:

■ “Display an Active Storage Region Report” on page 219

■ “Commit Active Storage Region Changes” on page 216
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Non-disruptive Capacity Changes
Changes to active capacity result in minimal disruptions to library operations. The 
specific library behavior depends on the type of host connection, as described in the 
following sections:

■ “Active Capacity Changes and HLI Connections” on page 207

■ “Active Capacity Changes and FC-SCSI Connections” on page 208

Caution – Although changes to active capacity are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other users before committing 
your active storage region changes. Because the SL Console does not validate storage 
region boundaries against the library controller database in real-time, configuration 
conflicts may arise if you change active storage region boundaries while other users are 
performing cartridge movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 38 for details. 

Active Capacity Changes and HLI Connections
With HLI libraries, you can increase active capacity without stopping host jobs or 
having host connections go offline. When you decrease capacity, the library goes offline 
only momentarily and then comes back online automatically.

Adding Active Capacity 
Whenever you add active storage cells, the library stays online. The library controller 
sends an asynchronous message to all hosts notifying them that the library 
configuration has changed. The hosts experience a brief interruption as they update 
their library configuration information, and then they automatically continue 
processing jobs. 

Removing Active Capacity 
Whenever you make any of the following types of capacity changes, the library goes 
offline temporarily. 

■ De-activate a storage cell

■ Remove an empty drive slot 

After the configuration change is updated in the library controller database, the library 
comes back online and the library controller sends an asynchronous message to all 
hosts notifying them that the library configuration has changed. The hosts experience a 
brief interruption as they update their library configuration information, and then they 
automatically continue processing jobs. 
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Active Capacity Changes and FC-SCSI Connections
With FC-SCSI libraries, whenever you make any of the following changes, the library 
goes offline temporarily with a Unit Attention condition: 

■ Activate or de-activate a storage cell

■ Add, change, or remove a host connection

■ Remove an empty drive slot 

Multiple error messages may be generated, and all hosts must issue the appropriate 
commands to update their library configuration information. See the appropriate tape 
management software documentation for detailed procedures and commands. In the 
case of adding or removing drives, the device SCSI numbering is updated as well.
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Increasing Licensed Capacity
The following special considerations apply after you successfully install a capacity 
license providing additional capacity. See Chapter 4, “Licensing” on page 181 for 
details on installing license key files. 

■ The new library capacity is equal to the capacity specified in the most recently 
installed license key file. 

■ You do not need to reboot the library in order to begin using the new capacity, but 
you must configure all affected library host applications to recognize the new 
capacity. See “Non-disruptive Capacity Changes” on page 207 for details. 

■ If the new licensed capacity exceeds the physical capacity, a warning is displayed. 
No corrective action is necessary. 

■ If the library is not partitioned, the library controller automatically activates cells 
that have not been explicitly de-activated by the user previously. In this case, no user 
intervention is required to make the new licensed capacity available. If cells have 
been de-activated, however, you may need to manually select cells in order to start 
using the additional capacity. 

■ If the library is partitioned, all new capacity is added as unallocated cells. You must 
allocate new storage cells to partitions manually in order to start using the cells; see 
“Design a Partition – Base, DEM, or CEM Modules” on page 271 for details. 

Decreasing Licensed Capacity
The following special considerations apply after you successfully install a capacity 
license resulting in reduced capacity. See Chapter 4, “Licensing” on page 181 for details 
on installing license key files.

Note – Installing reduced capacity is an exceptional situation; be sure this is what you 
really want to do before installing the license key file. 

■ A warning appears if cartridges will be orphaned as a result of the reduced capacity. 
See “Orphaned Cartridges in Non-Partitioned Libraries” on page 206 for details.  

■ For non-partitioned libraries:

■ The new, reduced capacity takes effect immediately. 

■ The library controller de-activates cells in reverse order of their activation – the 
cells activated most recently are de-activated first. 

■ For partitioned libraries:

■ If the total number of cells allocated to all partitions exceeds the new licensed 
capacity, the library is automatically taken offline. You must manually de-allocate 
cells from partitions so the total allocation does not exceed the new licensed 
capacity.

■ If the total number of cells allocated to all partitions is still less than the new 
licensed capacity, the new reduced capacity takes effect immediately with no 
change to the existing partition allocations. The library continues operations 
without interruption. 
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Capacity Management Tasks 
This section provides detailed instructions for all tasks involved in implementing and 
managing active storage capacity in the library. 

Storage Capacity Installation Process
Following is a summary of the process used to install new library storage capacity. 

1. You purchase and install a capacity license for the library. See “License Installation 
Process” on page 183 for details. 

2. The new licensed capacity is available immediately. You do not need to re-boot the 
library. 

3. In non-partitioned libraries, by default, all newly activated cells are immediately 
available for use. Proceed as follows:

■ If you want to use the default storage region configuration assigned by the library 
controller, you must configure all affected library host applications to recognize 
the new storage regions. See “Non-disruptive Capacity Changes” on page 207 for 
details. 

■ If you want to modify the storage region configuration from the default, see 
“Define Active Storage Regions” on page 213. 

4. In partitioned libraries, all newly activated cells are added as “unallocated,” and are 
therefore not available for use. You must manually allocate the new cells to 
partitions. See “Partitioning Process” on page 263 for detailed instructions. 

SL Console Active Storage Region Workspace
The Select Active Cells screens, and all associated popups, give you a dynamic 
workspace to customize your licensed capacity configuration. All licensed capacity 
configuration information is automatically saved to the active storage region workspace 
in SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among active storage region views and leave and return to the 
Select Active Cells screens any number of times without losing your configuration 
changes.

Information in the SL Console active storage region workspace is committed to the 
library controller database only through the Apply button on the 
Select Active Cells > Select Active Cells screen. The information is lost if any one of the 
following occurs before you have committed your updates: 

■ You actively log off the SL Console session.

■ The SL Console session times out or the connection to the library is lost. 

■ You actively refresh the active storage region workspace from the current library 
controller database. This is done through the Refresh button on the 
Select Active Cells screens. 
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Caution – Although changes to active capacity are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other users before committing 
your active storage region changes. Because the SL Console does not validate storage 
region boundaries against the library controller database in real-time, configuration 
conflicts may arise if you change active storage region boundaries while other users are 
performing cartridge movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 38 for details. 
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Capacity Management Tasks

Note – The following tasks apply to non-partitioned libraries only. For detailed 
instructions on configuring storage regions for partitioned libraries, see “Partitioning 
Process” on page 263. 

Note – The following tasks can be performed only from the standalone SL Console or 
the Web-launched SL Console. They cannot be performed at the local operator panel. 

Task Page

Define Active Storage Regions 213

Commit Active Storage Region Changes 216

Display an Active Storage Region Report 219

Print Active Storage Region Report Data 221

Save Active Storage Region Report Data 222

Display Active Cell Detail 223
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▼ Define Active Storage Regions 

Note – See “License Installation Process” on page 183 for information about installing 
licensed capacity. 

When you install additional licensed capacity, the library controller automatically 
activates the number of storage cells equal to the licensed capacity. It uses a set of 
internal rules when choosing the actual cells to activate. See “Active Storage Region 
Configuration” on page 204 for details. 

Use this procedure only if you want to do one of the following:

■ Customize the active storage regions so they are different from the default 
configuration assigned by the library controller. For example, you can configure 
active storage cells so that cartridges are concentrated around the drives and the 
ends of the library are left for future growth. 

■ De-activate storage cells, so the total number of active storage cells is less than the 
licensed capacity. 

■ De-select storage cells, so these cells will not be automatically activated when the 
library’s licensed capacity is increased. 

Note – If you want to use the default storage region configuration defined by the 
library controller, you do not need to use this procedure. 
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1. Select Tools > Select Active Cells. 

The Module Map screen appears.

2. Click the module for which you want to define the active storage regions. 

3. Click the Select Active Cells tab.

The Select Active Cells screen appears, displaying the current configuration of the 
module you have selected.
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Note – The first time you display this screen, the number of selected cells is equal to 
the physical capacity of the library, and the number of active cells is equal to the 
library’s total licensed capacity. 

Note – Click the Move Left or Move Right buttons to display a module directly 
adjacent to the one currently displayed. 

4. Choose the Select by method, and click either the Add or Remove radio button.

5. Use the library map to select the storage cells you want to activate or de-activate. 

Note – See “Select Active Cells > Select Active Cells” on page 228 for detailed 
instructions on using the library map. 

Your capacity configuration changes are saved to the SL Console active storage region 
workspace for the duration of this login session. You can make additional 
modifications and leave and return to the Select Active Cells screens any number of 
times without losing your changes.

6. When you are done making changes, proceed to “Commit Active Storage Region 
Changes” on page 216 to verify and commit your changes. 
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▼ Commit Active Storage Region Changes 
Use this procedure to verify and commit active storage region configuration changes 
you have made on the Select Active Cells screen. This procedure warns you of the 
following possible errors:

■ The library has orphaned cartridges. See “Orphaned Cartridges in Non-Partitioned 
Libraries” on page 206 for details.

■ Cells will be made inaccessible to library hosts. 

Caution – Although changes to active capacity are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other users before committing 
your active storage region changes. Because the SL Console does not validate storage 
region boundaries against the library controller database in real-time, configuration 
conflicts may arise if you change active storage region boundaries while other users are 
performing cartridge movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 38 for details. 

1. Perform the steps in “Define Active Storage Regions” on page 213. 

The changes you have made are displayed on the Select Active Cells screen. 

2. In the Options Bar, click Apply. 

The boundaries of the active storage regions are verified, including the locations of all 
tape cartridges. 
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Note – This verification is performed only on the active storage region configuration 
defined in the Select Active Cells screens. It does not verify active storage regions 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made changes to active storage 
regions. 

The Confirm Apply popup appears, indicating whether there are any orphaned 
cartridges or other problems in the active storage region configuration. 

3. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 

You can use the Details button to toggle between the expanded and collapsed views of 
the warning messages. 

4. Optionally, in the expanded view of the warning messages you can do the following:

■ Click Print to print the detailed message data.

■ Click Save to File to save the detailed message data to a comma-separated file. 

5. Proceed as follows:
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■ Click No to cancel the update. 

The library controller database is not updated, but all changes you have made are 
retained on the Select Active Cells screen. 

■ Click Yes to make the following updates to the library controller database and 
proceed to Step 6. 

■ White cells with a “dog-eared” left corner are made inactive.

■ Purple cells without a “dog-eared” left corner are made active, up to the total 
licensed capacity of the library. Purple cells that cannot be activated due to 
licensed capacity limits will remain purple and will be activated automatically 
whenever additional licensed capacity is installed. 

■ All other cells are left unchanged. 

The Commit Success popup appears. 

6. Click OK to return to the Select Active Cells screen. 

All newly activated cells are immediately available for use; the library does not need to 
be rebooted. 

7. All affected library host applications must now be configured to recognize these 
updates. See the appropriate tape management software documentation for the 
procedures and commands.
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▼ Display an Active Storage Region Report 
Use this procedure to display the following active storage region reports:

■ Cartridge Cell and Media Summary – Displays a detailed list of all library resources 
and their status (active or inactive).

■ Orphaned Cartridge Report – Displays a detailed list of all orphaned cartridges.

Note – The active storage region reports display data saved to the library controller 
database. If you have made changes to the active storage region configuration without 
commiting the changes to the library controller, the data in these reports will differ 
from data shown on Select Active Cells screen. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.
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2. In the pull-down menu, select the report you want to display. 

The screen is updated with current data from the library controller database. 

3. If you want to print the report data or save it to a file, see the following procedures:

■ “Print Active Storage Region Report Data” on page 221

■ “Save Active Storage Region Report Data” on page 222 
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▼ Print Active Storage Region Report Data
Use this procedure to print an active storage region report. This procedure can be 
performed from any of the active storage region report screens. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to File 
buttons. 

3. Click Print. 

The Print popup appears. 

4. Complete the print popup, and click Print. 

The report is printed to the selected printer. 
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▼ Save Active Storage Region Report Data
Use this procedure to save active storage region report data to a comma-separated file 
(.csv format). You can use a variety of spreadsheet applications to view the file. This 
procedure can be performed from any of the active storage region report screens. 

1. Select Tools > Select Active Cells, and click the View Reports tab.

The View Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to File 
buttons. 

3. Click Save to File.

The Save popup appears. 

4. Browse to the directory where you want to save the file, and enter the file name. 

5. Click Save. 

The data is saved to the specified file. 
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▼ Display Active Cell Detail 
Use this procedure to display which storage cells are currently active, inactive, or 
selected for activation. You can also display detailed information about cartridge, drive, 
and storage cell locations. 

Note – This procedure is available on the local operator panel.

1. Select Tools > Select Active Cells. 

The Module Map screen appears.

2. Click the module you want to display. 
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3. Click the Current Active Cells tab.

The Active Cells screen appears, displaying the current configuration of the module 
you have selected.

You can mouse-over a cell or drive to display a tooltip of detailed information. 
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Active Storage Region Screen Reference
This section includes detailed descriptions of all SL Console active storage region 
screens, arranged by screen navigation path. For example, 
Select Active Cells—Select Active Cells—Confirm Apply indicates the screen accessed 
by clicking Tools and then Select Active Cells from the Menu Bar, and then clicking 
the Select Active Cells tab, and then the Confirm Apply button. 

Note – These screens are available for non-partitioned libraries only. See “Partition 
Screen Reference” on page 312 for the screens used in managing capacity in partitioned 
libraries. 

Note – Only the Select Active Cells—Current Active Cells screen is available on the 
local operator panel. The remaining screens can be accessed only from the standalone 
SL Console or the Web-launched SL Console.

Note – The Select Active Cells screen, and all associated popups, give you a dynamic 
workspace to design active storage regions. All active cell information is automatically 
saved to the storage region workspace in SL Console memory and retained for the 
duration of your SL Console session. This allows you to make modifications and leave 
and return to the Select Active Cells screens any number of times without losing your 
changes. 

Caution – Information in the SL Console active storage region workspace is saved to 
the library controller database only through the Apply button. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Apply button, you will lose any active storage region changes you 
have made through the Select Active Cells screens and all associated popups. 

Screen Page

Select Active Cells > Module Map 226

Select Active Cells > Select Active Cells 228

Select Active Cells > Select Active Cells—Confirm Apply 234

Select Active Cells—View Reports—Cartridge Cell and Media 
Summary

239

Select Active Cells—View Reports—Orphaned Cartridge Report 242

Select Active Cells—Current Active Cells 245
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Select Active Cells > Module Map

Sample Screen

Description
Allows you to select the library module for which you want to activate or de-activate 
cells for cartridge storage. 

Screen Fields
Select a module from the map below 

The screen displays an illustration of the library’s actual module configuration. This 
information is taken directly from the library controller database. 

Click the module for which you want to select storage cells, then click the 
Select Active Cells tab. 
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Buttons
? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells > Select Active Cells 
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Select Active Cells > Select Active Cells

Sample Screen

Description

Note – If you want to use the default active storage region configuration defined by 
the library controller, you do not need to use this screen. 

Allows you to define active library storage regions by selecting the storage cells you 
want to activate or de-activate for use. This allows you to configure active storage cells 
so that cartridges are concentrated around the drives, and the ends of the library are 
left for future growth.

You can activate any number of cells up to the total licensed capacity of the library. 
Selected cells that cannot be activated due to licensed capacity limits will remain 
selected and will be activated automatically whenever additional licensed capacity is 
installed. 

You can use any of the following methods to select storage cells (see “Library Map” on 
page 231 for detailed instructions): 
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■ Select individual cells or groups of cells 

■ Select an entire column within a library module 

■ Select a side within a library module (front or back) 

■ Select an entire library module 

■ Select all cells within the library 

Caution – De-activating storage cells can result in orphaned cartridges and 
inaccessible data. See “Orphaned Cartridges in Non-Partitioned Libraries” on page 206 
for details. 

Note – You can select storage cells only; installed CAPs and tape drives are always 
active. 

Note – The Select Active Cells screen, and all associated popups, give you a dynamic 
workspace to design active storage regions. All active cell information is automatically 
saved to the storage region workspace in SL Console memory and retained for the 
duration of your SL Console session. This allows you to make modifications and leave 
and return to the Select Active Cells screens any number of times without losing your 
changes. 

Caution – Information in the SL Console active storage region workspace is saved to 
the library controller database only through the Apply button. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Apply button, you will lose any active storage region changes you 
have made through the Select Active Cells screens and all associated popups. 

Screen Fields
Select by

Required.

Indicates the method you want to use for selecting storage cells to activate or de-
activate. Options are:

■ Cell – Select individual or rectangular groups of cells.

■ Column – Select all cells within a column. 

■ Side – Select all cells within one side of a library module. 

■ Module – Select all cells within a library module. 

■ Library – Select all cells within the library. 

Note – You must select either Add or Remove. 

Add 

Required.
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Indicates you want to add cells to the active storage region. You will only be able to 
click inactive cells on the library map. 

Remove

Required.

Indicates you want to remove cells from the active storage region. You will only be 
able to click active or selected cells on the library map. 

Current Library Totals

Capacity

Display only.

Total licensed storage capacity of the library. 

Active Cells

Display only.

Total number of storage cells that have been activated for use in the library 
controller database. This cannot be greater than the licensed Capacity. 

Selection Totals 

Selected Cells 

Display only.

Total number of selected and active cells. This can be greater than the licensed 
Capacity. 

Unselected Cells 

Display only.

Total number of de-selected and inactive cells. 

Note – Selected Cells + Unselected Cells = library physical capacity

% Capacity Used 

Display only.

Percentage of total licensed capacity that has been selected for use (cannot be greater 
than 100%). Calculated as:

Selected Cells / (licensed) Capacity 

Interface Type 

Required.

Type of interface to be used for the library host connection. Options are:

■ HLI

■ FC-SCSI 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 



Active Storage Region Screen Reference

316194401 • Revision AB Chapter 5 Capacity on Demand 231

Note – For additional details about modifying this field, see “Change the Library 
Interface Type (Non-Partitioned Libraries)” on page 99. 

Legend 

Legend for the library map. The state of each library resource (storage cell, tape drive, 
or CAP cell) is indicated as follows: 

■ Not Accessible (white and x-ed out). Resource is not accessible to any host. 
Following are some possible reasons:

■ Storage cells have been configured for diagnostic cartridges. 

■ Drive bay has no installed drive. 

■ CAP has been configured for storage, not CAP operations. 

■ Inactive (white). Storage cell is not selected. 

■ If the cell also has a “dog-eared” left corner, it is currently activated for use in the 
library controller database and you have selected this cell to be removed from the 
active storage region. The cell will be made inactive in the library controller 
database when you click the Apply button.

■ If the cell does not have a “dog-eared” left corner, it is currently inactive in the 
library controller database. There will be no change to the cell’s status in the 
library controller database when you click the Apply button. 

■ Active (“dog-eared” left corner). Indicates the status of the storage cell in the library 
controller database:

■ Cells with a “dog-eared” left corner are currently active. 

■ Cells with no “dog-eared” left corner are currently inactive. 

■ Selected (purple). Storage cell is selected. Cells can be selected automatically by the 
library controller or manually by the user. 

■ If the cell also has a “dog-eared” left corner, it is currently activated for use in the 
library controller database. There will be no change to the cell’s status in the 
library controller database when you click the Apply button.

■ If the cell does not have a “dog-eared” left corner, it is currently inactive in the 
library controller database and you have selected this cell to be added to the 
active storage region. When you click the Apply button, the cell will be made 
active in the library controller database, up to the total licensed capacity of the 
library. Purple cells that cannot be activated due to licensed capacity limits will 
remain purple and will be activated automatically whenever additional licensed 
capacity is installed. 

■ No Activation Needed (brown). Resource cannot be selected on this screen because it 
is active by default; applies to all CAP cells and tape drives. 

■ Cartridge (cartridge icon). Resource contains a tape cartridge. 

■ Drive slots with installed drives are outlined with a thick border. Empty drive slots 
have a narrow border. 

Library Map 
Graphical representation of the current library configuration. Initial display for the 
current SL Console login session is from the library controller database, then the 
display reflects your modifications. The display includes the following information:
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■ Type of module currently displayed (base module, drive expansion module, 
access expansion module, parking expansion module.) 

■ Numeric module ID (1–12)

■ Location of all resources (storage cells, tape drives, CAP cells) within the library 

Note – Move the cursor over any resource to display a tooltip of detailed information 
about the cell or drive, whether it is active in the library controller database, whether it 
is currently selected on the screen, and the identity of any resident cartridge. 

Use the library map to modify the boundaries of the active storage capacity areas. 
Depending on whether you have clicked the Add or Remove radio button, cells you 
click will be selected or de-selected. 

Depending on your choice in the Select by field, you can perform any of the 
following actions. 

■ Select by cell – Select individual or groups of resources. Active storage cells do 
not need to be adjacent to one another. 

- To select an individual storage cell, double-click it.

- To select a rectangular group of storage cells, click the cell at one corner of the 
rectangle, and then click the cell diagonally opposite. 

■ Select by column – Select an entire column within the module. Columns of active 
cells do not need to be adjacent to one another. Click any storage cell within the 
column you want to select. 

■ Select by side – Select all storage cells within an entire module side. Active sides 
do not need to be adjacent to one another. Click any storage cell within the side 
you want to select. 

■ Select by module – Select all storage cells within a module. Active modules do not 
need to be adjacent to one another. Click any storage cell within the module you 
want to select. 

■ Select the library – Select all storage cells in the library. Click any storage cell in 
the library. 

Buttons
Move Left 

Click to display the library module directly to the left of the one currently displayed. 
This button is grayed out if there is no module to the left. 

Move Right 

Click to display the library module directly to the right of the one currently 
displayed. This button is grayed out if there is no module to the right. 

Apply 

Click to update the library controller database with the current settings from the 
screen. The Confirm Apply popup appears, indicating whether there are any 
orphaned cartridges or other errors in the active storage region configuration. 

Note – This button is grayed out if you have not made any changes to the 
Select Active Cells screen since the last update. 
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The status of the cells will be updated in the library controller database, as follows: 

■ White cells with a “dog-eared” left corner are made inactive.

■ Purple cells without a “dog-eared” left corner are made active, up to the total 
licensed capacity of the library. Purple cells that cannot be activated due to 
licensed capacity limits will remain purple and will be activated automatically 
whenever additional licensed capacity is installed. 

■ All other cells are left unchanged. 

Refresh

Click to refresh the screen with current data from the library controller database. All 
unapplied active storage region changes you have made during this SL Console 
login session will be discarded. The Cell Selection Refresh popup appears, 
prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells > Module Map 

■ Select Active Cells > Select Active Cells—Confirm Apply 

■ Select Active Cells—Current Active Cells 
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Select Active Cells > Select Active Cells—Confirm 
Apply

Sample Screen

Description
Displays a list of configuration errors in the defined active storage regions. This screen 
is a popup that appears when you click Apply on the 
Select Active Cells > Select Active Cells screen. 

After viewing the error messages, you can commit all data from the Select Active Cells 
screen to the library controller database by clicking the Yes button. 

Caution – Although changes to active capacity are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other users before committing 
your active storage region changes. Because the SL Console does not validate storage 
region boundaries against the library controller database in real-time, configuration 
conflicts may arise if you change active storage region boundaries while other users are 
performing cartridge movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 38 for details. 

Possible errors include:

■ The library has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” on page 253 for details.
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■ Storage cells have been removed from the library. 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the library 
controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 

Screen Fields
Warnings found

Display only.

Summary error messages regarding the storage region configuration. 

Library 

Display only.

Library number where the orphaned cartridge is located. This is always “1”. 

Rail 

Display only.

Rail number where the orphaned cartridge is located. This is always “1”. 

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Cause for Orphaned State

Display only.

Reason why the cartridge has been identified as orphaned. Options include:

■ Just Activated 

■ Inactive Media 

Vol Ser 

Display only.

Volume serial number (VOLID) of the orphaned cartridge. 
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Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Some possible options are:

■ Media was found in an inactive cell. 

■ Inactive cell with media was just activated. 

Buttons

Note – To display the Print and Save to File buttons, you may need to scroll down 
within the inner window. 

Print

Click to print the report on a selected printer.

Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Yes

Click to confirm that you want to update the library controller database with the 
current settings from the Select Active Cells. The status of the cells are updated in 
the library controller database, as follows: 

■ White cells with a “dog-eared” left corner are made inactive.

■ Purple cells without a “dog-eared” left corner are made active, up to the total 
licensed capacity of the library. Purple cells that cannot be activated due to 
licensed capacity limits will remain purple and will be activated automatically 
whenever additional licensed capacity is installed. 

■ All other cells are left unchanged. 

No

Click to cancel the update. The library controller database is not updated, but the 
current settings on the Select Active Cells are retained. 

Details 

Click to toggle between the expanded and collapsed views of the warning message 
display. 

See Also
■ Select Active Cells > Select Active Cells 
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Select Active Cells—View Reports

Sample Screen

Description
Allows you to select one of the following active storage region reports:

■ Cartridge Cell and Media Summary

■ Orphaned Cartridge Report

Note – The active storage region reports display data saved to the library controller 
database. If you have made changes to the active storage region configuration without 
commiting the changes through the Apply button, the data in these reports will differ 
from data shown on the Select Active Cells screen. 

Screen Fields
Please select a report to display

Required.
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Click the report you want to display. The drop-down menu lists all available active 
storage region reports. 

Buttons
Apply 

Click to update the library controller database with the current settings from the 
screen. The Confirm Apply popup appears, indicating whether there are any 
orphaned cartridges or other errors in the active storage region configuration. 

Note – This button is grayed out if you have not made any changes to the 
Select Active Cells screen since the last update. 

Refresh

Click to refresh the screen with current data from the library controller database. All 
unapplied active storage region changes you have made during this SL Console 
login session will be discarded. The Cell Selection Refresh popup appears, 
prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells > Select Active Cells 

■ Select Active Cells—View Reports—Cartridge Cell and Media Summary 

■ Select Active Cells—View Reports—Orphaned Cartridge Report 
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Select Active Cells—View Reports—Cartridge Cell 
and Media Summary

Sample Screen

Description
Displays detailed information about all library resources (storage cells, tape drives, and 
CAP cells) and any stored cartridges.

Note – The active storage region reports display data saved to the library controller 
database. If you have made changes to the active storage region configuration without 
commiting the changes to the library controller, the data in these reports will differ 
from data shown on Select Active Cells screen. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 39 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields
Library 

Display only.

Library number where the library resource is located. This is always “1”. 

Rail 

Display only.

Rail number where the library resource is located. This is always “1”. 

Column

Display only.

Column number where the library resource is located. Column location is referenced 
from the left edge of the Base Module. “+1” is to the right; “-1” is to the left.

Side

Display only.

Module side where the library resource is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the library resource is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Element Type

Display only.

Type of library resource. Options are:

■ CAP
■ CELL
■ DRIVE

Vol Ser 

Display only.

Volume serial number (VOLID) of the cartridge resident in the library resource, if 
applicable. 

Cell Status

Display only.

Capacity status of the library resource. Applies to storage cells only. Options are:

■ Active – Cell is activated for use and can be used for cartridge storage. 

■ Inactive – Cell is not activated for use and cannot be used for cartridge storage. 

Buttons
Print

Click to print the report on a selected printer.
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Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells—View Reports

■ Select Active Cells—View Reports—Orphaned Cartridge Report
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Select Active Cells—View Reports—Orphaned 
Cartridge Report 

Sample Screen

Description
Displays the locations and volume serial numbers (VOLIDs) of all orphaned cartridges 
in the library. Also identifies why the cartridge is orphaned. 

Note – The active storage region reports display data saved to the library controller 
database. If you have made changes to the active storage region configuration without 
commiting the changes to the library controller, the data in these reports will differ 
from data shown on Select Active Cells screen. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 39 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields
Library 

Display only.

Library number where the orphaned cartridge is located. This is always “1”. 

Rail 

Display only.

Rail number where the orphaned cartridge is located. This is always “1”. 

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Vol Ser 

Display only.

Volume serial number (VOLID) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Some possible options are:

■ Media was found in an inactive cell. 

■ Inactive cell with media was just activated. 

Buttons

Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 
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See Also
■ Select Active Cells—View Reports 

■ Select Active Cells—View Reports—Orphaned Cartridge Report 
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Select Active Cells—Current Active Cells

Sample Screen

Description
Displays current active library storage regions. Shows which storage cells are currently 
active, inactive, or selected for activation.

This is the only Select Active Cells screen that is available on the local operator panel.

Note – This screen is display only. 

Screen Fields
For detailed descriptions of the screen fields, see 
“Select Active Cells > Select Active Cells” on page 228. 
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Buttons
Refresh

Click to refresh the display with current data from the library controller database. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Select Active Cells > Select Active Cells 
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6

Library Partitioning

Note – Library partitioning is a licensed feature which must be installed through the 
SL3000 licensing utility. See Chapter 4, “Licensing” for details. 

Library partitioning allows sections of the SL3000 library to be assigned for exclusive 
use by specified hosts. For example, you can configure one group of storage cells and 
drives to be used only for Veritas operations, and another group only for Tivoli 
operations.This allows you to configure an SL3000 library for applications running on 
multiple operating systems. 

Partitioning Features and Restrictions
This section describes important features and restrictions of library partitioning that 
will help you to configure and use partitioning in your SL3000 library. 

■ You can configure up to eight partitions within an SL3000 library. 

■ A partition can be as small as a single storage cell or tape drive, or a whole rotational 
or AEM CAP. Cells and drives within a partition do not need to be adjacent. 

■ Storage cells and tape drives allocated to a partition can be used only by the hosts 
assigned to that partition. Hosts assigned to other partitions cannot access the 
contents of these cells and drives. See “Storage Cells and Drives” on page 253 for 
details. 

■ Storage cells and drives not allocated to any partition cannot be accessed by any 
hosts. For example, you might leave an area of cells unallocated, in preparation for 
future partitioning. 

■ Host-partition connections can use either the FC-SCSI or HLI (TCP/IP) interface. 

■ Whole rotational or AEM CAPs can be allocated for exclusive use by one partition, 
or they can be shared by multiple partitions. See “Partitions and Rotational and 
AEM CAPs” on page 255 for details.

■ CAPs can only be shared by partitions with the same host interface type. That is, 
FC-SCSI and HLI partitions cannot both share the same CAP. 

■ With the non-disruptive partitioning (NDP) feature, there is minimal host disruption 
whenever resources are allocated to a partition, and changes made to one partition 
do not impact other partitions or their host connections. See “Non-Disruptive 
Partitioning” on page 260 for details. 
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Enabling and Disabling Partitioning
In order for you to use partitions in a library, the partitioning feature must be installed 
through the licensing utility.See Chapter 4, “Licensing”  on page 181 for details. 

A library with partitioning enabled can be in either of the following states: 

■ Partitioned – The library has at least one user-defined partition with a valid partition 
ID. 

■ Non-partitioned – The library has no user-defined partitions. A non-partitioned 
library behaves in the same manner as a library that does not have partitioning 
enabled; that is all active storage cells, drives, and rotational and AEM CAPs are 
accessible to all hosts. 

To disable partitioning on a library, you must first delete all partitions. The library state 
will then change to “non-partitioned.” 

Partition Planning
The partitioning feature offers great flexibility in the use of your library. It also requires 
careful planning, a thorough knowledge of library wall and storage cell mapping, and 
expertise in configuring and administering host software applications. There must be 
clear communication among all parties involved, including system programmers and 
administrators, library operators, and your Sun service representative. 

Before creating partitions, you must plan the storage area that is needed for resident 
tape cartridges and anticipate the number of required free cells. You must understand 
the boundaries of each partition and the host ownership relationships. You must verify 
that all tape drives and cartridges have been moved to the proper locations, according 
to the planned  assignments.   

Installing the Partitioning Feature
The following special considerations apply after you successfully install the 
Partitioning feature on a previously non-partitioned library. 

■ You can begin creating partitions immediately; you do not need to reboot the library 
first.

■ Until you create at least one partition, the library remains in a non-partitioned state; 
that is all licensed storage cells, drives, and rotational and AEM CAPs are accessible 
to all hosts. 

Allocated Storage Capacity
In partitioned libraries, the total number of storage cells allocated to all library 
partitions cannot exceed the licensed capacity of the library. 
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In partitioned libraries, there is no default active storage region. You must explicitly 
assign storage cells to partitions, thereby configuring the active storage regions for each 
partition. See “Partitioning Process” on page 263 for details. 

When assigning cartridges to storage cells, the library controller applies the predefined 
cell selection rules separately to each partition. See “Cell Activation Rules” on page 205 
for details. 

Partition Configurations
You must use the standalone SL Console or Web-launched SL Console to configure 
library partitions; the partitioning screens are not available on the local operator panel. 

To configure a partition, you must define the following information: 

■ Partition Summary Information

■ Host-Partition Connections

■ Partition Boundaries

For detailed instructions on defining library partitions, see “Partitioning Process” on 
page 263. 

Partition Summary Information
Partition summary information includes the partition ID, name, and host-partition 
connection type (HLI or FC-SCSI). Partition IDs must be unique and can range  
from 1–8. 

Host-Partition Connections
Host-partition connections identify the hosts that are able to access a partition. Each 
partition appears to the host as a separate library. A host can control one or more 
partitions. In addition, it is possible for more than one host to control a single FC-SCSI 
partition, but it is recommended that you exercise caution in implementing this 
configuration, as some host applications may not allow for resource sharing. 

HLI Host-Partition Connections

An HLI (Host Library Interface) partition can have up to 16 assigned hosts. You define 
the HLI host-partition connection configuration through the library management 
software (ACSLS or HSC). Therefore there are no SL Console screens to display or 
maintain this information. See the appropriate tape management software 
documentation for details. 

FC-SCSI Host-Partition Connections

An FC-SCSI partition can have one or more host-partition connections. The host-
partition connection configuration is user-defined and consists of the following 
information: 

■ World Wide Port Name of theFC-SCSI host bus adapter 
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■ Port number of the library Fibre Channel card 

■ Logical unit number (LUN) of the partition on the host 

See “Configure a Host-Partition Connection” on page 269 for detailed instructions on 
defining this information. 

Partition Boundaries
Partition boundaries identify the storage cells, drives, and rotational and AEM CAPs 
that are part of each partition. Only unallocated cells can be added to a partition, and 
only allocated cells can be removed. 

You can define partition boundaries in any of the following ways:

■ Select individual cells or rectangular groups of cells to add or remove from a 
partition. Cells or cell groups do not have to be contiguous.

■ Select a module column to add or remove from a partition. Columns do not have to 
be contiguous. 

■ Select an entire module side (front or back) to add or remove from a partition. Sides 
do not have to be contiguous. 

■ Select an entire module to add or remove from a partition. Modules do not have to 
be contiguous. 

Note – It is possible to have partitions with no allocated resources. 

Partitions and Library Resources

Library Resource Addresses 
Resource addresses uniquely identify each resource (storage cells, drives, and rotational 
and AEM CAPs) within the library. The SL3000 library and attached hosts use the 
following addressing schemes: 

■ Library Internal Address

■ Host FC-SCSI Element Address

■ HLI-PRC Address

Each partition appears to a host as a separate library; this is reflected in the partition 
address. 
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Library Internal Address
The library internal address is used by the SL3000 library controller and the SL Console 
device tree to identify the physical location of each resource. The addressing scheme 
used by the SL3000 is a five-digit, comma-separated value, specifying the library, rail, 
column, side, and row, as viewed from the front of the library, facing the drive bays. 

The format of the SL3000 library internal address is l,r,c,s,w where:

■ l = library or partition number; this value is always “1”. 

■ r = rail number; this value is always “1”.

■ c = column number. Column numbering is referenced from the left edge of the Base 
Module, as you face the inside back wall, as follows:

■ Numbering is static, allowing modules to be added without renumbering existing 
columns. 

■ Columns within and to the right of the Base Module are numbered positively (+), 
in ascending sequence from left to right. 

■ Columns to the left of the Base Module are numbered negatively (-), in 
descending sequence from right to left. 

■ Base Module panels are always “1” to “6”. 

■ DEM panels (if present) are always “-1” to “-6”.

■ If there is no DEM and a CEM is to the left of the Base Module, then columns 
“-1” to “-6” are skipped and the CEM is assigned columns “-7” to “-12”. 

■ CEM columns to the right of the Base Module start with “7”. 

■ Left AEM columns are always numbered “–33” to “–31”. Right AEM columns are 
always “31” to “33”. In other words, AEM columns are numbered as if a DEM 
and four CEMS are installed to the left, and four CEMs are installed to the right, 
of the Base Module. 

■ s = side. Back wall = “1”; front wall = “2”.

■ w = row number. Numbered consecutively from the top, down. Valid values are 
“1” to “52”, with row “1” at the top. 

Host FC-SCSI Element Address
TheFC-SCSI element address is used by hosts with an FC-SCSI connection to the SL3000 
library to uniquely identify each library resource available to the host. 

FC-SCSI element numbering uses a single integer to identify each library resource. 
FC-SCSI element numbering within partitioned libraries is continuous for each 
partition, even if cell locations for the partition are not adjacent. FC-SCSI element 
addresses for a partition start at the lowest module, row, and column within the 
partition, then proceed by row until the end of the column, then increment by column 
until the end of the module. 

When additional resources are allocated to an existing FC-SCSI partition, the original 
resources are not renumbered. This helps to minimize disruption to the FC-SCSI host. 

FC-SCSI Element Address Examples

If a library’s base and storage expansion modules are allocated to Partition 1 and the 
drive module is allocated to Partition 2, FC-SCSI element numbering is as follows:
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■ Numbering for Partition 1 begins at the first available storage cell in the Base 
Module and continues through the last available cell in the storage module cell. 

■ Numbering for Partition 2 begins with the first available storage cell in the drive 
module PRC Address and ends with the last available cell in that module. 

HLI-PRC Address
The HLI-PRC (Host Library Interface-Panel, Row, Column) address is used by hosts 
with an HLI connection to the SL3000 library, including ACSLS and HSC. The HLI-PRC 
address uniquely identifies each library resource accessible to the host and is assigned 
by the host software.

The HLI-PRC address is an eight-digit value specifying the library, panel, row, and 
column where the resource is located. The format is ll:pp:rr:cc, where:

■ ll = Library number; this value is always “00”. 

■ pp = Panel number. Numbering is relative to the Base Module, as follows:

■ Base Module panels are always “12” and “13”. 

■ Modules to the left of the Base Module are numbered in descending sequence, 
starting with “11”; modules to the right are numbered in ascending sequence, 
starting with “14”. 

■ Rear walls are assigned even numbers; front walls are assigned odd numbers. 

■ DEM panels (if present) are always “10” and “11”.

■ If there is no DEM and a CEM is to the left of the Base Module, then panels “10” 
and “11” are skipped and the CEM is assigned panels “8” and “9”. This allows 
you to add a DEM to the left of the Base Module at a later date without 
renumbering modules. 

■ For AEM panel numbering, see “HLI CAP numbering – rotational and AEM 
CAPs” on page 252. 

■ rr = Row number within the panel. Numbered consecutively from the top, down. 
Valid values are 0–51, with row 0 at the top. 

■ cc = Column number within the panel. Numbered consecutively from left to right, 
starting at the front of the module. Each panel has a maximum of six columns; 
therefore, valid column values are 0–5. 

HLI CAP numbering – rotational and AEM CAPs

Note – HSC displays HLI-PRC addresses in hexadecimal notation. Therefore, panels 
10, 11, and 12 are displayed as “0A”, “0B”, and “0C” respectively. ACSLS and the 
SL Console display HLI-PRC addresses in decimal notation. 

Library CAP numbers are assigned by module, from left to right: 

■ Base Module CAP = 6

■ DEM CAP = 5

■ Rotational CAPs in CEMs to the left of the Base Module = 1–4

■ Rotational CAPs in CEMs to the right of the Base Module = 7–10

■ AEM CAP to the left of the Base Module = 0

■ AEM CAP to the right of the Base Module = 11
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Rotational CAPs contain a single column of cells with 26 rows; cells are numbered 0–25. 

The AEM contains a bulk load CAP with 234 cells arranged in six columns. Column 
numbering starts at the rear wall and runs left to right (columns 0–2); then proceeds to 
the front wall and runs left to right (columns 3–5). 

Storage Cells and Drives 
All storage cells, tape drives, and cartridges allocated to a partition are owned 
exclusively by the assigned host and cannot be accessed by other hosts. For example, if 
a group of tape drives is allocated to a partition, only the host assigned to that partition 
can use those drives. 

Storage cells and drives that are not allocated to any partition cannot be accessed at all. 
For example, you can leave an area of cells unallocated in preparation for a planned 
future partition. 

On the SL Console screens and reports, storage cells and drives appear in any of the 
following states:

■ Allocated – Assigned to the current partition. 

■ Unallocated (or Unassigned) – Not assigned to any partition; available to be assigned 
to any current partition. 

■ Unavailable – Assigned to another partition. 

■ Not accessible – Not available for host operations; for example, cells reserved for 
diagnostic cartridges, cells that are physically blocked, and cells that are inactive. 

Note – TallBots are shared resources and cannot be allocated exclusively to a partition. 

To display partition assignments for storage cells and drives, see 
“Partitions—Reports—Cartridge Cell and Media Summary” on page 362. 

Orphaned Cartridges in Partitioned Libraries

Note – For a discussion of orphaned cartridges in non-partitioned libraries, see 
“Orphaned Cartridges in Non-Partitioned Libraries” on page 206. 

In partitioned libraries, an orphaned cartridge is a cartridge located in an unallocated 
cell or drive (that is, a cell or drive not allocated to any defined partition). 

Caution – If a host encounters an orphaned cartridge it might treat the cartridge as 
scratch and overwrite the data. Therefore, it is very important to disposition orphaned 
cartridges properly. 

A cartridge can become orphaned for a variety of reasons. Following are some possible 
causes:

■ Partition boundaries have changed.

■ A partition has been deleted. 
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■ The cartridge has been moved to an unallocated or inaccessible cell through manual 
intervention. 

If the SL Console identifies an orphaned cartridge, it displays a warning message. You 
can then use the following tools to help you resolve and disposition the orphaned 
cartridge:

■ Generate a report of orphaned cartridges. 

■ Perform an audit of the library. 

■ Perform a recovery move on a cartridge. 

For detailed instructions on checking for and resolving orphaned cartridges, see the 
following procedures:

■ “Verify Partition Configurations” on page 276

■ “Resolve Orphaned Cartridges” on page 279

■ “Commit Partition Configuration Changes” on page 280
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Partitions and Rotational and AEM CAPs 

Note – AEM CAPs are subject to the same partitioning rules and restrictions as 
rotational CAPs. Throughout this section, the term “CAP” refers to both types of CAPs. 

Note – The SL3000 does not support common CAPs, split CAPs, or the allocation of 
individual CAP cells to a partition. These features are available for the SL500 only. 

When configuring CAPs, you must plan carefully for anticipated CAP usage. A 
partition can only use the CAPs explicitly allocated to it. There is no “common” CAP in 
the SL3000. 

When you allocate a CAP to a partition, all cells in the CAP are allocated as a whole. It 
is not possible to allocate or de-allocate individual cells within a CAP. There is no 
“split” CAP in the SL3000. 

CAP Allocations
All CAPs in a partitioned library are unallocated by default. You allocate CAPs to 
partitions through the following screens:

■ “Partitions—Design (Step 3b)” on page 336, for Base, Drive, and CEM modules

■ “Partitions—Design (Step 3b) – AEMs Only” on page 342, for AEM modules

CAP allocations can take either of the following forms:

■ Dedicated – The CAP is allocated for the exclusive use of one partition.

■ Shared – The CAP is allocated for the use of more than one specified partition. See 
“Shared CAPs” for details. 

Once a CAP is allocated, it becomes either an FC-SCSI CAP or an HLI CAP, depending 
on the host interface type of the first partition to which it is allocated. For example, if 
you allocate a previously unallocated CAP to a partition with an FC-SCSI interface, the 
CAP becomes an FC-SCSI CAP. Subsequent allocations of the CAP can be to other 
FC-SCSI partitions only. To change the CAP from FC-SCSI to HLI, you must first de-
allocate the CAP from all FC-SCSI partitions, and then allocate the CAP to an HLI 
partition.

Note – CAP allocations are not required; it is possible to have partitions with no 
allocated CAP. 

Note – Because FC-SCSI host applications typically do not use CAP reservations, it is 
recommended that you dedicate at least one CAP to each FC-SCSI partition whenever 
possible. This allows each partition to operate independently from the others and 
allows you to avoid the resource contention issues that can arise through shared CAPs. 
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Shared CAPs
Because a library can have more partitions than CAPs, it may be necessary to share 
CAPs among partitions. Only partitions with the same host interface type can share a 
CAP. For example, any number of FC-SCSI partitions can share a group of one or more 
CAPs, and any number of HLI partitions can share a different group of CAPs, but HLI 
and FC-SCSI partitions cannot both share any of the same CAPs. 

For ease of management, it is recommended that you keep shared CAP groupings 
together for all partitions they are allocated to. For example, if you allocate CAPs A and 
B to one partition, and another partition also needs access to A or B, you should 
allocate both CAPs, not just one of them, to the second partition. 

Note – You must carefully manage shared CAP usage among FC-SCSI hosts in order to 
avoid contention. See “CAP “Ownership”” on page 256 for details. 

CAP Auto Enter Mode 
CAP auto enter mode allows a library operator to open a CAP and initiate an enter 
operation without issuing an explicit enter request and without an explicit reservation 
from a host application. Auto enter mode is available for CAPs that have been 
dedicated to a partition. CAPs in auto enter mode are left unlocked. 

Auto enter mode is managed by the host applications. See the appropriate tape 
management software documentation for details. 

CAP “Ownership” 
A CAP can be used by only one partition at a time for enters and ejects. A partition can 
take ownership of a CAP in any of the following ways:

■ The CAP is dedicated to one partition. In this case the partition always has exclusive 
ownership of the CAP.

■ A host application reserves the CAP prior to an enter or eject operation. This 
typically applies to HLI host applications only. See “CAP Reservations” on page 257 
for details. 

■ The user explicitly associates the partition to the CAP. This applies to shared 
FC-SCSI CAPs only. See “Shared FC-SCSI CAP Associations” on page 259 for details. 

■ A partition places a cartridge in the CAP. If none of the conditions above apply, the 
first partition to place a cartridge in the CAP as part of an export operation takes 
ownership of the CAP until the export is completed and the CAP is closed and 
empty.

While a partition has ownership of a CAP, the CAP is reserved exclusively to that 
partition and unavailable to all others. The library sends “CAP opened” and “CAP 
closed” messages only to the host holding the reservation. 

For HLI CAPs only, when a host attempts to reserve a CAP already reserved by another 
partition, the library sends a message to the requesting host identifying the partition ID 
and host ID holding the reservation. 
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CAP States
A CAP must be unlocked in order for you to open it to insert or remove cartridges. 
When a CAP is unlocked, the light on the CAP button is turned on. 

When you close a CAP, the TallBot performs an audit to determine whether there are 
cartridges present. During the audit the CAP is locked and the light on the CAP button 
is turned off. Once the audit is completed, the CAP is returned to its default state. 

The following table describes the default states of the various types of CAPs within a 
partitioned library. 

CAP Reservations
Both FC-SCSI and HLI hosts can make use of CAP reservations. CAP reservations give 
a partition exclusive ownership of a shared CAP for the duration of an enter or eject 
operation. When the operation is finished, the host application must release the 
reservation to make the CAP available to other partitions sharing the CAP. No other 
partitions can access the CAP until the first one has terminated the operation and 
released the reservation. 

For a partition to reserve a CAP, the CAP must be unreserved (applies to shared CAPs 
only), empty, and closed. 

HLI CAP Reservations 
HLI host applications use a strict reservation scheme to manage CAP usage among host 
clients, and therefore always reserve a CAP before unlocking it or moving a cartridge to 
it. When an HLI host application attempts to reserve a CAP already reserved by 
another partition, the library controller sends a message to the requesting host 
identifying the partition ID and host ID holding the reservation. 

Type of CAP Default State

Default CAP 
Button Light 
Condition Comment

HLI – dedicated or 
shared 

Locked Off Host reservation unlocks the 
CAP and turns the light on. 
See “CAP Reservations” on 
page 257 for details. 

HLI – auto enter 
mode

Unlocked On

FC-SCSI – dedicated Unlocked On

FC-SCSI – shared Locked Off Partition-CAP association 
unlocks the CAP and turns 
the light on. See “Shared 
FC-SCSI CAP Associations” 
on page 259 for details.
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Releasing CAP Reservations 

In normal operations, a CAP reservation for an ACSLS or HSC host is released in the 
following ways:

■ Enter operations – After all cartridges have been successfully entered into the 
library, the host explicitly terminates the enter command. The library controller 
releases the CAP after verifying that the CAP is closed and empty. 

■ Eject operations – After all cartridges have been successfully ejected, the host 
automatically terminates the eject operation. The library controller releases the CAP 
after verifying that the CAP is closed and empty. 

If for some reason a CAP reservation is not released as described above, the CAP will 
be unavailable to all other partitions, and cartridges belonging to the first partition may 
remain in the CAP. In this case, it is recommended that you terminate the enter or eject 
from the host holding the reservation. This ensures a normal release of the CAP 
reservation. 

Note – See the ACSLS or HSC documentation for details about terminating enters and 
ejects. 

Overriding CAP Reservations 

In some cases, you may not be able to access the host holding a reservation and 
therefore cannot perform a normal release of the CAP. This may be because the host 
has terminated or because you lack physical access or security authorization to issue 
commands to the host. In these cases, you can override (unreserve) the CAP reservation 
manually. See “Override a CAP Reservation” on page 309 for the detailed procedure. 

Note – Use extreme care when using the SL Console to override a CAP reservation. If 
you do not complete the procedure, the CAP could be left unavailable to all partitions, 
and/or cartridges assigned to one partition could be entered into another partition.

Note – You can use the SL Console to override a CAP reservation only in a partitioned 
library. If a library is not partitioned, CAP reservations must always be released 
through ACSLS or HSC. 

FC-SCSI CAP Reservations 
Most FC-SCSI host applications do not use CAP reservations. FC-SCSI host applications 
typically assume sole ownership of a CAP and therefore do not coordinate CAP sharing 
well. To avoid contention among partitions for a shared CAP, you can manually 
associate a partition to a CAP. See “Shared FC-SCSI CAP Associations” on page 259 for 
details. 
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Shared FC-SCSI CAP Associations 
If a FC-SCSI partition shares CAPs with other partitions, it is recommended that you 
manually associate the partition to its CAPs prior to initiating an enter or eject 
operation. See “Associate an FC-SCSI Partition to Its Shared CAPs” on page 304 for the 
detailed procedure.

A partition-CAP association gives a partition exclusive ownership of its shared CAPs, 
similar to a CAP reservation. This ensures that cartridges are always entered into the 
correct partition and prevents other partitions from taking ownership of a shared CAP 
that is already in use. 

The following rules apply when making partition-CAP associations:

■ You can associate only one partition at a time to a CAP. 

■ Selecting a partition causes all its allocated CAPs to be associated to it at once; you 
cannot select individual CAPs to be associated to the partition. 

■ You can select multiple partitions at once, as long as the selected partitions do not 
share any CAPs with one another. 

■ Partition-CAP associations remain active until you explicitly remove them; the 
associations are not automatically removed when the enter or eject operation 
completes. 

■ Partition-CAP associations are removed during library reboots, power cycles, library 
door open/close operations, or CAP initializations 

■ Partition-CAP associations are removed if the CAP becomes allocated to a different 
partition through the Design (Step 3b) screen. 

■ If a partition-CAP association is removed while the CAP is open or has cartridges in 
it, the CAP ownership will be changed to the “default” requester and the CAP will 
be unavailable to all partitions. You must empty and close the CAP before it can be 
associated to any partitions. 
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Non-Disruptive Partitioning
The non-disruptive partitioning (NDP) feature minimizes the number of host 
interruptions that occur when partitions are modified. The library does not need to be 
taken offline for every partition change, and hosts are insulated from partition changes 
that do not affect them directly.

Prior to this feature, whenever a partition was changed in any way, all partitions would 
go offline while the library controller database was updated. As a result, library 
outages needed to be coordinated across all hosts connected to a partitioned library. 

The specific functions of the NDP feature vary, depending on the type of host-partition 
connection. For details, see the following sections:

■ “NDP and HLI Partitions” on page 260

■ “NDP and FC-SCSI Partitions” on page 261

Caution – Although partition changes are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other users before committing 
your partition workspace changes. Because the SL Console does not validate partition 
boundaries against the library controller database in real-time, configuration conflicts 
may arise if you change partition boundaries while other users are performing 
cartridge movements or library configuration changes. See “Synchronizing the Display 
With the Controller Database” on page 38 for details. 

NDP and HLI Partitions
With HLI partitions, you can allocate additional resources to a partition without 
stopping host jobs or having the partition go offline. In general, a partition goes offline 
only when resources are de-allocated. In all cases, neighboring partitions are always left 
undisturbed.

Allocating Additional Resources to a Partition
Whenever you make any of the following types of partition changes, the affected 
partition stays online: 

■ Allocate a storage cell 

■ Allocate a drive 

■ Allocate a CAP 

The library controller sends an asychronous message to all hosts connected to the 
partition that the library configuration has changed. The hosts experience a brief 
interruption as they update their library configuration information, and then they 
automatically continue processing jobs. 
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Removing Allocations from a Partition
Whenever you make any of the following types of partition changes, the affected 
partition goes offline briefly: 

■ De-allocate a storage cell

■ De-allocate a drive

■ Remove an empty drive slot

After the configuration change is updated in the library controller database, the 
partition automatically comes back online and the library controller notifies all hosts 
connected to the partition that a configuration change has occurred. The hosts 
experience a brief interruption as they update their library configuration information, 
and then they automatically continue processing jobs. 

NDP and FC-SCSI Partitions
With FC-SCSI partitions, you can allocate a CAP to a partition without stopping host 
jobs or having the partition go offline. 

All other changes to an FC-SCSI partition cause the affected partition to go offline with 
a Unit Attention condition. Neighboring partitions and their connected hosts are not 
disturbed.

Host Connection Changes
Host connection changes include the following activities:

■ Add a host-partition connection

■ Change the properties of a host-partition connection 

■ Delete a host-partition connection

Whenever you make any of these changes, the affected partition goes offline with a 
LUNS Data Has Changed Unit Attention condition. The hosts connected to the 
partition must issue the appropriate commands to update their library configuration 
information. See the appropriate tape management software documentation for 
detailed procedures and commands.

If a host has unique ITL nexus connection mappings for each partition connection, then 
only the partition experiencing the connection change is affected. However, because the 
SL3000 library supports only one target port (0), it is possible that a host with multiple 
partition connections may reference the same target/LUN pair for each one. In this 
case, whenever one host-partition conection is changed, all partitions the host has 
connections to are also affected. 

Partition Configuration Changes
Partition configuration changes include the following activities:

■ Allocate a storage cell 

■ Allocate a drive 

■ De-allocate a storage cell

■ De-allocate a drive
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■ De-allocate a CAP 

■ Remove an empty drive slot 

Whenever you make any of these changes, the affected partition goes offline with a 
Mode Parameters Have Changed Unit Attention condition. The hosts connected to the 
partition must issue the appropriate commands to update their library configuration 
information; see the appropriate tape management software documentation for detailed 
procedures and commands. In the case of adding or removing drives, the device SCSI 
numbering is updated as well. 
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Partitioning Process

Note – Library partitioning is a licensed feature which must be installed through the 
SL3000 licensing utility. See Chapter 4, “Licensing” for details. 

Partition Configuration Process
When configuring library partitions for the first time, it is recommended that you use 
the library partition screens in the following sequence: 

1. Instructions (Step 1) – Review summary instructions for the partition configuration 
process. 

2. Summary (Step 2) – Display summary partition configuration and host-partition 
connection information. Optionally access other screens to perform the following 
tasks:

■ Add Partition

■ Modify Partition

■ Delete Partition

Note – The following tasks are available for FC-SCSI host-partition connections only. 

■ Add Connection

■ Modify Connection

■ Delete Connection

3. Module Map (Step 3a) – Select the library module for which you want to design 
detailed partition boundaries. 

4. Design (Step 3b) – Display and optionally modify detailed partition boundary 
information. Optionally access other screens to perform the following tasks:

■ Verify Partition Configurations 

■ Refresh the display with current data from the library controller database

5. Commit (Step 4) – Commit all changes made in the Summary(2) and Design (3b) 
screens, and all associated popups, to the library controller database. Optionally 
access other screens to perform the following task: 

■ Refresh the display with current data from the library controller database

You can use the Reports screen at any time to display, and optionally save or print, 
partition configuration information from the library controller database. 
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SL Console Partition Workspace
The partition Summary (Step 2) and Design (Step 3b) screens, and all associated 
popups, give you a dynamic workspace to design your library partitions. All partition 
configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes.

Information in the SL Console partition workspace is committed to the library 
controller database only through the Commit (Step 4) screen. The information is lost if 
any one of the following occurs before you have committed your updates: 

■ You actively log off the SL Console session.

■ The SL Console session times out or the connection to the library is lost. 

■ You actively refresh the SL Console workspace from the current library controller 
database. This is done through the Refresh button on the Summary (Step 2) and 
Design (Step 3b) screens. 

Caution – Although partition changes are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other users before committing 
your partition workspace changes. Because the SL Console does not validate partition 
boundaries against the library controller database in real-time, configuration conflicts 
may arise if you change partition boundaries while other users are performing 
cartridge movements or library configuration changes. See “Synchronizing the Display 
With the Controller Database” on page 38 for details. 



Partitioning Task Summary

316194401 • Revision AB Chapter 6 Library Partitioning 265

Partitioning Task Summary
Partitioning tasks are divided into the following categories:

■ “Partition Configuration Tasks” on page 266

■ “Partition Management Tasks” on page 283

■ “Partition Report Tasks” on page 296

■ “CAP Operation Tasks” on page 303
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Partition Configuration Tasks

Task Page

Review Partitioning Instructions 267

Create a Partition 268

Configure a Host-Partition Connection (FC-SCSI partitions only) 269

Design a Partition – Base, DEM, or CEM Modules 271

Design a Partition – AEM Modules 274

Verify Partition Configurations 276

Resolve Orphaned Cartridges 279

Commit Partition Configuration Changes 280



Partition Configuration Tasks

316194401 • Revision AB Chapter 6 Library Partitioning 267

▼ Review Partitioning Instructions
Use this procedure to review the partitioning process. 

1. Select Tools > Partitions.

The first time you make this selection during an SL Console login session, the 
Instructions (Step 1) screen appears automatically. 

2. Review the instructions on the screen before proceeding with other partitioning 
tasks. 
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▼ Create a Partition 
Use this procedure to create a new library partition and assign its storage capacity. You 
can create up to eight partitions, with IDs from 1–8. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab. 

The Summary (Step 2) screen appears.

2. Click Add Partition. 

The Add Partition popup appears. 

3. Select the Partition ID you want to add, and enter the Name, Capacity, and Interface 
Type.

Note – Partition IDs do not need to be contiguous. For example, you can create 
partition 2 and partition 4, with no partitions 1 or 3. 

4. Click OK. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 276 and “Commit Partition 
Configuration Changes” on page 280. 
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▼ Configure a Host-Partition Connection

Note – This procedure applies to FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details. 

Use this procedure to configure the connection between a host and a selected partition. 
You must perform this procedure in order for the partition to be accessible by the host.

Each partition can have up to nine host connections, each with a unique LUN. Also, 
each host can connect to multiple partitions. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. Click the partition to which you want to add a host connection

Note – If you select an HLI partition, all the buttons in the Details section of the screen 
are grayed out. 
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3. Click Add Connection. 

The Add Connection popup appears. 

4. Enter the Initiator (WWPN) and LUN. 

Note – Each initiator connected to the library must have one library partition assigned 
to LUN 0. When you verify or commit partition configuration changes, the SL Console 
will notify you if an initiator does not meet this requirement. 

5. Click OK. 
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▼ Design a Partition – Base, DEM, or CEM Modules
Use this procedure to add or remove library resources (storage cells, tape drives, and 
rotational CAPs) from a partition. 

Note – This procedure applies to Base, DEM, or CEM modules. See “Design a 
Partition – AEM Modules” on page 274 for detailed instructions on allocating or de-
allocating an AEM CAP to or from a partition. 

Note – Library resources can be allocated to only one partition at a time. If you want to 
add resources to a partition but the resources are already allocated to another partition, 
you must first remove the resources from the assigned partition, and then add them to 
the new partition. 

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the module for which you want to design a partition. 
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4. Click the Design (Step 3b) tab.

The Design (Step 3b) screen appears, displaying the current configuration of the 
module you have selected.

5. In the Partition pull-down menu, select the partition you want to configure. 

All screen fields are updated to reflect the current configuration for the selected 
partition. 

Note – Click the Move Left or Move Right buttons to display a module directly 
adjacent to the one currently displayed. 

6. Choose the Select by method, and click either the Add or Remove radio button.

7. Use the library map to select the resources you want to add or remove. 
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Note – See “Partitions—Design (Step 3b)” on page 336 for detailed instructions on 
using the library map. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 276 and “Commit Partition 
Configuration Changes” on page 280. 
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▼ Design a Partition – AEM Modules 
Use this procedure to add or remove an AEM CAP to or from a partition. 

You can allocate or de-allocate the entire AEM at one time; it is not possible to allocate 
just part of an AEM to a partition. AEMs can be shared by multiple partitions that share 
the same host-partition interface (HLI or FC-SCSI). 

Note – See “Design a Partition – Base, DEM, or CEM Modules” on page 271 for 
detailed instructions on adding or removing library resources in Base, DEM, or CEM 
modules to or from a partition. 

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the AEM you want to allocate to a partition. 
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4. Click the Design (Step 3b) tab.

The Design (Step 3b) screen appears, displaying the current configuration of the AEM 
you have selected. 

5. In the Partition pull-down menu, select the partition you want to configure. 

All screen fields are updated to reflect the current configuration for the selected 
partition. 

Note – Click the Move Left or Move Right buttons to display a module directly 
adjacent to the one currently displayed. 

6. Click either the Add or Remove radio button.

7. Click anywhere on the library map to select the AEM and indicate that you want to 
allocate or de-allocate it to or from the partition. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 276 and “Commit Partition 
Configuration Changes” on page 280. 



Partition Configuration Tasks

276 SL3000 User’s Guide • May 2009 Revision AB • 316194401

▼ Verify Partition Configurations 
Use this procedure to verify partition configuration changes you have made during this 
SL Console login session. This procedure warns you of the following possible errors:

■ A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” on page 253 for details.

■ Library resources have been removed from a partition. 

■ A host connected to the library does not have a partition assigned to LUN 0. 

■ The library’s licensed capacity is oversubscribed; that is total partition allocations 
exceed licensed capacity.

Note – This procedure verifies only one partition at a time. If you need to verify 
multiple partitions, you must repeat this procedure separately for each partition. 

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the module for which you want to verify a partition. 

The module is highlighted on the screen. 
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4. Click the Design (Step 3b) tab.

The Design (Step 3b) screen appears, displaying the current configuration of the 
module you have selected.

5. In the Partition pull-down menu, select the partition you want to verify. 

All screen fields are updated to reflect the current configuration for the selected 
partition. 

6. In the Options Bar, click Verify. 

The boundaries of the selected partition are verified, including the locations of all tape 
cartridges. 

Note – This verification is performed on the current partition configuration in the 
SL Console partition workspace only. It does not verify current partition boundaries 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made partition changes. 

The Verify Results popup appears, indicating whether there are any orphaned 
cartridges, oversubscribed storage capacity, or other errors in the current partition 
configuration. 

Note – If library capacity is oversubscribed (that is, total partition allocations exceed 
licensed capacity), before you can proceed to “Commit Partition Configuration 
Changes” on page 280, you must remove storage cells from partition allocations to 
bring the total allocated cells within the library’s licensed capacity. 
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7. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 

You can use the Details button to toggle between the expanded and collapsed views of 
the warning messages. 

8. Optionally, in the expanded view of the warning messages you can do the following:

■ Click Print to print the detailed message data.

■ Click Save to save the detailed message data to a comma-separated file. 

9. Click OK to dismiss the Verify Results popup and return to the Design (Step 3b) 
screen. 

Note – It is recommended that you follow the “Resolve Orphaned Cartridges” on 
page 279 procedure before committing your changes to the library controller database. 
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▼ Resolve Orphaned Cartridges
If the SL Console identifies an orphaned cartridge, it displays a warning message. You 
should resolve and disposition all orphaned cartridges before proceeding to “Commit 
Partition Configuration Changes” on page 280. 

You can performing any of the following actions to resolve orphaned cartridges: 

■ Print a report of orphaned cartridges. 

■ Perform an audit of the library. 

■ Perform a recovery move on an orphaned cartridge. 
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▼ Commit Partition Configuration Changes 

Caution – This procedure updates the library controller database with all partition 
configuration changes you have made during this SL Console session. Failure to use 
this procedure before logging out of the current SL Console session will cause all your 
library configuration changes to be lost.

Caution – Although partition changes are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other users before committing 
your partition workspace changes. Because the SL Console does not validate partition 
boundaries against the library controller database in real-time, configuration conflicts 
may arise if you change partition boundaries while other users are performing 
cartridge movements or library configuration changes. See “Synchronizing the Display 
With the Controller Database” on page 38 for details. 

Note – It is recommended that you follow the “Resolve Orphaned Cartridges” on 
page 279 procedure before performing this procedure. 

Note – You cannot perform this procedure if current library capacity is oversubscribed 
(that is, total partition allocations exceed licensed capacity). The Apply button is grayed 
out, and before you can proceed, you must remove storage cells from partition 
allocations to bring the total allocated cells within the library’s licensed capacity.

1. Vary the library offline to ACSLS and HSC. 

See the appropriate tape management software documentation for the procedures and 
commands.

2. Select Tools > Partitions, and click the Commit (Step 4) tab.

The Commit (Step 4) screen appears.

3. In the Options Bar, click Apply. 

The boundaries of the selected partition are verified, including the locations of all tape 
cartridges. 
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Note – This verification is performed on the current partition configuration in the 
SL Console partition workspace only. It does not verify current partition boundaries 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made partition changes. 

The Confirm Apply popup appears, indicating whether there are any orphaned 
cartridges or other problems in the current partition configuration. 

4. To display detailed warning messages explaining the reasons for any orphaned 
cartridges, click Details. 

You can use the Details button to toggle between the expanded and collapsed views of 
the warning messages. 

5. Optionally, in the expanded view of the warning messages you can do the following:

■ Click Print to print the detailed message data.

■ Click Save to save the detailed message data to a comma-separated file. 
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6. Proceed as follows:

■ Click No to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

■ Click Yes to update the library controller database.

The Commit Success popup appears. 

Click OK to return to the Commit (Step 4) screen. 

7. All affected library host applications must now be configured to recognize these 
updates. See the appropriate tape management software documentation for the 
procedures and commands. 
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Partition Management Tasks

Task Page

Modify Partition Summary Information 284

Delete a Partition 285

Modify the Interface Type of a Host-Partition Connection 287

Modify FC-SCSI Host-Partition Connection Detail 289

Delete a FC-SCSI Host-Partition Connection 291

Refresh the SL Console Partition Workspace 293

Reallocate Library Resources 294

Make a Hardware Change to a Partitioned Library 295
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▼ Modify Partition Summary Information
Use this procedure to change the name or allocated storage capacity of an existing 
partition.

Note – To change the host-partition connection type (HLI or FC-SCSI), see “Modify the 
Interface Type of a Host-Partition Connection” on page 287. 

Note – You cannot change the partition ID. To assign a different Partition ID, you must 
delete the old partition and create a new one with the new ID. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, select the partition you want to modify. 

3. Click Modify Partition.

The Modify a Partition popup appears.

4. Enter the changes you want to make. 

5. Click OK to confirm the changes. 
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▼ Delete a Partition
Use this procedure to delete a partition from the library. The following changes are 
made to the library partition configuration:

■ All resources allocated to the partition are marked available. 

■ All host connections for the partition are deleted. 

■ The partition ID is deleted. 

Caution – Deleting partitions can result in orphaned cartridges and data that could be 
lost. See “Orphaned Cartridges in Partitioned Libraries” on page 253 for details. 

Note – Deleting all partitions from the library causes the library state to change to 
“non-partitioned.” All active storage cells, drives, and rotational or AEM CAPs will be 
accessible to all hosts.

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, click the partition you want to remove.

3. Click Delete Partition.

A confirmation popup appears.

4. Click OK to confirm the deletion. 

■ If partitions still remain in the library, proceed to Step 7. 
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■ If no partitions remain, the Select Library Interface Type popup appears. 

5. Select the library interface type you want to assign for all host connections to the 
library. Options are:

■ HLI

■ FC-SCSI

6. Click OK to confirm the change. 

7. The updates are made as follows:

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 276 and “Commit Partition 
Configuration Changes” on page 280. 

If there are no partitions remaining in the library, when you commit the updates the 
library state will change to “non-partitioned”. 
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▼ Modify the Interface Type of a Host-Partition 
Connection 
Use this procedure to change the host-partition connection type of an existing partition. 
You should use this procedure with caution, due to the following possible effects:

■ Changing the interface type can result in the loss of active host connections. 

■ Changing the interface type from FC-SCSI to HLI can result in the loss of FC-SCSI 
connection detail. 

■ Because rotational and AEM CAPs cannot be shared across partition types, changing 
the interface type can result in the loss of existing shared CAP assignments. 
Dedicated CAP assignments are not affected. 

Note – To change the name or allocated storage capacity of an existing partition, see 
“Modify Partition Summary Information” on page 284. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Partition Summary section, click the partition you want to modify. 

3. Click Modify Partition.

The Modify a Partition popup appears.

4. In the Interface Type pull-down, select the interface type you want to assign. Click 
OK.
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5. The SL Console checks the current partition configuration in the SL Console 
workspace. If the partition has shared CAP allocations or, in the case of FC-SCSI 
partitions, host-partition connection detail, warning popups will appear. Following 
are sample popups that may appear. 

■ Changing from HLI to FC-SCSI:

■ Changing from FC-SCSI to HLI:

6. Click Yes to confirm the change. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 276 and “Commit Partition 
Configuration Changes” on page 280. 
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▼ Modify FC-SCSI Host-Partition Connection Detail

Note – This procedure applies to FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details. 

Use this procedure to modify the host World Wide Port Name or LUN number of the 
library for a host-partition connection. 

Note – You cannot modify the target port number for the library; it is always “0”. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Summary section of the screen, click the partition for which you want to 
modify a connection. 

3. In the Connections section, click the host-partition connection you want to modify. 
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Note – If you select an HLI partition, all the buttons in the Details section of the screen 
are grayed out. 

4. Click Modify Connection.

The Modify a Connection popup appears.

5. Enter the changes you want to make. 

6. Click OK to confirm the changes. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 276 and “Commit Partition 
Configuration Changes” on page 280. 
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▼ Delete a FC-SCSI Host-Partition Connection 

Note – This procedure applies to FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details. 

Use this procedure to delete a host-partition connection. After you perform this 
procedure, the host will no longer be able to access the partition. 

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) screen appears.

2. In the Summary section of the screen, click the partition for which you want to 
delete a connection. 

Note – If you select an HLI partition, all the buttons in the Details section of the screen 
are grayed out. 

3. In the Connections section, click the host-partition connection you want to delete.
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4. Click Delete Connection.

A confirmation popup appears.

5. Click OK to confirm the deletion. 

Your partition configuration changes are saved to the SL Console partition workspace 
for the duration of this login session. 

To update the library controller database with all changes from this SL Console login 
session, see “Verify Partition Configurations” on page 276 and “Commit Partition 
Configuration Changes” on page 280. 
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▼ Refresh the SL Console Partition Workspace
Use this procedure to refresh the SL Console partition workspace with current data 
from the library controller database. The current data includes all updates that other 
users have made to the library controller database during your login session, through 
the command line interface, other SL Console sessions, or host applications. 

Note – After you complete this procedure, all uncommitted partition changes you have 
made during this SL Console login session are discarded. 

1. Select Tools > Partitions.

2. Click one of the following tabs:

■ Summary (Step 2) 

■ Design (Step 3b)

The selected screen appears.

3. In the Options Bar, click Refresh. 

The Partition Refresh popup appears.

4. Click Yes to confirm the refresh. 

All partition screen data is updated with current data from the library controller 
database. 
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▼ Reallocate Library Resources 
Reallocating library resources (storage cells, tape drives, rotational or AEM CAPs, or 
cartridges) from one partition to another is done through one of the following screens: 

■ “Partitions—Design (Step 3b)” on page 336, for Base, Drive, and CEM modules

■ “Partitions—Design (Step 3b) – AEMs Only” on page 342, for AEM modules

You must use the following two-step process: 

1. Remove the resource from the partition it is currently allocated to.

2. Allocate the resource to a different partition. 

See “Design a Partition – Base, DEM, or CEM Modules” on page 271 for detailed 
instructions.

Caution – Reallocating resources can result in orphaned cartridges and data that could 
be lost. See “Orphaned Cartridges in Partitioned Libraries” on page 253 for details. 
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▼ Make a Hardware Change to a Partitioned Library
Some library hardware changes, such as adding expansion modules, adding a second 
robot, or adding rotational CAP cells, may require the removal of all or part of an 
existing partitioned module. Use the following process to make such hardware changes 
without losing partitioning information for the sections of the library that are 
unchanged. 

Caution – Failure to follow this procedure could result in the loss of library partition 
configuration information after a hardware change. 

1. De-allocate all library resources (storage cells, rotational and AEM CAPs, and drives) 
that will be removed as part of the hardware change from the partitions they are 
currently allocated to. 

See “Design a Partition – Base, DEM, or CEM Modules” on page 271 for detailed 
instructions.

2. Power down the library. 

See “Power Down the Library” on page 463 for detailed instructions. 

3. Install the hardware change.

4. Power up the library. 

See “Power Up the Library” on page 464 for detailed instructions. 

All partition allocations for the unchanged parts of the library remain in effect.

5. Allocate the library resources that have been added due to the hardware change. 

See “Design a Partition – Base, DEM, or CEM Modules” on page 271 for detailed 
instructions.

Caution – Reallocating resources can result in orphaned cartridges and data that could 
be lost. See “Orphaned Cartridges in Partitioned Libraries” on page 253 for details. 
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Partition Report Tasks

Task Page

Display a Partition Report 297

Print Partition Report Data 299

Save Partition Report Data 300

Display Partition Detail 301
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▼ Display a Partition Report 
Use this procedure to display any of the following partition reports:

■ Cartridge Cell and Media Summary – Displays a detailed list of all resource partition 
assignments.

■ Host Connections Summary – Displays detailed host-partition connection 
information for all partitions.

■ Orphaned Cartridge Report – Displays a detailed list of all orphaned cartridges.

■ Partition Details – Displays detailed information for a selected partition.

■ Partition Summary – Displays summary information for all partitions.

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.
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2. In the pull-down menu, select the report you want to display. 

The screen is updated with current data from the library controller database. 

3. If you want to print the report data or save it to a file, see the following procedures:

■ “Print Partition Report Data” on page 299

■ “Save Partition Report Data” on page 300 
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▼ Print Partition Report Data
Use this procedure to print a partition report. This procedure can be performed from 
any of the partition report screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to File 
buttons. 

3. Click Print. 

The Print popup appears. 

4. Complete the print popup, and click Print. 

The report is printed to the selected printer. 
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▼ Save Partition Report Data
Use this procedure to save partition report data to a comma-separated file (.csv 
format). You can use a variety of spreadsheet applications to view the file. This 
procedure can be performed from any of the partition report screens. 

1. Select Tools > Partitions, and click the Reports tab.

The Reports screen appears.

2. In the pull-down menu, select any report. 

The specified report is displayed. All report screens include the Print and Save to File 
buttons. 

3. Click Save to File.

The Save popup appears. 

4. Browse to the directory where you want to save the file, and enter the file name. 

5. Click Save. 

The data is saved to the specified file. 
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▼ Display Partition Detail 
Use this procedure to display current partition boundaries and allocations. You can 
also display detailed information about cartridge, drive, and storage cell locations. 

Note – This procedure is available on the local operator panel.

1. Select Tools > Partitions.

2. Click the Module Map (Step 3a) tab. 

The Module Map (Step 3a) screen appears. 

3. Click the module you want to display. 

The module is highlighted on the screen. 
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4. Click the Current Partition Definitions tab.

The Partition Definitions screen appears, displaying the current configuration of the 
module you have selected.

You can mouse-over a cell to display a tooltip of detailed information about the cell. 
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CAP Operation Tasks 

Task Page

Associate an FC-SCSI Partition to Its Shared CAPs 304

Enter Cartridges Into a Partition 306

Eject Cartridges From a Partition 307

Remove a Partition-CAP Association 308

Override a CAP Reservation 309
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▼ Associate an FC-SCSI Partition to Its Shared CAPs
Use this procedure to associate an FC-SCSI partition to its shared rotational or AEM 
CAPs. You must use this procedure prior to entering or ejecting cartridges from an 
FC-SCSI partition if BOTH of the following conditions are true:

■ The partition shares one or more CAPs with other partitions, and 

■ the FC-SCSI host application does not use CAP reservations and prevent/allow 
commands.

Note – This procedure should not be used for HLI partitions because HLI host 
applications always use CAP reservations. If you use this procedure for HLI partitions, 
the CAP will be made unavailable to ACSLS and HSC hosts. 

Note – This procedure is not necessary for dedicated FC-SCSI CAPs because a partition 
always has ownership of its dedicated CAPs. 

Note – AEM CAPs are subject to the same partitioning rules and restrictions as 
rotational CAPs. Throughout this section, the term “CAP” refers to both types of CAPs. 

This procedure gives the partition exclusive ownership of its shared CAPs until you 
explicitly remove the association. See “Remove a Partition-CAP Association” on 
page 308 for details. 



CAP Operation Tasks

316194401 • Revision AB Chapter 6 Library Partitioning 305

1. Select Tools > Shared CAP Assignment. 

The Shared CAP Assignment screen appears.

2. Click the checkbox of the partitions into which you want to enter cartridges. See 
“Shared CAP Assignment” on page 380 for details on these screen fields. 

3. Click Apply. 

The CAP Confirm popup appears. 

4. Click OK. 

5. Perform the enter or eject operation. See one of the following procedures for details:

■ “Enter Cartridges Into a Partition” on page 306

■ “Eject Cartridges From a Partition” on page 307
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▼ Enter Cartridges Into a Partition
Use this procedure to enter or bulk load cartridges into one or more partitions. 
Partitions can use only the rotational or AEM CAPs allocated to them. 

Note – If you are entering cartridges into an FC-SCSI partition that has one or more 
shared rotational or AEM CAPs and the host application does not use CAP reservations 
and prevent/allow commands, you must associate the partition to its CAPs before 
beginning this procedure. See “Associate an FC-SCSI Partition to Its Shared CAPs” on 
page 304. Failure to do this may cause the CAP to remain locked and may prevent the 
partition from acquiring ownership of the CAP. 

1. Follow the steps in one of the following procedures, depending on whether you are 
using a rotational or AEM CAP:

■ “Enter Cartridges Through a Rotational CAP” on page 127

■ “Bulk Load Cartridges Through an AEM CAP” on page 129

2. At the completion of the procedure, the CAP reservation is released, as follows:

■ If you initiated this procedure from an HLI host or an FC-SCSI host that uses CAP 
reservations, the host removes the reservation, making the CAP available to other 
partitions. 

■ If prior to performing this procedure you performed a manual partition-CAP 
association, you can now remove the association if the partition is finished with the 
CAP. See “Remove a Partition-CAP Association” for details. 

■ If the FC-SCSI partition uses a dedicated CAP, the CAP remains unlocked and 
reserved to the partition. 
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▼ Eject Cartridges From a Partition
Use this procedure to eject or bulk unload cartridges from a partitioned library. 
Partitions can use only the rotational or AEM CAPs allocated to them. 

Note – If you are ejecting cartridges from an FC-SCSI partition that has one or more 
shared rotational or AEM CAPs and the host application does not use CAP 
reservations, you must associate the partition to its CAPs before beginning this 
procedure. See “Associate an FC-SCSI Partition to Its Shared CAPs” on page 304. 
Failure to do this may cause the CAP to remain locked and may prevent the partition 
from acquiring ownership of the CAP. 

1. Follow the steps in one of the following procedures, depending on whether you are 
using a rotational or AEM CAP:

■ “Eject Cartridges Through a Rotational CAP” on page 128

■ “Bulk Unload Cartridges Through an AEM CAP” on page 131

2. At the completion of the procedure, the CAP reservation is released, as follows:

■ If you initiated this procedure from an HLI host or an FC-SCSI host that uses CAP 
reservations, the host removes the reservation, making the CAP available to other 
partitions. 

■ If prior to performing this procedure you performed a manual partition-CAP 
association, you can now remove the association if the partition is finished with the 
CAP. See “Remove a Partition-CAP Association” for details. 

■ If the FC-SCSI partition uses a dedicated CAP, the CAP remains unlocked and 
reserved to the partition. 
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▼ Remove a Partition-CAP Association
Use this procedure after completing an enter or eject operation if you have previously 
associated the partition to its shared rotational or AEM CAPs. This procedure removes 
the partition-CAP associations previously set, making the shared CAPs available to 
other partitions. 

Note – AEM CAPs are subject to the same partitioning rules and restrictions as 
rotational CAPs. Throughout this section, the term “CAP” refers to both types of CAPs. 

1. Select Tools > Shared CAP Assignment. 

The Shared CAP Assignment screen appears.

2. Clear the checkbox of the partitions with the CAP associations. See “Shared CAP 
Assignment” on page 380 for details on these screen fields. 

3. Click Apply. 

The CAP Confirm popup appears. 

4. Click OK. 
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▼ Override a CAP Reservation
Use this procedure when a partition has reserved a shared rotational or AEM CAP but 
the reservation cannot be released through the ACSLS or HSC host. 

Note – This topic applies to partitioned libraries only. If a library is not partitioned, 
CAP reservations must always be released through ACSLS or HSC. See the ACSLS or 
HSC documentation for details.

Note – You must follow all steps in this procedure. If you do not complete the 
procedure, the CAP could be left unavailable to all partitions, and/or cartridges 
assigned to one partition could be entered into another partition. 

Note – AEM CAPs are subject to the same partitioning rules and restrictions as 
rotational CAPs. Throughout this section, the term “CAP” refers to both types of CAPs. 

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, and click the CAP whose reservation you want to override 
(unreserve). 

Note – AEM CAPs are identified as follows: column “–31” for a left AEM CAP, and 
column “31” for a right AEM CAP. 
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3. Click the Unreserve tab.

The Unreserve screen appears, identifying the partition that has reserved the CAP.

4. Click Apply to override the reservation.

The Unreserve Confirm popup appears, indicating “This will remove the reservation 
from the designated host...” 

■ Click OK to continue with the override operation. The library removes the CAP 
reservation and sets the CAP user to “default,” which makes the CAP unavailable to 
all partitions.

■ Click Cancel to cancel the override operation and return to Step 3. 

5. If the CAP is locked, unlock it at the SL Console. See “Unlock a CAP or AEM Access 
Door” on page 122 for the detailed procedure. 

6. Push the CAP button to open the CAP. 

■ If it is empty, proceed to Step 8. 

■ If it contains cartridges, remove them all. 

7. Label the cartridges with the partition ID displayed in Step 3. 

8. Push the CAP button to close the CAP. 

The CAP closes and locks automatically, and the CAP button light turns off.

The library audits the CAP to verify that it is empty. It then sets the CAP status to 
“unreserved,” which makes the CAP available to all partitions it is allocated to. 
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Note – You might need to refresh the CAP display to see the new CAP status. 

9. Contact a person responsible for managing the removed cartridges to determine their 
disposition. If they are to be re-entered into the library, they must be entered into the 
correct partition. 
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Partition Screen Reference
This section includes detailed descriptions of all SL Console partition screens, arranged 
by screen navigation path. For example, 
Partitions—Summary (Step 2)—Add Connection indicates the screen accessed by 
clicking Tools and then Partitions from the Menu Bar, and then clicking the Summary 
(Step 2) tab, and then the Add Connection button. 

Note – Only the Partitions—Current Partition Definitions screen is available on the 
local operator panel. The remaining screens can be accessed only from the standalone 
SL Console or the Web-launched SL Console.

Partition Screens are organized into the following categories:

■ “Partition Summary Screens” on page 313

■ “Partition Design and Commit Screens” on page 333

■ “Partition Report Screens” on page 359

■ “Partition CAP Operation Screens” on page 379

Note – The partition Summary (Step 2) and Design (Step 3b) screens, and all 
associated popups, give you a dynamic workspace to design your library partitions. All 
partition configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 
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Partition Summary Screens

Partitions—Instructions (Step 1)

Partitions—Summary (Step 2)

Partitions—Summary (Step 2)—Add Connection

Partitions—Summary (Step 2)—Delete Connection

Partitions—Summary (Step 2)—Modify Connection

Partitions—Summary (Step 2)—Add Partition

Partitions—Summary (Step 2)—Delete Partition

Partitions—Summary (Step 2)—Modify Partition
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Partitions—Instructions (Step 1)

Sample Screen

Description
Displays instructions for using the partition screens.

Note – This screen appears automatically the first time you select Tools > Partitions 
during an SL Console login session. 

Screen Fields
None

Buttons
? (Help) 

Click to display online help for the screen. 
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See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Design (Step 3b) 

■ Partitions—Commit (Step 4) 

■ Partitions—Reports 
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Partitions—Summary (Step 2)

Sample Screen

Description
Displays summary information for the library and, optionally, a selected partition. 

Also includes buttons that allow you to initiate any of the following activities:

■ Add a new partition 

■ Delete a partition from the library

■ Modify partition summary information 

Note – The following buttons are available for FC-SCSI host-partition connections 
only. HLI host-partition connections are configured through the host library 
management software (HSC or ACSLS), not through the SL Console. See the HSC or 
ACSLS documentation for details. 

■ Add a new host-partition connection

■ Delete a host-partition connection

■ Modify the configuration of a host-partition connection
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Screen Fields

Partition Summary

Partition Number

Display only.

ID assigned to the partition. IDs can range from 1–8.

Storage Cells

Display only.

Total number of storage cells allocated to this partition. 

Drive Bays

Display only.

Total number of tape drives allocated to this partition. 

CAPs 

Display only.

Total number of rotational CAPs allocated to this partition; this number represents 
whole CAPs, not individual CAP cells. 

AEMs 

Display only.

Total number of AEMs allocated to this partition; this number represents whole 
AEMs, not individual AEM cells. 

CAP+AEM Cells

Display only.

Total number of individual rotational and AEM CAP cells allocated to this partition. 

%Licensed Capacity 

Display only.

Percentage of the library’s licensed capacity that has been allocated to this partition. 
Calculated as:

(partition) Allocated Storage Cells / (total library) Licensed Capacity 

Details for Partition n 

Note – The following fields display host-partition connection information for the 
partition currently selected in the Partition Summary table. 

Name

Display only.

Name assigned to the selected partition. 

Interface Type 

Display only.
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Type of interface assigned to the selected host-partition connection. Options are:

■ HLI

■ FC-SCSI

Note – The following fields are available for FC-SCSI host-partition connections only. 

Connections

Initiator (WWPN) 

Display only.

World Wide Port Name of theFC-SCSI host bus adapter (HBA). 

Target Port 

Display only.

Port number of the SL3000 library controller. This entry is always “0”. 

LUN

Display only.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. 

Total Library Resources

Storage Cells  

Display only.

Total physical capacity of the library.

Drive Bays  

Display only.

Total number of tape drives in the library.

CAPs 

Display only.

Total number of rotational CAPs in the library.

AEMs 

Display only.

Total number of AEMs in the library.

CAP cells

Display only.

Total number of rotational CAP cells in the library.

AEM cells 

Display only.

Total number of AEM cells in the library.
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Licensed Capacity 

Display only.

Total licensed storage capacity of the library. 

Resources Allocated 

Storage Cells  

Display only.

Total number of storage cells allocated to all library partitions in the 
Design (Step 3b) screen. 

Drive Bays  

Display only.

Total number of tape drives allocated to all library partitions.

CAPs 

Display only.

Total number of rotational CAPs allocated to all library partitions.

AEMs 

Display only.

Total number of AEMs allocated to all library partitions.

CAP cells

Display only.

Total number of rotational CAP cells allocated to all library partitions.

AEM cells

Display only.

Total number of AEM cells allocated to all library partitions.

Licensed Capacity 

Display only.

Total licensed storage capacity assigned to all library partitions through the 
Add Partition or Modify Partition screen. 

Resources Unallocated 

Storage Cells 

Display only.

Total number of storage cells in the library that are not allocated to any partition.

Drive Bays  

Display only.

Total number of tape drives in the library that are not allocated to any partition.

CAPs 

Display only.
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Total number of rotational CAPs in the library that are not allocated to any library 
partition.

AEMs 

Display only.

Total number of AEMs in the library that are not allocated to any library partition.

CAP cells

Display only.

Total number of rotational CAP cells in the library that are not allocated to any 
partition.

AEM cells

Display only.

Total number of AEM cells in the library that are not allocated to any partition.

Licensed Capacity 

Display only.

Total licensed storage capacity not assigned to any library partition through the 
Add Partition or Modify Partition screen. Calculated as:

(total library) Licensed Capacity – (allocated) Licensed Capacity 

Buttons
Refresh 

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help)

Click to display online help for the screen. 

Add Partition

Click to add a new partition. The Partitions—Summary (Step 2)—Add Partition 
popup appears. 

Delete Partition

Click to delete the currently selected partition. The Partitions—Summary 
(Step 2)—Delete Partition popup appears. 

Modify Partition

Click to modify summary information for the currently selected partition. The 
Partitions—Summary (Step 2)—Modify Partition popup appears. 

Note – The following buttons are available for FC-SCSI host-partition connections 
only. 

Add Connection

Click to add a new host connection to the currently selected partition. The 
Partitions—Summary (Step 2)—Add Connection popup appears. 
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Delete Connection

Click to delete the currently selected host-partition connection. The 
Partitions—Summary (Step 2)—Delete Connection popup appears.

Modify Connection

Click to modify the configuration of the currently selected host-partition connection. 
The Partitions—Summary (Step 2)—Modify Connection popup appears.

See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Summary (Step 2)—Add Partition 

■ Partitions—Summary (Step 2)—Delete Partition 

■ Partitions—Summary (Step 2)—Modify Partition 

■ Partitions—Summary (Step 2)—Add Connection 

■ Partitions—Summary (Step 2)—Delete Connection 

■ Partitions—Summary (Step 2)—Modify Connection 

■ Partitions—Module Map (Step 3a) 

■ Partitions—Design (Step 3b) 

■ Partitions—Commit (Step 4) 

■ Partitions—Reports 
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Partitions—Summary (Step 2)—Add Connection

Sample Screen

Description
Allows you to configure the connection between a host and the selected partition. Each 
partition can have up to nine host-partition connections, each one having a unique 
LUN. 

Note – This screen is available for FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details.

This screen is a popup that appears when you click Add Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Connections n 

Display only.

Partition ID of the selected partition. 

Initiator (WWPN)

Required.

World Wide Port Name of theFC-SCSI host bus adapter (HBA). 

Sixteen hexadecimal digits. You can enter upper- or lower-case hex digits, but the 
display is always shown in all upper-case. 
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Target Port

Display only.

Port number of the SL3000 library controller. This entry is always “0”. 

LUN

Required.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. You can create up to nine unique LUNs per partition. 

Note – Each initiator connected to the library must have one library partition assigned 
to LUN 0. When you verify or commit partition configuration changes, the SL Console 
will notify you if an initiator does not meet this requirement. 

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Delete Connection

Sample Screen

Description
Allows you to delete the selected host-partition connection. 

Note – This screen is available for FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details.

This screen is a popup that appears when you click Delete Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
None

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 
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See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Modify Connection

Sample Screen

Description
Allows you to modify the configuration of the selected host-partition connection. 

Note – This screen is available for FC-SCSI host-partition connections only. HLI host-
partition connections are configured through the host library management software 
(HSC or ACSLS), not through the SL Console. See the HSC or ACSLS documentation 
for details.

This screen is a popup that appears when you click Modify Connection on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Connections n 

Display only.

Partition ID of the selected partition. 

Initiator (WWPN)

World Wide Port Name of theFC-SCSI host bus adapter (HBA). 

Sixteen hexadecimal digits. You can enter upper- or lower-case hex digits, but the 
display is always shown in all upper-case. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 
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Target Port

Display only.

Port number of the SL3000 library controller. This entry is always “0”. 

LUN

Required.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. 

Note – Each initiator connected to the library must have one library partition assigned 
to LUN 0. When you verify or commit partition configuration changes, the SL Console 
will notify you if an initiator does not meet this requirement. 

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Add Partition 

Sample Screen

Description
Allows you to add a new partition. You can create up to eight partitions, with IDs 
ranging from 1–8. 

This screen is a popup that appears when you click Add Partition on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Select a Partition ID

Required.

Partition ID you want to add. Options are 1–8. 

The pull-down menu displays all available IDs; the default is the next available ID in 
numerical order. 

Name 

Optional.

Name you want to assign to the partition. 

0–60 ASCII characters. 

Interface Type 

Required.

Type of interface to be used for this host-partition connection. Options are:

■ HLI

■ FC-SCSI 
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Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Delete Partition

Sample Screen

Description
Allows you to confirm that you want to delete the specified partition. All information 
for the partition – including host-partition connections, partition boundaries, and 
partition ID – are deleted from the SL Console partition workspace. 

This screen is a popup that appears when you click Delete Partition on the 
Partitions—Summary (Step 2). 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
None

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partitions—Summary (Step 2)—Modify Partition

Sample Screen

Description
Allows you to modify the name or host-partition connection type assigned to the 
selected partition. 

This screen is a popup that appears when you click Modify Partition on the 
Partitions—Summary (Step 2) screen. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Modify Partition n 

Display only.

ID of the partition you want to modify. 

Name 

Required.

Name you want to assign to the partition. 

0–60 ASCII characters. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 

Interface Type 

Type of interface to be used for this host-partition connection. Options are:

■ HLI

■ FC-SCSI 
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The screen displays the value assigned previously. You can leave it as is or make 
changes. 

Note – Changing the interface type can result in the loss of active host connections and 
shared rotational or AEM CAP allocations. See “Modify the Interface Type of a Host-
Partition Connection” on page 287 for details. 

Buttons
OK

Click to update the SL Console partition workspace with the current screen settings 
and return to the previous screen. 

Note – Clicking this button does not update the library controller database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also
■ Partitions—Summary (Step 2) 
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Partition Design and Commit Screens

Partitions—Design (Step 3b)

Partitions—Design (Step 3b) – AEMs Only

Partitions—Design (Step 3b)—Verify Results

Partitions—Commit (Step 4)

Partitions—Commit (Step 4)—Confirm Apply

Partitions—Current Partition Definitions
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Partitions—Module Map (Step 3a)

Sample Screen

Description
Allows you to select the library module for which you want to define partition 
boundaries. 

Screen Fields
Select a module from the map below 

Required.

The screen displays an illustration of the library’s actual module configuration. This 
information is taken directly from the library controller database. 

Click the module for which you want to design a partition, then click the 
Design (Step 3b) tab. 
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Buttons
? (Help)

Click to display online help for the screen. 

See Also
■ Partitions—Design (Step 3b) 

■ Partitions—Design (Step 3b) – AEMs Only 
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Partitions—Design (Step 3b)

Note – This section describes the Design (Step 3b) screens for Base, Drive, and CEM 
modules. For AEM modules, see “Partitions—Design (Step 3b) – AEMs Only” on 
page 342. 

Sample Screen

Description
Allows you to define partition boundaries by selecting the resources (storage cells, tape 
drives, or rotational CAPs) you want to include in the partition. You can use any of the 
following methods to add or remove resources from a partition (see “Library Map” on 
page 340 for detailed instructions): 

■ Select individual cells or groups of cells 

■ Select an entire column within a library module (top to bottom) 

■ Select a side within a library module (front or back) 

■ Select an entire library module
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Note – This screen is available only if partitions have been defined for the library 
through the Partitions—Summary (Step 2)—Add Partition screen. 

Caution – Changing partition boundaries can result in orphaned cartridges and data 
that could be lost. See “Orphaned Cartridges in Partitioned Libraries” on page 253 for 
details. 

Note – The partition Summary (Step 2) and Design (Step 3b) screens, and all 
associated popups, give you a dynamic workspace to design your library partitions. All 
partition configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Partition

Required.

Partition to which you want to add or remove resources (storage cells, tape drives, 
or rotational CAPs). 

The pull-down menu displays all valid partition IDs for the library.It also identified 
their host interface type (FC-SCSI or HLI). If no partition IDs have been defined, the 
menu is blank. 

Note – When you select a partition, the screen is automatically updated to display data 
for that partition from the SL Console partition workspace. 

Select by

Required.

Indicates the method you want to use for defining partition boundaries. Options are:

■ Cell – Select individual or rectangular groups of resources.

■ Column – Select all resources within a column. 

■ Side – Select all resources, except the CAP, within one side of a library module. 

■ Module – Select all resources, except the CAP, within a library module. 

Note – You must select either Add or Remove. 
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Add 

Required.

Indicates you want to add resources to the partition. You will only be able to click 
unallocated resources on the library map. 

Remove

Required.

Indicates you want to remove resources from the partition. You will only be able to 
click allocated resources on the library map. 

Allocated to Partition n 

Note – The data in these fields is automatically updated from the SL Console partition 
workspace when you select a partition.

Storage Cells 

Display only.

Total number of storage cells allocated to the selected partition, based on the 
currently defined partition boundaries. 

Drive Bays

Display only.

Total number of tape drives allocated to the selected partition, based on the 
currently defined partition boundaries. 

CAP Cells

Display only.

Total number of rotational and AEM CAP cells allocated to the selected partition, 
based on the currently defined partition boundaries. 

Unallocated in Library 

Note – The data in these fields is automatically updated from the SL Console partition 
workspace when you select a partition.

StorageCells 

Display only.

Total number of storage cells in the library that are not allocated to any partition.

Drive Bays

Display only.

Total number of tape drives in the library that are not allocated to any partition.

CAP Cells

Display only.
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Total number of rotational and AEM CAP cells in the library that are not allocated to 
any partition.

Licensed Capacity 

Note – This field appears only if the library has unallocated licensed capacity. If 
allocations exceed licensed capacity (an oversubscription situation), the 
Oversubscription field appears. 

Display only.

Total licensed capacity of the library that is not allocated to any partition. Calculated 
as:

Total licensed capacity – Total allocated storage cells 

Oversubscription 

Note – This field appears only if allocations exceed licensed capacity (an 
oversubscription situation). If the library has unallocated licensed capacity, the 
Licensed Capacity field appears. 

Display only.

Total licensed capacity of the library that has been exceeded through partition 
allocations. Calculated as:

Total allocated storage cells – Total licensed capacity 

You must remove the excess allocations before you can commit your changes 
through the Commit (Step 4) screen. 

Legend 
Legend for the library map. The state of each library resource (storage cell, tape 
drive, or rotational CAP cell) is indicated as follows: 

■ Not Accessible (white and x-ed out). Resource is not accessible to any partition. 
Following are some possible reasons:

- Storage cells have been configured for diagnostic cartridges. 

- Storage cells are not included in the library’s licensed capacity. 

■ Unallocated. Resource is currently not allocated to any partition and therefore 
available to the selected partition. 

■ Partition n (gold). Resource is allocated to the selected partition, partition n. 

■ Other Partitions (red). Resource is allocated to another partition and therefore 
NOT available to the selected partition. 

■ Shared CAP (gray background). CAP has been assigned to at least one partition. 
The host interface type assigned to the CAP (HLI or FC-SCSI) is displayed. 

■ Cartridge (cartridge icon). Resource contains a tape cartridge. 

■ Drive slots with installed drives are outlined with a thick border. Empty drive 
slots have a narrow border. 
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Library Map 
Graphical representation of the current library configuration. Initial display for the 
current SL Console login session is from the library controller database, then the 
display reflects data from the SL Console partition workspace as you modify 
partition configurations. The display includes the following information:

■ Type of module currently displayed (base module, drive expansion module, or 
parking expansion module) 

■ Numeric module ID (1–12)

■ Partition-host connection type of a shared CAP (FC-SCSI or HLI) 

■ Location of all resources (storage cells, tape drives, rotational CAP cells) within 
the library 

Note – Move the cursor over any resource to display a tooltip of detailed information 
about the cell or drive, its partition assignment, and the identity of any resident 
cartridge. 

Note – If no partition IDs have been defined, the library map is display only.

Use the library map to modify the boundaries of the selected partition. Depending 
on whether you have clicked the Add or Remove radio button, all selected resources 
are either added to or removed from the partition. 

Depending on your choice in the Select by field, you can perform any of the 
following actions. 

■ Select by cell – Select individual or groups of resources. Resources in a partition 
do not need to be adjacent to one another. 

- To select an individual resource, double-click it.

- To select a rectangular group of resources, click the cell or drive at one corner 
of the rectangle, and then click the cell or drive diagonally opposite. 

■ Select by column – Select an entire column within the module. Columns in a 
partition do not need to be adjacent to one another. To select a column, click any 
resource within the column. 

■ Select by side – Select an entire side within a module, except the CAP. Sides in a 
partition do not need to be adjacent to one another. To select one side of a library 
module, click any resource in that side. 

■ Select by module – Select an entire module, except the CAP. Modules in a 
partition do not have to be adjacent to one another. To select a library module, 
click any resource in that module. 

Buttons
Move Left 

Click to display the library module directly to the left of the one currently displayed. 
This button is grayed out if there is no module to the left. 

Move Right 

Click to display the library module directly to the right of the one currently 
displayed. This button is grayed out if there is no module to the right. 
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Verify 

Click to verify partition configuration changes you have made during this 
SL Console login session. The Tools > Partitions—Design (Step 3b)—Verify Results 
popup appears, indicating whether there are any orphaned cartridges or other errors 
in the current partition configuration.

Note – This procedure verifies only one partition at a time. If you need to verify 
multiple partitions, you must repeat this procedure separately for each partition. 

Note – This verification is performed on the current partition configuration in the 
SL Console partition workspace only. It does not verify current partition boundaries 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made partition changes. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Module Map (Step 3a)

■ Partitions—Design (Step 3b) – AEMs Only

■ Partitions—Design (Step 3b)—Verify Results 

■ Partitions—Commit (Step 4) 

■ Partitions—Current Partition Definitions 

■ Partitions—Reports 



Partition Design and Commit Screens

342 SL3000 User’s Guide • May 2009 Revision AB • 316194401

Partitions—Design (Step 3b) – AEMs Only

Note – This section describes the Design (Step 3b) screen for AEM modules only. For 
Base, Drive, and CEM modules, see “Partitions—Design (Step 3b)” on page 336. 

Note – This screen is available only if the library configuration includes one or more 
AEMs. 

Sample Screen 

Description
Allows you to define partition boundaries by allocating all cells in an AEM to a 
partition. As with rotational CAPs, multiple partitions can share an AEM CAP, if the 
partitions have the same host interface type (HLI or FC-SCSI). 

Note – This screen is available only if partitions have been defined for the library 
through the Partitions—Summary (Step 2)—Add Partition screen. 
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Caution – Changing partition boundaries can result in orphaned cartridges and data 
that could be lost. See “Orphaned Cartridges in Partitioned Libraries” on page 253 for 
details. 

Note – The partition Summary (Step 2) and Design (Step 3b) screens, and all 
associated popups, give you a dynamic workspace to design your library partitions. All 
partition configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields
Partition

Required.

Partition to which you want to add or remove AEM CAP cells. 

The drop-down menu displays all valid partition IDs for the library. It also identifies 
their host interface type (FC-SCSI or HLI). If no partition IDs have been defined, the 
menu is blank. 

Note – When you select a partition, the screen is automatically updated to display data 
for that partition from the SL Console partition workspace. 

Select by

Required.

Indicates the method you want to use for defining partition boundaries. Regardless 
of the option you choose, all cells within the AEM will be selected at once. 

Note – You must select either Add or Remove. 

Add 

Required.

Indicates you want to add the AEM to the partition. This option is valid only if the 
AEM is currently unallocated. 

Remove

Required.
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Indicates you want to remove the AEM from the partition. This option is valid only 
if the AEM is currently allocated. 

Allocated to Partition n 

Note – The data in these fields is automatically updated from the SL Console partition 
workspace when you select a partition.

Storage Cells 

Display only.

Total number of storage cells allocated to the selected partition, based on the 
currently defined partition boundaries. 

Drive Bays

Display only.

Total number of tape drives allocated to the selected partition, based on the 
currently defined partition boundaries. 

CAP Cells

Display only.

Total number of rotational and AEM CAP cells allocated to the selected partition, 
based on the currently defined partition boundaries. 

Unallocated in Library 

Note – The data in these fields is automatically updated from the SL Console partition 
workspace when you select a partition.

Storage Cells 

Display only.

Total number of storage cells in the library that are not allocated to any partition.

Drive Bays

Display only.

Total number of tape drives in the library that are not allocated to any partition.

CAP Cells

Display only.

Total number of rotational and AEM CAP cells in the library that are not allocated to 
any partition.

Licensed Capacity 

Note – This field appears only if the library has unallocated licensed capacity. If 
allocations exceed licensed capacity (an oversubscription situation), the 
Oversubscription field appears. 
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Display only.

Total licensed capacity of the library that is not allocated to any partition. Calculated 
as:

Total licensed capacity – Total allocated storage cells 

Oversubscription 

Note – This field appears only if allocations exceed licensed capacity (an 
oversubscription situation). If the library has unallocated licensed capacity, the 
Licensed Capacity field appears. 

Display only.

Total licensed capacity of the library that has been exceeded through partition 
allocations. Calculated as:

Total allocated storage cells – Total licensed capacity 

You must remove the excess allocations before you can commit your changes 
through the Commit (Step 4) screen. 

Legend 
Legend for the library map. The state of each AEM CAP cell is indicated as follows: 

■ Not Accessible (white and x-ed out). Resource is not accessible to any partition. 
Following are some possible reasons:

- Storage cells have been configured for diagnostic cartridges. 

- Storage cells are not included in the library’s licensed capacity. 

■ Unallocated. Resource is currently not allocated to any partition and therefore 
available to the selected partition. 

■ Partition n (gold). Resource is allocated to the selected partition, partition n. 

■ Other Partitions (red). Resource is allocated to another partition and therefore 
NOT available to the selected partition. 

■ Shared AEM CAP (gray background). AEM CAP has been assigned to at least one 
partition. The host interface type assigned to the AEM CAP (HLI or FC-SCSI) is 
displayed. 

■ Cartridge (cartridge icon). Resource contains a tape cartridge. 

AEM Map 
Graphical representation of the current AEM configuration. Initial display for the 
current SL Console login session is from the library controller database, then the 
display reflects data from the SL Console partition workspace as you modify 
partition configurations. The display includes the following information:

■ Type of module currently displayed; for AEMs, this is always “Access Module”. 

■ Numeric module ID (1–12)

■ Current module view indicator (“Door Closed View” or “Door Open View”) 

■ Host interface type of the partition(s) to which the AEM is allocated (FC-SCSI or 
HLI) 

■ CAP type; for AEMs, this is always “Bulk Load CAP”. 
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■ Location of all storage cells within the AEM 

Note – Move the cursor over any resource to display a tooltip of detailed information 
about the cell or drive, its partition assignment, and the identity of any resident 
cartridge. 

Note – If no partition IDs have been defined, the library map is display only.

Use the library map to modify the partition allocation of the AEM. Depending on 
whether you have clicked the Add or Remove radio button, the entire AEM is either 
added to or removed from the partition. 

Buttons
Move Left 

Click to display the library module directly to the left of the one currently displayed. 
This button is grayed out if there is no module to the left. 

Move Right 

Click to display the library module directly to the right of the one currently 
displayed. This button is grayed out if there is no module to the right. 

Note – The “Door Closed View” is the default AEM view. You can use the next two 
buttons to toggle between the alternate views. 

Show Door Open View

Click to display the layout of the AEM CAP cells as if the AEM access door were 
open and you are looking directly at the interior of the AEM. 

Show Door Closed View

Click to show display the layout of the AEM CAP cells as if the AEM access door 
were closed and you are “looking through” the front access door panel to the 
interior of the AEM. 

Verify

Click to verify partition configuration changes you have made during this 
SL Console login session. The Tools > Partitions—Design (Step 3b)—Verify Results 
popup appears, indicating whether there are any orphaned cartridges or other errors 
in the current partition configuration.

Note – This procedure verifies only one partition at a time. If you need to verify 
multiple partitions, you must repeat this procedure separately for each partition. 
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Note – This verification is performed on the current partition configuration in the 
SL Console partition workspace only. It does not verify current partition boundaries 
against the library controller database; therefore it cannot identify configuration 
conflicts that may arise due to other users performing cartridge movements or library 
configuration changes—through the command line interface, other SL Console sessions, 
or host applications—at the same time you have made partition changes. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Module Map (Step 3a)

■ Partitions—Design (Step 3b)

■ Partitions—Design (Step 3b)—Verify Results 

■ Partitions—Commit (Step 4) 

■ Partitions—Current Partition Definitions 

■ Partitions—Reports 
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Partitions—Design (Step 3b)—Verify Results

Sample Screen

Description
Displays a list of configuration errors in the current SL Console partition workspace. 

This screen is a popup that appears when you click Verify Results on the 
Partitions—Design (Step 3b) screen. 

Possible errors include:

■ A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” for details.

■ Library resources have been removed from a partition. 

■ A host-partition connection does not have a partition assigned to LUN 0 (applies to 
FC-SCSI connections only). 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the library 
controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 
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Note – The partition Summary (Step 2) and Design (Step 3b) screens, and all 
associated popups, give you a dynamic workspace to design your library partitions. All 
partition configuration information is automatically saved to the partition workspace in 
SL Console memory and retained for the duration of your SL Console session. This 
allows you to switch among partition views and leave and return to the partition 
screens any number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields

Note – The screen fields are the same as those displayed in the Partitions—Commit 
(Step 4)—Confirm Apply popup. 

Warnings found

Display only.

Summary error messages regarding the partition configuration. 

The library is oversubscribed. Please unallocate nnn storage cells. 

Display only.

Indicates that the total partition allocations currently exceed the library’s licensed 
capacity. nnn is the number of cells you must remove from partition allocations. The 
Apply button on the Commit (Step 4) screen remains deactivated until the total 
allocated cells is within the library’s licensed capacity. 

The following hosts will need re-audited

Display only.

World Wide Port Names (WWPNs) of any hosts that should re-audit their library 
partition. This may be because library resources have been deleted from the 
partition. 

The following hosts do not have Lun 0 set

Display only.

World Wide Port Names (WWPNs) of any hosts that have not defined any library 
partitions as LUN 0 on the host. This error applies to FC-SCSI host-partition 
connections only. 

The following orphaned cartridges were found

Display only.
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Detailed information regarding all orphaned cartridges in the current partition 
configuration. Includes library, rail, column, side, and row location of the cartridge, 
cartridge volume serial number (VOLID), and probable causes and explanations why 
the cartridge is orphaned. 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

OK

Click to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

Details 

Click to toggle between the expanded and collapsed views of the warning message 
display. 

See Also
■ Partitions—Design (Step 3b) 

■ Partitions—Commit (Step 4)—Confirm Apply 
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Partitions—Commit (Step 4)

Sample Screen

Description
Allows you to commit all data from the current SL Console partition workspace to the 
library controller database. The following data will be committed for all partitions: 

■ Partition summary information 

■ Host-partition connection configuration information 

■ Partition boundary details 

Caution – Although partition changes are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other users before committing 
your partition workspace changes. Because the SL Console does not validate partition 
boundaries against the library controller database in real-time, configuration conflicts 
may arise if you change partition boundaries while other users are performing 
cartridge movements or library configuration changes. See “Synchronizing the Display 
With the Controller Database” on page 38 for details. 
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Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 
updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Caution – It is recommended that you follow the Resolve Orphaned Cartridges 
procedure before using this screen. 

Caution – This screen updates the library controller database with all partition 
configuration changes you have made during this SL Console session. Failure to use 
this screen before logging out of the current SL Console session will cause all your 
library configuration changes to be lost.

Screen Fields
None 

Buttons
Apply

Click to update the library controller database with the current settings from the 
SL Console partition workspace. The Tools > Partitions—Commit 
(Step 4)—Confirm Apply popup appears, indicating whether there are any 
orphaned cartridges or other errors in the current partition configuration. 

Note – This button is grayed out if total partition allocations currently exceed the 
library’s licensed capacity. To activate the button, you must remove storage cells from 
partition allocations to bring the total allocated cells within the library’s licensed 
capacity.

Note – This button is grayed out if you have not made any changes to the SL Console 
partition workspace since the last commit. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Design (Step 3b) 

■ Partitions—Design (Step 3b)—Verify Results 

■ Partitions—Commit (Step 4)—Confirm Apply 
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■ Partitions—Reports 
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Partitions—Commit (Step 4)—Confirm Apply

Sample Screen

Description
Displays a list of configuration errors in the current SL Console partition workspace. 
This screen is a popup that appears when you click Apply on the 
Partitions—Commit (Step 4) screen. 

After viewing the error messages, you can commit all data in the SL Console partition 
workspace to the library controller database by clicking the Yes button. 

Possible errors include:

■ A partition has orphaned cartridges. See “Orphaned Cartridges in Partitioned 
Libraries” for details.

■ Library resources have been removed from a partition. 

■ A host-partition connection does not have a partition assigned to LUN 0 (applies to 
FC-SCSI connections only). 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the library 
controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 

Caution – Information in the SL Console partition workspace is saved to the library 
controller database only through the Commit (Step 4) screen. If your SL Console 
session ends or you refresh the workspace data before you have committed your 



Partition Design and Commit Screens

316194401 • Revision AB Chapter 6 Library Partitioning 355

updates through the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3b) screens and all 
associated popups. 

Screen Fields

Note – The screen fields are the same as those displayed in the Partitions—Design 
(Step 3b)—Verify Results popup. 

Warnings found

Display only.

Summary error messages regarding the partition configuration. 

The library is oversubscribed. Please unallocate nnn storage cells. 

Display only.

Indicates that the total partition allocations currently exceed the library’s licensed 
capacity. nnn is the number of cells you must remove from partition allocations. The 
Apply button on the Commit (Step 4) screen remains deactivated until the total 
allocated cells is within the library’s licensed capacity. 

The following hosts will need re-audited

Display only.

World Wide Port Names (WWPNs) of any hosts that should re-audit their library 
partition. This may be because library resources have been deleted from the 
partition. 

The following hosts do not have Lun 0 set

Display only.

World Wide Port Names (WWPNs) of any hosts that have not defined any library 
partitions as LUN 0 on the host. This error applies to FC-SCSI host-partition 
connections only. 

The following orphaned cartridges were found

Display only.

Detailed information regarding all orphaned cartridges in the current partition 
configuration. Includes library, rail, column, side, and row location of the cartridge, 
cartridge volume serial number (VOLID), and probable causes and explanations why 
the cartridge is orphaned. 

Buttons
Print

Click to print the report on a selected printer.

Save 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 
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Yes

Click to confirm that you want to update the library controller database with the 
current settings from the SL Console workspace. 

No

Click to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

Details 

Click to toggle between the expanded and collapsed views of the warning message 
display. 

See Also
■ Partitions—Commit (Step 4) 

■ Partitions—Design (Step 3b)—Verify Results 
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Partitions—Current Partition Definitions

Sample Screen

Description
Displays current partition boundaries and allocations. This is the only Partitions screen 
that is available on the local operator panel.

Note – This screen is display only. 

Screen Fields
For detailed descriptions of the screen fields, see one of the following sections:

■ “Partitions—Design (Step 3b)” on page 336, for Base, Drive, and CEM modules

■ “Partitions—Design (Step 3b) – AEMs Only” on page 342, for AEMs 
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Buttons
Refresh

Click to refresh the display with current data from the library controller database. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Design (Step 3b) 

■ Partitions—Design (Step 3b) – AEMs Only
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Partition Report Screens

Partitions—Reports

Partitions—Reports—Cartridge Cell and Media Summary

Partitions—Reports—Host Connections Summary

Partitions—Reports—Orphaned Cartridge Report

Partitions—Reports—Partition Details

Partitions—Reports—Partition Summary
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Partitions—Reports

Sample Screen

Description
Allows you to select one of the following library partition reports:

■ Cartridge Cell and Media Summary

■ Host Connections Summary

■ Orphaned Cartridge Report

■ Partition Details

■ Partition Summary

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 
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Screen Fields
Please select a report to display

Required.

Click the report you want to display. The drop-down menu lists all available library 
partition reports. 

Buttons
Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Summary (Step 2) 

■ Partitions—Design (Step 3b) 

■ Partitions—Commit (Step 4) 

■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Orphaned Cartridge Report 

■ Partitions—Reports—Partition Details 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Cartridge Cell and Media 
Summary

Sample Screen

Description
Displays detailed information about all library resources (storage cells, tape drives, and 
rotational or AEM CAP cells) and any stored cartridges.

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

Note – AEM CAP cells are identified as follows: left AEM CAP cells are in columns 
“-33” to “-31”; right AEM CAP cells are in columns “31” to “33”. 
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Note – You can modify the layout and display of this screen. See “Modifying the 
Screen Layout” on page 39 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Fields
Library 

Display only.

Library number where the library resource is located. This is always “1”. 

Rail 

Display only.

Rail number where the library resource is located. This is always “1”. 

Column

Display only.

Column number where the library resource is located. Column location is referenced 
from the left edge of the Base Module. “+1” is to the right; “-1” is to the left.

Side

Display only.

Module side where the library resource is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the library resource is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Partition ID

Display only.

Partition ID to which the library resource is allocated, if applicable. 

Partition Name

Display only.

Name of the partition to which the library resource is allocated, if applicable. If the 
library has no defined partitions, “Non-Partitioned Library” is displayed. 

Element Type

Display only.

Type of library resource. Options are:

■ CAP (rotational or AEM) 
■ CELL
■ DRIVE

Vol Ser 

Display only.
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Volume serial number (VOLID) of the cartridge resident in the library resource, if 
applicable. 

Cell Status

Display only.

Capacity status of the library resource. Applies to storage cells only. Options are:

■ Active – Cell is activated for use based on assigned capacity; can be used for 
cartridge storage. 

■ Inactive – Cell is not activated for use; cannot be used for cartridge storage. 

Buttons
Print

Click to print the report on a selected printer.

Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Orphaned Cartridge Report 

■ Partitions—Reports—Partition Details 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Host Connections Summary

Sample Screen

Description
Displays detailed information about all host-partition connections for the library. 

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 39 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields

Partitions

Note – The screen fields in this section also appear on the 
Partitions—Reports—Partition Summary report.

Partition ID

Display only.

ID of the partition (1–8). 

Partition Name

Display only.

Name of the partition. 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

■ HLI 

■ FC-SCSI 

Storage Cells 

Display only.

Total number of storage cells allocated to the partition.

Media in Storage Cells

Display only.

Total number of tape cartridges resident in the partition’s storage cells. 

% Storage Cells w/ Media

Display only.

Percentage of storage cells containing tape cartridges. Calculated as Media in 
Storage Cells / Storage Cells. 

Drive Bays 

Display only.

Total number of drive bays allocated to the partition. 

CAP Cells 

Display only.

Total number of rotational CAP cells allocated to the partition. 

AEM Cells 

Display only.

Total number of AEM CAP cells allocated to the partition. 

Total Media 

Display only.
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Total number of tape cartridges resident in the partition; includes cartridges in 
storage cells, rotational and AEM CAPs, and drives assigned to the partition. 

Active Cells

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 

Host Connections

Initiator WWPN

Display only.

World Wide Port Name of anFC-SCSI host bus adapter (HBA) with a connection to 
the partition. 

Library Controller Port

Display only.

Port number of the SL3000 library controller on the host. This entry is always “0”.

LUN

Display only.

Logical unit number of the library partition on the host.

Partition ID 

Display only.

Partition ID to which the host has a connection. 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Orphaned Cartridge Report 
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■ Partitions—Reports—Partition Details 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Orphaned Cartridge Report 

Sample Screen

Description
Displays the locations and volume serial numbers (VOLIDs) of all orphaned cartridges 
in the library. Also identifies why the cartridge is orphaned. 

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 39 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields
Library 

Display only.

Library number where the orphaned cartridge is located. This is always “1”. 

Rail 

Display only.

Rail number where the orphaned cartridge is located. This is always “1”. 

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right; “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall; “2” is the 
front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Vol Ser 

Display only.

Volume serial number (VOLID) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Because this report is produced from the library controller database, the only option 
is:

■ Unreachable from any host 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 
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Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Partition Details 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Partition Details

Sample Screen

Description
Displays detailed information for a selected partition. 

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 
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You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 39 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Fields
Partition Name

Display only.

Name of the partition. 

Partition ID

Display only.

ID of the partition (1–8). 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

■ HLI 

■ FC-SCSI 

Assigned Cells 

Display only.

Total number of storage cells allocated to the partition.

Available Cells 

Display only.

Total number of storage cells in the library available for allocation to the partition.

Occupied Cells 

Display only.

Total number of storage cells in the partition with tape cartridges present.

Active (Capacity Licensed) Cells 

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 

Assigned Drive Bays 

Display only.

Total number of drive bays allocated to the partition.

Available Drive Bays 

Display only.

Total number of drive bays in the library available for allocation to the partition.

Number of Drives

Display only.

Total number of installed tape drives allocated to the partition. 



Partition Report Screens

374 SL3000 User’s Guide • May 2009 Revision AB • 316194401

Occupied Drives 

Display only.

Total number of installed tape drives in the partition with tape cartridges present.

Assigned CAP cells 

Display only.

Total number of rotational CAP cells allocated to the partition through dedicated or 
shared CAPs. 

Available CAP cells

Display only.

Total number of rotational CAP cells in the library available for allocation to the 
partition. This number includes all rotational and AEM CAP cells in the following:

■ CAPs not allocated to any partition. 

■ CAPs not currently allocated to this partition, but allocated to other partitions 
with the same host interface type as this one. 

This number excludes all rotational and AEM CAP cells in the following:. 

■ CAPs currently allocated to this partition.

■ CAPs allocated to partitions with a different host interface type. 

Occupied CAP cells

Display only.

Total number of rotational CAP cells in the partition with tape cartridges present.

Assigned AEM cells 

Display only.

Total number of AEM CAP cells allocated to the partition through dedicated or 
shared AEMs. 

Available AEM cells

Display only.

Total number of AEM CAP cells in the library available for allocation to the 
partition. This number includes all AEM cells in the following:

■ AEMs not allocated to any partition. 

■ AEMs not currently allocated to this partition, but allocated to other partitions 
with the same host interface type as this one. 

This number excludes all AEM cells in the following: 

■ AEMs currently allocated to this partition.

■ AEMs allocated to partitions with a different host interface type. 

Occupied AEM cells

Display only.

Total number of AEM CAP cells in the partition with tape cartridges present.

% Cell Capacity (Assigned Cells/Total Cells) 

Display only.

Percentage of storage cells in the library allocated to this partition. Calculated as:

Number of cells allocated to the partition / Total physical capacity of the library 
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Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Orphaned Cartridge Report 

■ Partitions—Reports—Partition Summary 
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Partitions—Reports—Partition Summary

Sample Screen

Description
Displays summary information for all partitions in the library. 

Note – The partition reports display data saved to the library controller database. If 
you have made partition configuration changes without commiting the changes to the 
library controller through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and Design (Step 3b) 
screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 39 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.
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Screen Fields

Note – These screen fields also appear on the Partitions—Reports—Host Connections 
Summary report.

Partition ID

Display only.

ID of the partition (1–8). 

Partition Name

Display only.

Name of the partition. 

Connection Type 

Display only.

Type of interface used by the host-partition connection. Options are:

■ HLI 

■ FC-SCSI 

Storage Cells 

Display only.

Total number of storage cells allocated to the partition.

Media in Storage Cells

Display only.

Total number of tape cartridges resident in the partition’s storage cells. 

% Storage Cells w/ Media

Display only.

Percentage of storage cells containing tape cartridges. Calculated as Media in 
Storage Cells / Storage Cells. 

Drive Bays 

Display only.

Total number of drive bays allocated to the partition. 

CAP Cells 

Display only.

Total number of rotational CAP cells allocated to the partition. 

AEM Cells 

Display only.

Total number of AEM CAP cells allocated to the partition. 

Total Media 

Display only.

Total number of tape cartridges resident in the partition; includes cartridges in 
storage cells, rotational and AEM CAPs, and drives assigned to the partition. 
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Active Cells

Display only.

Total storage cell capacity assigned to the partition in the Add Partition screen. 

Buttons
Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Reports—Cartridge Cell and Media Summary 

■ Partitions—Reports—Host Connections Summary 

■ Partitions—Reports—Orphaned Cartridge Report 

■ Partitions—Reports—Partition Details 
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Partition CAP Operation Screens

Shared CAP Assignment

Diagnostics > CAP—Unreserve
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Shared CAP Assignment 

Sample Screen

Description
Allows you to perform partition-CAP associations prior to using a shared FC-SCSI CAP 
to enter or eject cartridges to or from a partition. Partition-CAP associations reserve a 
rotational or AEM CAP for the exclusive use of the selected partition for the duration of 
the enter or eject operation. 

Note – This screen is not available if the library has no shared FC-SCSI CAPs. 
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Note – This screen is used for both rotational and AEM CAPs. Throughout this section, 
the term “CAP” refers to both types of CAPs. 

The following rules apply when using this screen:

■ You need to use this screen for shared FC-SCSI CAPs only. 

■ You do not need to use this screen for dedicated CAPs because a partition always 
has ownership of its dedicated CAPs. 

■ You do not need to use this screen for HLI partitions because HLI host applications 
always use CAP reservations. 

■ You can associate only one partition at a time to a CAP. 

■ Selecting a partition causes all its allocated CAPs to be associated to it at once; you 
cannot select individual CAPs to be associated to the partition. 

■ You can select multiple partitions at once, as long as the selected partitions do not 
share any CAPs with one another. 

■ Partition-CAP associations remain active until you explicitly remove them; the 
associations are not automatically removed when the enter or eject operation 
completes. 

■ Partition-CAP associations are removed during library reboots, power cycles, library 
door open/close operations, or CAP initializations 

■ Partition-CAP associations are removed if the CAP becomes allocated to a different 
partition through the Design (Step 3b) screen. 

■ If a partition-CAP association is removed while the CAP is open or has cartridges in 
it, the CAP ownership will be changed to the “default” requester and the CAP will 
be unavailable to all partitions. You must empty and close the CAP before it can be 
associated to any partitions. 

See “Enter Cartridges Into a Partition” on page 306 and “Eject Cartridges From a 
Partition” on page 307 for complete details on using this screen in conjunction with the 
CAP Open button. 

Screen Fields
Select

Select one or more partitions for which you want to enter or eject cartridges, as 
follows: 

■ Click the checkbox to select the partition; the screen is updated as follows:

- All CAPs allocated to that partition are marked with the partition number on 
the module map.

- All other partitions sharing CAPs with that partition are grayed out. 

■ Clear the checkbox to de-select the partition. 

Partitions that are grayed out cannot be selected. A partition may be grayed out for 
any of the following reasons: 

■ No CAPs have been allocated to the partition.

■ The partition has an HLI host-connection type. 

■ The CAP is currently in use by another partition that shares the CAP.

■ The CAP is currently in use by the “default” user (library operator). 
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Partition Name

Display only.

Name assigned to the partition. 

Partition ID

Display only.

ID assigned to the partition. IDs can range from 1–8.

Connection Type 

Display only.

Type of interface assigned to the host-partition connection. Options are:

■ HLI

■ FC-SCSI

Library module map 

Display only.

The screen displays an illustration of the library’s actual module configuration. This 
information is taken directly from the library controller database. 

The CAP allocations for each partition are indicated, as follows: 

■ An “X” in a library module column indicates the CAP in that module is allocated 
to the partition in that row.

■ No “X” in a library module column indicates the CAP in that module is not 
allocated to the partition in that row. 

Buttons
Apply

Click to update the library controller database with the current settings from this 
screen. The CAP Confirm popup appears, prompting you to confirm the update. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh popup 
appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Partitions—Design (Step 3b) 
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Diagnostics > CAP—Unreserve

Sample Screen

Description
Allows you to override a CAP reservation that has been initiated by a host. This causes 
the library controller to remove the CAP reservation and set the CAP user to “default,” 
which makes the rotational or AEM CAP unavailable to all partitions. 

After overriding the reservation you will need to open the CAP and remove any 
cartridges. After you close the CAP, the library controller will lock and audit the CAP 
to verify that it is empty. It will then set the CAP status to “unreserved,” which makes 
the CAP available to all partitions.

Note – For FC-SCSI CAPs, overriding a CAP reservation breaks any partition-CAP 
association, even if the CAP is dedicated to the FC-SCSI partition. You must explicitly 
associate the partition to the CAP again before the partition can use the CAP.
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Note – This screen is used for both rotational and AEM CAPs. Throughout this section, 
the term “CAP” refers to both types of CAPs. 

See “Override a CAP Reservation” on page 309 for the detailed procedure. 

Screen Fields
CAP CAP_id is status. 

Display only.

Status of the selected CAP. Possible options are:

■ reserved by host_name – A CAP operation has been initiated by the specified 
host; you can use this screen to unreserve the CAP.

■ reserved by default – A CAP operation has been initiated at the SL Console; 
you cannot use this screen to unreserve the CAP. 

■ not reserved – The CAP is not reserved; you do not need to unreserve the 
CAP. 

Module containing selected CAP is displayed below

Display only.

The screen displays an illustration of the library’s actual module configuration. This 
information is taken directly from the library controller database. 

The CAP you have selected is marked by an arrow. 

Buttons
Apply

Click to override the host CAP reservation. The CAP Confirm popup appears, 
prompting you to confirm the update. 

Note – This button is active only if the CAP status is “reserved by host_name”. 

? (Help) 

Click to display online help for the screen. 

See Also
■ Shared CAP Assignment
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7

SL Console Diagnostics and Utilities

Library Events
The library controller continually monitors library operations and logs all events. 
Events are stored under three headings:

■ Communication events – Includes host-to-library, library-to-library, and library-to-
drive communications. 

■ Error event – Each error event is assigned a four-digit (hexadecimal) action code. 

■ Warning events – Indicate a loss of performance or conditions that may be indicative 
of future, fatal errors. 

Event Monitors
You or your Sun support representative can use the SL Console monitors to review 
library events. You can spool the event monitor information to a text file. 

The following information can help to diagnose the cause of the event: 

■ Date/time stamp – Identifies when the event occurred. 

■ Action codes – Identifies the command that was issued, such as “load drive”.

■ Result codes – Identifies the result of the requested action. See “List a Result Code” 
on page 403 to look up a result code. 

■ Known service plan (KSP) diagnosis – Identifies the mechanism or component 
responsible for the task or fault. 

Note – There is no option to clear the event log.
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Library Self-Tests 
The self-test diagnostic utility is intended to help diagnose basic problems with the 
library. A self-test is typically run after the library is installed. It can be run whenever 
necessary. 

Note – The library self-test routines are non-disruptive. 

Library self-tests involve the following process:

1. Checks the communication path between the library controller, drives, and TallBots. 

2. Performs get and put operations to check the health of the TallBots and rotational or 
AEM CAPs. This includes get and put operations from a reserved cell to a random 
empty:

■ Storage cell 

■ CAP cell

3. Performs a full library audit. 

4. Performs mounts and dismounts of diagnostic cartridges for all the drives installed 
in the library.

Note – The self-test will not start unless a diagnostic cartridge is found in the reserved 
cells.

Note – The self-test is repeated for each drive type if a compatible diagnostic cartridge 
is found in the reserved cells. If a diagnostic cartridge is not found for a drive type, the 
mount/dismount operation is skipped for the drive.
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Library Firmware Upgrades
The library firmware resides on the library controller. The initial firmware is installed 
at the factory. When new firmware is released, you must use the code load utility to 
upgrade the firmware on the library and associated devices (rotational or AEM CAP 
and TallBot). 

Note – Library firmware does not contain drive code upgrades.   

Firmware Download Sites
The SL3000 library firmware package is a .jar (Java Archive) file.See “SunSolve and 
Helpful Links” on page xxxiv for download sites. 

Note – You must have a valid login ID and password for the download site you are 
using. Contact your Sun support representative for assistance. 

Firmware Installation Process
The process for loading firmware code on the library controller is as follows: 

1. Locate the firmware upgrade package (.jar file) on the appropriate Sun download 
site. See “SunSolve and Helpful Links” on page xxxiv. 

2. Download the code to a folder on your local PC or workstation. 

3. Download the firmware package from your PC to the library controller. This process 
also unpacks the package after downloading to make it ready for activation. See 
“Download Code to the Library Controller” on page 408. 

4. Activate the downloaded code on the library controller. See “Activate Code on the 
Library Controller” on page 410. 

5. Reboot the library to make the code operational. See “Reboot the Library” on 
page 406. 
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Audits 
An audit is the process of reading and cataloging cartridges within a library, verifying 
the locations of cartridges, or validating a range of slot locations. The library controller 
maintains a cartridge database that contains the following information for all the 
cartridges in the library:

■ Volume ID (VOLID or VOLSER) 

■ Current location (in library internal address format)

■ Verified status (true or false)

The library audits all cartridge locations in the storage and reserved areas at the 
following times:

■ After one or both access doors have been opened and closed. 

■ An audit request is made through the SL Console. 

■ A host request to audit the library is entered. 

You can use the SL Console to perform the following types of audits:

■ Physical Audit 

■ Verified Audit

Caution – System-level problems may occur if a host’s cartridge record does not match 
what is in the library controller cartridge database. 

Physical Audit
In a physical audit, the TallBot visits cartridge locations and verifies the VOLID of 
resident cartridges, and the library controller updates the cartridge database. This audit 
changes the “verified” status of the cartridge locations to “True.” Audit times vary 
according to the size of the library. Audits take approximately 1/2 second per cartridge 
slot, per TallBot.

The library performs a physical audit at the following times. 

■ At library power-up, or when a library access door has been opened and closed. This 
is always a full audit of the entire library. 

■ In libraries with an AEM, whenever the AEM access door is closed. This is a full 
audit of the AEM. 

■ When initiated manually from the SL Console. There are two types of manually 
initiated physical audits:

■ Entire library audit – The TallBot visits all cells (storage, rotational and AEM 
CAP, and drive), catalogs the VOLIDs and locations, and updates the library 
controller cartridge database. This audit is a background process and so does not 
interrupt online library operations. See “Audit the Entire Library” on page 418 for 
details.   



 

Audits

316194401 • Revision AB SL Console Diagnostics and Utilities 389

■ Specific range audit – The TallBot visits only a specific range of cells (storage, 
rotational or AEM CAP, and drive) and updates the library controller cartridge 
database. The audit information is displayed on the SL Console while the audit is 
performed. See “Audit a Range of Cells” on page 420 for details.

Verified Audit
A verified audit validates the status of a specific cartridge location or range of locations 
(including rotational and AEM CAPs and drives) in the cartridge database. If a 
cartridge address has a verified status of “false” then a physical audit of that location is 
performed and the cartridge database is updated. The progress of the audit is displayed 
in the Audit Console section of the SL Console. See “Perform a Verified Audit” on 
page 422 for details. 



 

Robot Diagnostic Moves

390 SL3000 User’s Guide • May 2009 Revision AB • 316194401

Robot Diagnostic Moves
Diagnostic moves are used to monitor or diagnose a problem with a TallBot. The move 
can be performed with or without cartridges. 

Successful diagnostic moves do not rearrange the cartridges in the storage cells; 
cartridges are returned to their original locations after the diagnostic move is 
completed. However, some diagnostic move failures can cause cartridges to be left in 
new locations. 

A diagnostic move involves the following elements:

■ Target Address Range

■ Pool Address Range

■ Move Access Order

■ Robot Selection

Target Address Range 
The target address range defines the location parameters in a library within which the 
get operation is performed in a diagnostic move. There are two types of access orders 
for a target address:

■ “Sequential Access Order” on page 391 

■ “Random Access Order” on page 391 

Following are valid target address types:

■ Storage cells – Reserves storage locations as the target/pool range

■ CAP – Reserves cells in a rotational or AEM CAP as the target/pool range. 

■ Drive and Storage cells – Reserves drives and storage cells as the target/pool range.

■ System cells – Reserves system (reserved) cells, which contain cleaning or diagnostic 
cartridges, as the target/pool range. 

■ All – Reserves storage cells, system cells, rotational or AEM CAP cells and drives as 
the target/pool range.

Note – Selecting the Storage, CAP, drive, system, or All option does reserve all the 
associated locations as the target range. However, only the location currently being 
accessed by the TallBot for a get/put operation is unavailable to the host.

Pool Address Range
The pool address range locations are used to supply cartridges required for diagnostic 
moves to and from the target address range. A pool address is also used in a get 
operation if a target address does not contain a cartridge. There is no specified access 
order within the pool address range. The pool address ranges does not include drive 
locations.
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Note – The pool address ranges cannot contain drive locations.

Move Access Order

Sequential Access Order
In a sequential access order diagnostic move, the TallBot performs a get operation 
starting with the first location in the target address ranges and then continues visiting 
the locations sequentially through the range until it completes the requested number of 
moves. 

Note – If you choose not to move cartridges the get/put operations are not performed. 
The TallBot just positions itself at the target and pool addresses.

Random Access Order
In a random access order diagnostic move, the TallBot randomly picks a location in the 
target address range to get a cartridge. The TallBot can also visit the same location in 
the in the target address range multiple times to get a cartridge. The random access 
routine ends after the requested number of moves is complete. 

If you choose not to move cartridges the get/put operations are not performed. The 
TallBot just positions itself at the target and pool addresses. 

Robot Selection
The TallBot for the diagnostic move is selected based on the minimum and maximum 
ranges you set for the target and pool addresses. Multiple robots maybe selected if the 
address range requires it.

Diagnostic Move Control Functions
The following options are available to manage the moves currently open:

To Select Menu Option Notes

Start File > Start Sequence

Pause File > Pause Sequence Stops all diagnostic moves, but 
maintains the current location in the 
access order.

Stop   File > Stop Sequence Stops a running or paused exerciser.
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Note – If multiple diagnostic moves are open, then each move has its own monitor 
screen.

Resume File > Start Sequence Resumes a paused exerciser starting 
with the last known location in the 
target address range.

Clear the messages 
displayed in the monitor 
window

File > Clear Output Window Erases the previous message lines and 
continues to fill the screen with new 
messages.

Spool Spool File > Start Spooling Directs the move output to a file.

Stop spooling the exerciser 
output to a file

Spool File > Stop Spooling Stops directing the move output to the 
spool file.

To Select Menu Option Notes
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Troubleshooting 
Before you run diagnostic tests, check the following areas of the library using the 
troubleshooting tips in the following table:

TABLE 7-1 Troubleshooting Table 

Problem What to do

Service Required 
(amber) LED is 
constantly on.

Perform the following procedure:
Using the SL Console, check the health of the library and the attached 
devices (drives, rotational and AEM CAPs, and TallBots). See 
“StorageTek Library Console” on page 33 for more details about 
operations.
To perform a health check:
1. Log in to the SL Console application.
2. Access the System Detail module, View > System Detail.
3. Check the device tree for the following indicators:
■ Device Healthy
■ Device Error
The Status (for example, online/offline) and Statistics (for example, 
uptime, downtime, errors and warnings) tabs provide more 
information on the health of the library and devices. 
Other checks:
■ Make sure that cartridges are fully seated and properly oriented in 

their storage cells.
■ Inspect the X table for any foreign objects or debris; remove them if 

found.

CAP Open LED is on 
and blinking.

Open the rotational or AEM CAP and make sure that the cartridges in 
the CAP cells are properly seated. 

The SL Console does 
not display modified 
data or information 
remains static.

Check the SL Console Heartbeat icon.

Robot Fault or Library 
Fault Amber LED is 
constantly on.

1. Check the SL Console for any displayed error messages. Write down 
the error messages reported.

2. Open the front door. Observe and note the state of the cartridges, 
hand, and tape drives.

3. .Make sure that cartridges are fully seated and properly oriented in 
their storage cells.

4. Make sure that packing materials have been removed.
5. Inspect the library floor for any objects or debris; remove them.
6. Check the status of the tape drives.
7. Close the front door.
8. Make sure that the tape drives are fully seated and locked forward 

by pushing and pulling on the rear of the drive tray. Any motion of 
the tray indicates that it requires reseating and locking down.

Tape drive is unable to 
eject a cartridge.

Manually remove the cartridge from the tape drive. “Remove a 
Cartridge from a Tape Drive” on page 325.
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The client computer 
cannot communicate 
with the library or tape 
drives.

1. Make sure that cables are securely attached to their connectors on 
the rear of the library, the tape drives, and the client computer.

2. Make sure that each SCSI device on the same bus has a unique 
address and that the last device is properly terminated.

The library is unable to 
communicate with the 
drives.
Drive status on the 
SL Console displays 
Not communicating.

1. Make sure that cables are securely attached to their connectors on 
the rear of the library, the drives, and the client computer.

2. Make sure that each SCSI device on a bus has a unique address and 
that the last device is properly terminated.

Repeated or excessive 
drive cleanings or 
cleaning messages.

1. Replace the cleaning cartridge with a new cleaning cartridge.
2. Run the Library Self-Test and note if errors are reported for the 

drive.
3. Run any client computer-based drive diagnostic tests.

TABLE 7-1 Troubleshooting Table (Continued)

Problem What to do
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Diagnostic Support Files
The following diagnostic support files are maintained on the library in order to aid in 
troubleshooting and diagnosing problems:

■ MIB File

■ Library Log Snapshot File

Depending on circumstances, your Sun support representative may request you to 
transfer one or both of these files to Sun for further evaluation, or he or she may do this 
him or herself. 

MIB File
The management information base (MIB) file is an small network management protocol 
(SNMP) database used to manage your library devices. This file can be saved as a text 
file. See “Transfer the Library MIB File” on page 412 for detailed instructions. 

Library Log Snapshot File

Note – This feature is available starting with SL3000 firmware version FRS_2.30 and 
SL Console version FRS_4.30. 

Your Sun support representative can use privileged CLI commands to generate an 
encrypted snapshot of the library event log. You cannot view or edit this file. This file 
is available for only 15 minutes from the time it is generated. See “Transfer the Library 
Log Snapshot File” on page 414 for detailed instructions. 
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Diagnostic and Utility Tasks 
Library diagnostic and utility tasks are divided into the following categories:

■ “Event Monitor Tasks” on page 397

■ “Library Utility Tasks” on page 404

■ “Audit Tasks” on page 417

■ “Rotational and AEM CAP Utility Tasks” on page 424

■ “Drive Utility Tasks” on page 430

■ “TallBot Utility Tasks” on page 434

■ “AEM Safety Door Utility Tasks” on page 451
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Event Monitor Tasks

Task Page

Display an Event Monitor 398

Spool Event Monitor Data to a File 399

Display Multiple Monitors 400

List a Device Status Code 401

List a Result Code 403
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▼ Display an Event Monitor
Event monitor information is dynamically updated depending upon occurrence of the 
selected events. The information sent during an e-mail, print, save, or spool operation 
reflects the data (and format) shown on-screen at the time the operation is requested. 

Note – Event monitors are useful tools for root cause analysis of errors. If the library is 
experiencing reproducible errors, you can open an event monitor and spool all events 
to a file to capture the data. Later, you can send the file to your Sun support 
representative for analysis. 

Note – To monitor multiple events, see “Display Multiple Monitors” on page 400.

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder. 

The library monitors you have access to are displayed. 

3. Click the event monitor you want to use, and then click Open from the Options Bar. 

The system displays the associated data collected for the event.

4. Use these options to manage the information displayed on the screen for the event 
selected:

5.  To close a monitor, click the X in the upper right corner of the window. 

Select To

Monitor > Pause Pause the continuous display of data related to the event 
selected

Monitor > Resume Resume displaying the events

Monitor > Stop Permanently stop the continuous display of data related to the 
event selected

Monitor > Clear Clear the event monitor display 
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▼ Spool Event Monitor Data to a File
Use this procedure to spool and save event monitor data to a file. You can send the file 
to your Sun support representative to assist in diagnosing problems. 

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder. 

The library monitors you have access to are displayed. 

3. Click the event monitor you want to use, and then click Open from the Options Bar. 

The system displays the an event monitor window.

4. In the event monitor window, select Spool File > Start Spooling. 

The Save popup appears.

5. Browse to the directory where you want to save the file. In the File Name field, enter 
the file name, and click Save. 

All event data is spooled to the specified file. 

6. To stop spooling, select Monitor > Stop Spooling. 

Following is a sample of the spool file:
2008-05-29T11:23:27.448  0,1,0,0     root  default       internal        281    warn   
0  rb_Reboot::reboot(): Resetting drive [0,3,4,9] 
2008-05-29T11:23:27.760  0,1,0,0     root  default       internal        281    info   
0  Service Beacon is ACTIVE: Current Health Event indicates Drive 04 in Module 03 is 
not operational 
2008-05-29T11:23:53.211  0,1,0,0     root  default       internal        281    info   
0  Service Beacon is ACTIVE: Current Health Event indicates Drive 04 in Module 03 is 
operational 
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▼ Display Multiple Monitors
You can open and manage multiple event monitors using these selections from the 
Options Bar:

To Select

Custom arrange the open monitors on screen Window > 
Arrange

Arrange the event monitor windows horizontally Window > Tile 
Horizontal

Arrange the event monitor windows vertically Window > Tile 
Vertical

Stack the event monitors Window > 
Cascade
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▼ List a Device Status Code
Use this procedure to list device status codes and their descriptions. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Search tab.

The Library Search screen appears. 

4. In the Search Type pull-down, click Device Status. 

5. Complete the Device Status field, as follows:

■ To search for a specific device status code, enter the complete code; wildcards or 
partial codes are not accepted. 

■ To list all device status codes, click the List All checkbox. 
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6. Click Search in the Options Bar. 

The screen lists the specified device status codes and their descriptions. 
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▼ List a Result Code
Use this procedure to list result codes and their descriptions. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Search tab.

The Library Search screen appears. 

4. In the Search Type pull-down, click Result Code. 

5. Complete the Result Code field, as follows:

■ To search for a code, enter the complete code; wildcards or partial codes are not 
accepted. 

■ To list all codes, click the List All checkbox. 
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Library Utility Tasks

Task Page

Perform a Library Self-Test 405

Reboot the Library 406

Download Code to the Library Controller 408

Activate Code on the Library Controller 410

Transfer the Library MIB File 412

Transfer the Library Log Snapshot File 414
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▼ Perform a Library Self-Test 

Note – The proper diagnostic cartridges for library drives must be present in the 
library. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the SelfTest tab.

Note – The self-test screen displays a Mode field with two options: disruptive and non-
disruptive. At present, only the non-disruptive option is valid. 

4. Click the Run tab from the Options Bar.

During the self-test the SL Console window displays the status of the various 
diagnostics being performed.
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▼ Reboot the Library
Use this procedure to reboot the library. This process involves reloading the firmware 
from flash memory and restarting the library controller.

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click Reboot in the Options Bar.

The Reboot confirmation popup appears. 

4. Click OK to continue. 

If the library is online, the Offline confirmation popup appears.

5. Click OK to vary the library offline. 

The Reboot confirmation popup appears 

6. Click OK to continue. 

The SL Console termination popup appears.

7. Click OK to terminate this SL Console session. 

You are logged off the SL Console. 

The library controller reboots the library. This may take several minutes. 
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Note – You will not be able to log back in to the SL Console until the library has fully 
initialized. 
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▼ Download Code to the Library Controller
Use this procedure to download updates to the library controller firmware. This 
procedure is not used for downloading drive firmware updates.

Note – You can perform this procedure only from the standalone SL Console or Web-
launched SL Console, not the local operator panel. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Load Code tab. 

4. Click the Browse button to locate, select the folder and file name containing the 
firmware package (.jar file) on your PC, and then click Open.
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5. Click the Load button from the Options Bar.

6. Click OK to confirm the download. 

Note – The download process could take up to five minutes. The SL Console indicates 
the progress of the file transfer from the PC to the library controller.

Note – After the downloading, the system unpacks the package. 

7. After the package is successfully unpacked, you can activate the code immediately, 
or you can wait until a later time. See “Activate Code on the Library Controller” on 
page 410 for detailed instructions.
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▼ Activate Code on the Library Controller 
Activating the code makes the code residing in the library controller ready for 
operation. 

1. Select Tools > Diagnostics, 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Activate Code tab.

4. Click the Target on the pull-down menu.

Note – Target refers to firmware package (.jar file) containing the SL3000 library 
code.
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5. Click the code to activate from the Available Versions section. 

Note – The version prefixed with an “*” is the code currently active. You can not select 
this code again to activate.

6. Click the Activate button in the Options Bar.

Note – The activate code process could take up to ten minutes to complete.

Caution – POTENTIAL INTERNAL FILE CORRUPTION. Do not reboot any devices in 
the library or execute any operations on the library while code is being activated.

7. Click OK to continue.

Note – The Activate Console screen displays the status of the code activation process. 
The code you just activated is listed in the available versions section, marked with an 
“*”. The unpacked version and previously activated versions of the code are also listed 
(without the “*”). 

8. The system prompts you to reboot the library. Click OK to reboot the library.

Note – The library has two versions of the image file residing in the flash memory. 
After the library completes the reboot process, the latest image becomes active and the 
earlier version serves as a backup. The earlier version may be restored if required. 

9. Click OK to terminate the SL Console session.

10.In the logon screen, click Exit to close the application. 

Wait for the library to complete the initialization before you log in to the SL Console 
again.

Note – The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet available, 
in which case you need to exit and log in again at a later time. Additionally, if an audit 
is performed as part of initialization, until the audit is complete, any configuration data 
displayed may not be completely up-to-date and accurate. 
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▼ Transfer the Library MIB File
Use this procedure to copy the public SNMP management information base (MIB) file 
to a specified location on your local PC or workstation. The file is saved as a text file. 
You can e-mail the file to your Sun support representative to help diagnose problems 
with the library. 

1. Select Tools > Diagnostics, 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the TransferFile tab. 

The file transfer screen appears. 
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4. In the Transfer SNMP public MIB text file field, click the Transfer button. 

The Save popup appears. 

5. Browse to the directory where you want to save the file, and enter the file name in 
the File Name field. Be sure to give it a .txt suffix. 

6. Click Save. 

The data is saved to the specified file, and the Transferred Successful popup appears. 

7. Click OK to dismiss the popup. 
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▼ Transfer the Library Log Snapshot File

Note – Use this procedure only under the direction of your Sun support 
representative. Your Sun support representative must have generated a library log 
snapshot file within the previous 15 minutes.

Use this procedure to copy the library log snapshot file to a specified location on your 
local PC or workstation. The file is saved in an encrypted format, and you cannot view 
or edit it. You can e-mail the file to your Sun support representative to help diagnose 
problems with the library. 

1. Select Tools > Diagnostics, 

2. Click the Library folder on the device tree.

The Library screen appears.
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3. Click the TransferFile tab. 

The file transfer screen appears. 

4. In the Transfer log snapshot file field, click the Transfer button. 

The Save popup appears. 
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5. Browse to the directory where you want to save the file, and enter the file name in 
the File Name field. 

6. Click Save. 

The data is saved to the specified file, and the Transferred Successful popup appears. 

7. Click OK to dismiss the popup. 
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Audit Tasks

Task Page

Audit the Entire Library 418

Audit a Range of Cells 420

Perform a Verified Audit 422
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▼ Audit the Entire Library
During this audit the TallBot visits all the storage cells, catalogs the VOLIDs and 
locations, and updates the library controller database. 

Note – Although this audit is a background process and does not interrupt library 
operations, it does require sharing of TallBot resources. Therefore, it is not 
recommended that you run this audit during peak activity periods. 

Note – You cannot stop this audit once it has initiated. The audit will take 
approximately 1/2 second per cartridge slot. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.
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3. Click the Audit tab.

The Library Audit screen appears. 

4. In the Entire Library field, click Yes. Then click the Audit button in the Options Bar.

A confirmation popup appears. 

5. Click OK to perform the audit as a background process or Cancel to cancel the audit.

Note – Once you click OK, you cannot stop the audit; it will run until completion. 

6. You can view the Cartridge Summary report after a few hours for the latest cartridge 
locations and VOLIDs. See “Display a Library Report” on page 102 for details.
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▼ Audit a Range of Cells
During this audit the TallBot visits only a specific range of storage cells (including the 
cap and drives) and updates the library controller database.

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Audit tab.

The Library Audit screen appears. 

4. In the Entire Library field, click No. In the Physical Audit field, click Yes. In the 
Verified Audit field, click No.
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5. In the Start Address and End Address fields, select the device types you want to 
audit and the starting and ending library internal address locations.See “Library 
Internal Address” on page 473 for a detailed explanation of this address format. 

6. Click the Audit button in the Options Bar.

A confirmation popup appears. 

7. Click OK to perform the audit as a background process or Cancel to cancel the audit.

Note – Once you click OK, you cannot stop the audit; it will run until completion. 

8. The Audit Console section displays the progress of the audit. 

Note – You can also view the Cartridge Summary report for the latest cartridge 
locations and VOLIDs. See “Display a Library Report” on page 102 for details.
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▼ Perform a Verified Audit
A verified audit validates the status of a specific cartridge location or a range of 
locations (including rotational and AEM CAPs and drives) in the library controller 
database. If a cartridge address has a verified status of “false” then a physical audit of 
that location is performed and the library controller database is updated. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the Audit tab.

The Library Audit screen appears. 

4. In the Entire Library field, click No. In the Physical Audit field, click No. In the 
Verified Audit field, click Yes. 
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5. In the Start Address and End Address fields, select the device types you want to 
audit and the starting and ending library internal address locations.See “Library 
Internal Address” on page 473 for a detailed explanation of this address format. 

6. Click the Audit button in the Options Bar.

The Audit Console section displays the progress of the audit. 
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Rotational and AEM CAP Utility Tasks

Task Page

Perform a Self-Test on a Rotational or AEM CAP 425

Vary a Rotational or AEM CAP Offline 426

Vary a Rotational or AEM CAP Online 428
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▼ Perform a Self-Test on a Rotational or AEM CAP 

Note – At present, the CAP self-tests perform the same routines as the library self-test. 
Specific rotational and AEM CAP self-tests will be available at a later date.

1. Select Tools > Diagnostics.

2. Expand the CAP folder, and click the CAP you want to test. 

Note – AEM CAPs are identified as follows: column “–31” for a left AEM CAP, and 
column “31” for a right AEM CAP. 

3. Click the SelfTest tab.

4. In the Mode pull-down menu, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed message 
appears when the test finishes. 
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▼ Vary a Rotational or AEM CAP Offline 
Use this procedure to vary a rotational or AEM CAP offline through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

Note – AEM CAPs are identified as follows: column “–31” for a left AEM CAP, and 
column “31” for a right AEM CAP. 

3. Click the Status tab.

The screen displays the current status of the CAP. 
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4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the CAP are completed, and then the CAP status is changed, as 
follows:

■ Health State: Warn

■ Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

■ Access State: Offline
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▼ Vary a Rotational or AEM CAP Online 
Use this procedure to vary a rotational or AEM CAP online through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go online; the error 
condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

Note – AEM CAPs are identified as follows: column “–31” for a left AEM CAP, and 
column “31” for a right AEM CAP. 
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3. Click the Status tab.

The screen displays the current status of the CAP. 

4. In the Transition Request field, click Bring online. Click Apply. 

The CAP status is updated, as follows:

■ Health State: ok

■ Device State: Ready

■ Access State: Online
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Drive Utility Tasks

Task Page

Perform a Drive Self-Test 431

Vary a Drive Offline 432

Vary a Drive Online 433
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▼ Perform a Drive Self-Test 
1. Select Tools > Diagnostics.

2. Expand the Drive Folder, and click the drive you want to test. 

3. Click the SelfTest tab.

4. In the Mode pull-down, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed message 
appears when the test finishes. 
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▼ Vary a Drive Offline 
Use this procedure to vary a drive offline through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click the Status tab.

The screen displays the current status of the drive. 

4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the drive are completed, and then the drive status is changed, 
as follows:

■ Health State: Warn

■ Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

■ Access State: Offline
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▼ Vary a Drive Online 
Use this procedure to vary a drive online through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go online; the error 
condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click the Status tab.

The screen displays the current status of the drive. 

4. In the Transition Request field, click Bring online. Click Apply. 

The drive status is updated, as follows:

■ Health State: ok

■ Device State: Ready

■ Access State: Online
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TallBot Utility Tasks

Task Page

Perform a TallBot Self-Test 435

Vary a TallBot Offline 436

Vary a TallBot Online 437

Define a Diagnostic Move 438

Manage Diagnostic Move Definitions 443

Save a Diagnostic Move to a File 445

Start a Diagnostic Move 447

Monitor and Control Open Diagnostic Moves 449
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▼ Perform a TallBot Self-Test 

Note – To perform a TallBot self-test, diagnostic cartridges must be available in the 
library. 

1. Select Tools > Diagnostics.

2. Expand the Robot Folder, and click the robot you want to test. 

3. Click the SelfTest tab.

4. In the Mode pull-down, click Non-Disruptive. 

5. Click the Run button from the Options Bar.

Status messages are displayed as the self-test is run. A Diagnostic completed message 
appears when the test finishes. 
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▼ Vary a TallBot Offline 
Use this procedure to vary a TallBot offline through the SL Console. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the TallBot you want to modify. 

3. Click the Status tab.

The screen displays the current status of the TallBot. 

4. In the Transition Request field, click Take Offline. Click Apply. 

All outstanding jobs for the TallBot are completed, and then the TallBot status is 
changed, as follows:

■ Health State: Warn

■ Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

■ Access State: Offline

5. The TallBot is moved to the end of the rail and is not usable by the library. If the 
library is using the redundant TallBot feature, the second TallBot will take all 
requests. 
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▼ Vary a TallBot Online 
Use this procedure to vary a TallBot online through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

Note – Library devices that are offline in an error state cannot go online; the error 
condition must be cleared first. 

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the TallBot you want to modify. 

3. Click the Status tab.

The screen displays the current status of the TallBot. 

4. In the Transition Request field, click Bring Online. Click Apply. 

The TallBot status is updated, as follows:

■ Health State: ok

■ Device State: Ready

■ Access State: Online
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▼ Define a Diagnostic Move 
Multiple diagnostic move routines can be set up and run simultaneously, as long as the 
target and pool address ranges do not overlap. 

Note – This procedure requires sharing of TallBot resources; therefore, it is not 
recommended that you run it during peak activity periods. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.
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4. In the Defined Sequence section, click Add.

The TARGET screen appears. 

5. Complete the TARGET screen as follows. See “Target Address Range” on page 390 
for details. 

■ In the Selection Mode field, click the type of cells you want to diagnose. 

■ In the Minimum Address and Maximum Address fields, select the library internal 
address of the starting and ending locations of the cells you want to diagnose. 
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6. Click Next. 

The SOURCE screen appears. 

7. Complete the SOURCE screen as follows. See “Pool Address Range” on page 390 for 
details. 

■ In the Selection Mode field, click the appropriate cartridge pool address type. 

■ In the Minimum Address and Maximum Address fields, select the library internal 
addresses of the starting and ending locations of the cartridge pool you want to use.
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8. Click Next.

The Sequence screen appears. 

9. Complete the Sequence screen as follows. See “Move Access Order” on page 391 for 
details. 

■ Name of the diagnostic move

■ Move Count (specify a number between 1 and 5000)

■ Access order (Sequential or Random)

■ Move Type (Robot and Cartridge or Robot Only) 

■ Disable pre move cartridge compatibility check
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10.Click Finish to complete the setup.

The Diagnostic Move Manage screen appears. The diagnostic sequence you have just 
defined is listed in the Defined Sequences section. 
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▼ Manage Diagnostic Move Definitions 
Use this procedure to manage diagnostic move sequence definitions. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.
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4. From the Defined Sequences section, select any of the following options:

5. To manage the diagnostic moves currently open, see “Monitor and Control Open 
Diagnostic Moves” on page 449.

Select 
Option To Notes

Add Define a diagnostic move 

Open Start a diagnostic move Multiple diagnostic moves may be open at a time, so long as 
the target and pool address ranges setup for the moves do 
not overlap.

Modify Modify options for a 
diagnostic move

This diagnostic move routine must not be open or if open 
must be in a “Stopped” state.

Remove Remove a diagnostic move This diagnostic move routine must not be open.

Copy Copy an existing diagnostic 
move

Copy a diagnostic move definition, make changes if 
necessary, and assign a different name.
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▼ Save a Diagnostic Move to a File 
Use this procedure to save a defined diagnostic move to a local file on your workstation 
or PC. The file is saved as a JavaBean component represented as an XML 1.0 document 
(.xml). 

Possible uses for the saved file are:

■ Can be used to restore a move that has been deleted from the library. 

■ Can be copied to a different library for use there. 

1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.
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4. Click the diagnostic move you want to save, and then click the Save button in the 
Options Bar. 

The Save popup appears.

5. Browse to the directory where you want to save the file. In the File Name field, enter 
the file name. 

6. Click Save. 

The data is saved to the specified file. Following is a sample excerpt:
<?xml version="1.0" encoding="UTF-8"?>  
<java version="1.5.0_11" class="java.beans.XMLDecoder">  
 <object class="com.stortek.ats.elib.opel.model.SequenceBeanList">  
  <string>FRS_4.10</string>  
  <string>SL500</string>  
  <void method="add">  
   <object class=
"com.stortek.ats.elib.opel.model.SequenceBeanList$SequenceBean">  
    <void property="accessOrder">  
     <string>Sequential</string>  
    </void>  
    <void property="moveCartridge">  
     <boolean>true</boolean>  
    </void>  
    <void property="moveCount">  
     <int>10</int>  
    </void>  
    <void property="name">  
     <string>DriveDiagMove1</string>  
    </void>  
    . . . 
    <void property="targetType">  
     <string>Drive</string>  
    </void>  
   </object>  
  </void>  
 </object>  
</java> 
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▼ Start a Diagnostic Move
1. Select Tools > Diagnostics. 

2. Click the Library folder on the device tree.

The Library screen appears.

3. Click the DiagMove tab and then the Manage tab. 

The Diagnostic Move Manage screen appears.

4. From the Defined Sequences section click a diagnostic move and then click Open. 

The Monitor window is activated. 

You can repeat this step to open multiple moves, as long as the target and pool address 
ranges for the moves do not overlap.

A monitor window is displayed for each move you open.
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5. From each monitor window, select File > Start Sequence to start the move. 



 

TallBot Utility Tasks

316194401 • Revision AB SL Console Diagnostics and Utilities 449

▼ Monitor and Control Open Diagnostic Moves
Use this procedure to control and monitor the status of one or more open diagnostic 
moves. 

1. See “Start a Diagnostic Move” on page 447 for instructions on starting one or more 
diagnostic moves. 

2. Click the Monitor tab. 

The Monitor screen appears, with one monitor window for each open move.

Each monitor window has the following status indicators:

Status Indicators Description Valid Values

Spooling Status Indicates if the move output is being 
spooled to a file 

True, False

State Current execution state of the move Running, pausing, paused, 
stopping, stopped

Health Current health state of the move OK, warning, error

Completed moves Number of moves completed in the 
requested move count 
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3. Use the File menu in each Monitor window to perform any of the following 
functions:

Select Option To Notes

File > Start Sequence Start 

File > Pause Sequence Pause Stops all diagnostic moves, but maintains 
the current location in the access order.

File > Stop Sequence Stop   Stops a running or paused move.

File > Start Sequence Resume Resumes a paused move starting with 
the last known location in the target 
address range.

File > Clear Output Window Clear the messages 
displayed in the monitor 
window

Erases the previous message lines and 
continues to fill the screen with new 
messages.

Spool File > Start Spooling Spool Directs the move output to a file.

Spool File > Stop Spooling Stop spooling the move 
output to a file

Stops directing the move output to the 
spool file.
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AEM Safety Door Utility Tasks

Task Page

Reboot an AEM Safety Door 452



 

AEM Safety Door Utility Tasks

452 SL3000 User’s Guide • May 2009 Revision AB • 316194401

▼ Reboot an AEM Safety Door 
Use this procedure to reboot an AEM safety door. You may need to do this to clear 
errors if the AEM safety door has experienced an abnormal condition. 

1. Select Tools > Diagnostics.

2. Expand the Safety Door Folder, and click the AEM safety door you want to reboot. 

3. Click Reboot in the Options Bar.

If the safety door is online, the Offline Confirm popup appears. 
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4. Click OK to vary the safety door offline. 

The Reboot Confirm popup appears. 

5. Click OK. 

The library controller reboots the safety door. The safety door is re-initialized, and the 
TallBot audits the AEM CAP.

The Reboot Success popup appears. 

6. Click OK to dismiss the popup. 
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CHAPTER 8

Manual Operations

When in manual mode of operation, the library is unavailable for host access. This may 
be because the library has experienced an unrecoverable error or a library component 
requires service or installation. When the library is in this mode, cartridge mounts and 
dismounts require human intervention. 

Library Safety
Thoroughly review the safety precautions in this section before attempting to enter the 
library. It is essential that you follow proper safety procedures at all times. 

General Safety Precautions

Warning – Possible Physical Injury.  To prevent accidental closure of the access 
door while someone is in the library, it is recommended that when you unlock 
the access door, you lock it open and retain the key on your person. 

Before entering the library, be sure you: 

■ Know the location of the emergency door unlocking mechanisms. See “SL3000 Door 
Interlocks” on page 456.

■ Leave the access door open whenever working inside the library. There is a switch 
on each door frame that disconnects DC power and signal lines to the library’s 
motors when an access door is opened. See “SL3000 Servo Power Interrupt” on 
page 456.

■ Know the location of the mechanical door releases. See “Mechanical Door Releases” 
on page 457. 

■ Know the physical restrictions. See “Physical Restrictions” on page 457. 
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SL3000 Door Interlocks
Door safety interlocks are located behind the front access doors of the Base Module and 
DEM. To open either access door, an access key is required. 

Door safety interlocks are constantly monitored by the library controller. During 
normal operation, if an access door is opened an Emergency Robotics Stop condition is 
initiated and all library motors are immediately disabled. This prevents motors from 
operating while a library door is open. If the library is varied offline, opening the access 
door disconnects DC voltages to the rails and the power bus. 

The door switches are also monitored when the library is powered off. A battery 
supplies power for the circuitry to detect a door opening/closing event while the 
library is powered off.

When a Base Module and DEM are connected together, opening an access door to 
either module automatically suspends operations within the entire library (the two 
door switches are connected in series).

SL3000 Servo Power Interrupt
An additional safety feature is the servo power interrupt (SPI). If the library controller 
detects that a library motor is out-of-range, it will generate an SPI to turn off drive 
voltage to the faulty motor. This prevents a servo runaway condition until the cause of 
the problem can be determined. 
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Mechanical Door Releases
Each lock handle on the access doors of the Base Module and DEM includes a 
mechanical release which is painted yellow (see FIGURE 8-1.) This release serves as a 
safeguard in case a person is inside the library and the access door is accidentally 
closed and locked. When you push the release, it unlocks and opens the door. 

FIGURE 8-1 Mechanical Door Release 

Interior Lighting
The interior of the library is always illuminated by white LEDs on the ceiling. 

Physical Restrictions
The library does not allow much free room for movement. You must be mindful of the 
restricted space at all times. 

■ Be careful not to snag your clothing on the plastic arrays that house the cartridges 
(only 0.4 m [18 in.] of aisle clearance).

■ Be careful not to bump your head or body against the arrays. 

■ To gain access to a cartridge, you may have to move a TallBot, in which case you 
must avoid damaging the TallBot’s electronic components. 

■ If you are loading or unloading a cartridge manually, your hands must remain clear of 
the drive’s mechanical and electronic load components.



Manual Operation Tasks

458 SL3000 User’s Guide • May 2009 Revision AB • 316194401

Manual Operation Tasks

Task Page

Vary the Library Offline 459

Vary the Library Online 459

Power Down the Library 459

Power Up the Library 459

Open the Library Main Access Door 459

Close and Lock the Library Main Access Door 467

Perform an AEM “Fast Access” 468

Close the AEM Access Door After a “Fast Access” 469
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▼ Vary the Library Offline 
Use this procedure to vary the library offline through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

You may need to use this procedure at the following times:

■ Before powering down the library

■ Before opening a library access door

■ When the library is inoperative and requires maintenance 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 432 for details. 

2. Select Tools > System Detail.

3. Click the Library folder on the device tree.
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4. Click the Status tab, and then the General tab.

The current status of the library is displayed. 

5. In the Transition Request field, click Take offline. Click Apply.

All outstanding library jobs are completed, and then the library status is changed, as 
follows:

■ Health State: Warn

■ Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

■ Access State: Offline 
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▼ Vary the Library Online 
Use this procedure to vary the library online through the SL Console. 

Note – You should use this procedure only if you are not using ACSLS or HSC tape 
management software, or if their servers are not able to communicate with the library. 
ACSLS and HSC are not notified when the state of the library or its components are 
changed through the SL Console, possibly leading to disruption in library operations. 
For instructions on changing the state of the library and its components through ACSLS 
or HSC, see the appropriate tape management software documentation. 

Note – LTO Ultrium drives are automatically brought online when you bring the 
library online.

1. Select Tools > System Detail.

2. Click the Library folder on the device tree.

3. Click the Status tab, and then the General tab.

The screen displays the current status of the library. 

4. In the Transition Request field, click Bring online. 
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5. Click Apply. 

The library status is updated, as follows:

■ Health State: ok

■ Device State: Ready

■ Access State: Online

6. If applicable, vary the library online to ACSLS and HSC hosts. See the ACSLS and 
HSC documentation for detailed procedures. 
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▼ Power Down the Library
Use this procedure to power down the library. 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 432 for details. 

2. Vary the library offline. 

See “Vary the Library Offline” on page 459 for details. 

3. Open the rear doors of the Base Module and DEM (if present). 

4. Turn off the power enable switches. 

5. If necessary, turn off the circuit breakers on the PDUs. 
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▼ Power Up the Library
Use this procedure to power up the library. If the access doors have been opened and 
closed, a full audit of the library will be performed. 

1. Open the rear doors of the Base Module and DEM (if present). 

2. If necessary, turn on the circuit breakers on the PDUs. 

3. Turn on the power enable switches. 

4. The library goes through the initialization sequence, as follows:

Note – The SL Console gets all library configuration data from the library controller. 
Therefore, you should be careful when logging in to the SL Console before the library 
has fully initialized. You may see warnings that configuration data is not yet available, 
in which case you need to exit and log in again at a later time. Additionally, if an audit 
is performed as part of initialization, until the audit is complete, any configuration data 
displayed may not be completely up-to-date and accurate. 

1. Library controller code is activated.

2. The library controller performs electronic discovery of library components:

a. Determines the AC power configuration (N+1 or 2N). 

b. Verifies tape drive controller function. 

c. Checks optional functions (for example, a local operator panel). 

d. Establishes communication and configuration of the TallBot controller. 

e. Polls all tape drives and determines their locations. 

f. Queries all rotational and AEM CAPs:

- If a CAP door is fully open, the door will be left open. 

- If the state of a CAP door is undetermined, it is updated to closed and locked.

3. The TallBot performs the physical discovery process:

a. The TallBot sweeps the entire library to determine the library size. 

b. The TallBot scans the module identification block in each module. 

c. Depending on this information, the library is auto configured. 

4. If one of the access doors was opened and closed, a library audit will begin, as 
follows: 

a. The TallBot targets on each column of arrays (from the top, down). 

b. The TallBot scans up each column, recording the VOLIDs of all cartridges. 

c. The location of each VOLID is recorded in the library controller database. 

d. Storage cells without cartridges are flagged as empty.

e. If a cartridge is found in a rotational or AEM CAP, the CAP is closed and locked. 
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Note – This audit does not update the host cartridge databases. See the appropriate 
tape management software documentation for details about updating the host 
databases. 

5. xThe library comes to a Ready state.

5. Vary the library online.

See “Vary the Library Online” on page 461 for detailed instructions. 
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▼ Open the Library Main Access Door 
Use this procedure to open the main doors of the library. 

Warning – Possible Physical Injury.  To prevent accidental closure of the access 
door while someone is in the library, it is recommended that when you unlock 
the access door, you lock it open and retain the key on your person. 

1. Vary all library drives offline. 

See “Vary a Drive Offline” on page 432 for details. 

2. Vary the library offline. 

See “Vary the Library Offline” on page 459 for details. 

3. Insert the key into the door lock, and turn the key to unlock the door. 

4. Pull up on the door latch to release it, and open the door.

5. Turn the key in the lock, to lock the door open, and then remove the key from the 
lock and keep it with you. This will prevent the door from being closed while you 
are in the library.

6. Enter the library. 
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▼ Close and Lock the Library Main Access Door 
Use this procedure to close and lock the main doors of the library. 

1. Verify that there are no loose items in the library.

2. If the access doors were locked open, insert the key into the door lock, and turn the 
key, to unlock the door. 

3. Push the door closed and make sure it latches securely. 

4. Turn the key in the lock, to lock the door closed.

5. Remove the key from the lock and keep it in a safe place. 

6. If the library has been powered down, power it up. 

See “Power Up the Library” on page 464 for details. 

Note – Because the access doors have been opened, the library will go through a full 
audit. 



Manual Operation Tasks

468 SL3000 User’s Guide • May 2009 Revision AB • 316194401

▼ Perform an AEM “Fast Access”
Use this procedure to gain emergency access to the AEM. 

Caution – This procedure has the same effects on library operations as opening the 
main library access door. It causes an abrupt interruption of library activity and should 
be used only in exceptional circumstances, such as an AEM component failure. This 
procedure does not lower the internal AEM safety door. 

Note – When the AEM access door is closed, a full audit of the library is initiated. See 
“Close the AEM Access Door After a “Fast Access”” on page 469. 

1. Insert the library access door key in the Deadbolt Override lock, and unlock the door 
by turning the key clockwise.

Note – The key cannot be removed from the lock while it is in the unlocked position.

2. Lift theAEM access door latch, and open the door.

Caution – Possible Equipment Damage. DO NOT force the AEM access door to open or 
close.

All power to the rails is killed, and the TallBots are stopped immediately. 

All in-process jobs are stopped abruptly, and the TallBots and AEM CAPs are brought 
offline. 

Caution – The AEM safety door is not lowered. 
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▼ Close the AEM Access Door After a “Fast Access”
Use this procedure to close the AEM access door and re-initialize the library after 
performing an AEM “fast access.” 

Note – This procedure initiates a full audit of the library. 

1. Close and latch the AEM access door.

Caution – Possible Equipment Damage. DO NOT force the AEM access door to open or 
close.

2. Lock the door by turning the key counter-clockwise in the Deadbolt Override lock. 

■ The library re-initializes. 

■ The TallBots go through their initalization sequence. 

■ A full audit of the library is conducted. 

■ The AEM CAP is brought online and returned to its default state. 
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APPENDIX A

Library Resource Addresses 

This appendix describes the following library addressing schemes: 

■ Library Internal Address – Used by the library controller.

■ HLI-PRC Locations – Used by hosts with TCP/IP connections to the library.

■ FC-SCSI Element Locations – Used by hosts with FC-SCSI connections to the library. 

■ Drive Hardware Numbers – Physical array slot into which a drive is installed. 

■ Drive Dynamic World-Wide Names – Automatically generated by the library 
controller for installed drives. 

These schemes are used to locate all library resources, including:

■ Cartridge storage cells

■ Tape drive slots

■ Installed drives 

■ System/reserved cells

■ Rotational and AEM CAP cells 

CenterLine Technology 
The SL3000 modular design uses CenterLine technology to help balance the work load 
and improve performance of the library. The left side of the Base Module – which is the 
only required module – serves as the centerline. You can add other modules to the left 
and right of the Base Module. Columns to the right of the centerline have positive (+) 
numbers, while columns to the left have negative (–) numbers. 
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FIGURE A-1 Centerline and Column Addressing 

Center Line

Negative (–) Numbered Columns Positive (+) Numbered Columns 

 Drives -4,    -3,    -2,     -1 1,     2,     3,     4 

Cartridges -12, -11, -10, -9, -8, -7 -6, -5, -4, -3, -2, -1  1,  2,  3,  4,  5,  6 7,  8,  9,  10, 11, 12
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Library Internal Address

Storage Cells
There are five components to the SL3000 library internal addressing scheme: 

1. Library number: always “1.” 

2. Rail number: always “1.”

3. Column number: the horizontal location. Column numbering starts from the left 
edge of the back wall of the Base Module, as viewed from the front of the library. 
Columns to the right of this edge, whether within the Base Module itself or in 
modules connected to the right, are numbered positively (+), from left to right, 
starting with +1. Columns in modules connected to the left of the Base Module are 
numbered negatively (–), from right to left, starting with –1. 

4. Side: the back wall = 1, the front wall = 2.

5. Row: the vertical position. Row numbering runs from top to bottom and can range 
from 1 to 52. 

Note – For any library, the actual numbering of columns and rows depends on the 
modules installed and the configuration of drives vs. storage cells. See TABLE A-1 on 
page 473 for details. 

Library Internal Address Example – Base Module
As an example of using the library internal addressing scheme, refer to TABLE A-1 on 
page 473, drive hardware number 13 would be 1, 1, +4, 1, 4, as follows: 

1. Library number = 1 

2. Rail number = 1

3. Column number = +4

4. Side = 1

5. Row = 4

TABLE A-1 Base Module – Rear Wall Locations (viewed from the front of the library) 

Row          +1          +2          +3          +4

   +1       Drive 4       Drive 3       Drive 2       Drive 1
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   +2       Drive 8       Drive 7       Drive 6       Drive 5

   +3       Drive 12       Drive 11       Drive 10       Drive 9

   +4       Drive 16       Drive 15       Drive 14       Drive 13

         +1          +2          +3          +4          +5          +6

+24 Storage cells Storage 
cells 

Storage cells Storage cells Storage cells Storage cells 

  ~

+35

+36 Storage cells Storage 
cells 

Storage cells Storage cells Storage cells Storage cells 

  ~

+48

+49 
  ~

    No array Top two = 
Drop off

4-cell  
Diagnostic/ 
Cleaning

4-cell ID 4-cell 
Diagnostic/ 
Cleaning

4-cell 
Diagnostic/ 
Cleaning

+52 Bottom = 
Swap

Note: Perspective is from the front of the library.

TABLE A-1 Base Module – Rear Wall Locations (viewed from the front of the library) 

Row          +1          +2          +3          +4
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As a second example, the location for the two drop-off cells on this wall are...

1. Library number = 1

2. Rail number = 1

3. Column number = +2

4. Side = 1

5. Rows = 49 and 50

...which translates to 1, 1, +2, 1, 49 and 1, 1, +2, 1, 50.

Library Internal Address Example – DEM
See TABLE A-2 on page 476 for drive hardware number 27. As an example of using the 
library internal addressing scheme, this drive location would be... 

1. Library number = 1

2. Rail number = 1

3. Column number = -3

4. Side = 1

5. Row = 1

...which translates to 1, 1, -3, 1, 1.

As a second example, the location for the four-cell array that can contain diagnostic 
cartridges on this wall are...

1. Library number = 1

2. Rail number = 1

3. Column number = -4

4. Side = 1

5. Rows = 49 through 52

...which translates to 1, 1, -4, 1, 49 through 1, 1, -4, 1, 52.
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System/Reserved Cells 
A total of two cells are reserved within the Base Module only for drop-off locations and 
one cell is reserved as a swap cell. All remaining system cells can be used for diagnostic 
or cleaning cartridges; these are listed in TABLE A-3 on page 477.

There are a total of 12 cells for diagnostic or cleaning cartridges in the Base Module; 
there are a total of 12 or 15 cells for diagnostic or cleaning cartridges in the DEM. These 
are also listed in TABLE A-3 on page 477.

TABLE A-2 Drive Expansion Module – Rear Wall Locations (viewed from the front of the library) 

         -4          -3          -2          -1 Row

      Drive 28       Drive 27       Drive 
26

      Drive 25    1

      Drive 32       Drive 31       Drive 
30

      Drive 29    2

         -6          -5          -4          -3          -2          -1

Storage 
cells

Storage 
cells

Storage 
cells

Storage 
cells

Storage cells Storage cells    13

   ~

   23

Storage 
cells

Storage 
cells

Storage 
cells

Storage 
cells

Storage cells Storage cells    24

   ~

   35

Storage 
cells 

Storage 
cells 

Storage 
cells 

Storage 
cells 

Storage cells Storage cells    36

   ~

   48

    No array Top 2 = 
Drop off

4-cell  
Diagnostic/ 
Cleaning

4-cell ID 4-cell 
Diagnostic/ 
Cleaning

4-cell 
Diagnostic/ 
Cleaning

   49 
   ~

Bottom = 
Swap

   52

Note: Perspective is from the front of the library.
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There are no reserved cells in a CEM or PEM.

CAP Cells 
Cell locations within the CAPs follow a similar notation scheme as other locations 
within the library: 

1. Library number: (always “1”)

2. Rail number: (always “1”)

3. Column number: the horizontal location. This is referenced from the left edge (as 
you face the inside front) of the Base Module. From this point, columns are 
numbered as positive (+), consecutively, from left-to-right, throughout all modules 
connected to the right side of the Base Module. 

Conversely, if a module is attached to the left of the Base Module, column locations 
are numbered as minus (-), consecutively, from right to left, throughout all modules.

4. Side: (always “2” [front wall]).

5. Row: the vertical position, as referenced from the top cell in the column. Cells are 
numbered from 1 – 13 for the top magazine and 14 – 26 for the lower magazine. 
Magazine handles are located at the tops of each CAP magazine. 

Note – The magazine handle is not counted as a cell.

Library Internal Address Examples – CAP Cells
The fourth CAP cell down in a Base Module would be... 

1. Library number = 1

TABLE A-3 Reserved Cells 

Cell Locations Module Type Use Location

1, 1, 2, 1, 49 – 50 Base module Drop off cells (Reserved)
Back wall of the Base 
Module 

1, 1, -4, 1, 49 – 50
DEM Cleaning/Diagnostics 

Cartridges
Back wall of the DEM 

1, 1, 2, 1, 51 Base module Swap cell (Reserved)
Back wall of the Base 
Module 

1, 1, -5, 1, 51 DEM Cleaning/Diagnostics Cartridges Back wall of the DEM 

1, 1, 5, 1, 49 – 52 
1, 1, 6, 1, 49 – 52

Base module Cleaning/Diagnostics Cartridges 
Back wall of the Base 
Module 

1, 1, -1, 1, 49 – 52 
1, 1, -2, 1, 49 – 52

DEM Cleaning/Diagnostics Cartridges Back wall of the DEM 

 Note: Do not place data cartridges in a reserved cell. These cells are masked from the customer’s 
database (that is, an online TallBot will never go to these cells).
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2. Rail number = 1

3. Column number = +5

4. Side = 2

5. Row = 4

...which translates to 1, 1, +5, 2, 4.

The sixth CAP cell down in a DEM would be...

1. Library number = 1

2. Rail number = 1

3. Column number = -2

4. Side = 2

5. Row = 6

...which translates to 1, 1, -2, 2, 6.
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HLI-PRC Locations

Storage Cells
The host library interface-panel, row, column (HLI-PRC) location (address) is an 
eight-digit, comma-separated value (LL, PP, RR, CC) representing LSM, Panel, Row, 
Column. This addressing scheme is used by HLI clients, including ACSLS and HSC, to 
represent cartridge storage cells accessible to those HLI clients. 

Note – The SL3000 library internal address identifies the physical location of the 
cartridge in the library and the HLI-PRC refers to the address assigned by the host 
software.

The cell location appears in the following format: 

where, 

LL: LSM number (always “00”)  
PP: Panel (relative to the Base Module – descending numbers on the left and ascending 
numbers to the right; even numbers = rear walls, odd numbers = front walls)

■ Base Module = panels 12 & 13

■ DEM added to the left = panels 10 & 11

Note – Exception: If a CEM is added to the left of a Base Module instead of a DEM, 
that module’s panel numbering will be 8 & 9 (see “HLI-PRC Storage Cell Locations –
 Example Three” on page 481). This allows for a DEM to be installed at a later date 
without the necessity of re-numbering the modules.

■ module added to the right = panels 14 & 15

Note – RR: Row in the panel (a number from 0 – 51)  
Note the difference here. Library internal address rows begin with “1” and HLI-PRC 
rows begin with “0.”

CC: Column in the row (numbered left to right, from the front of the module)

Note – CC: Columns in the panel (a number from 0 – 5. 
Note the difference here. Library internal address columns begin with “1” and 
HLI-PRC rows begin with “0.”

      L       L       P       P       R       R       C       C
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HLI-PRC Storage Cell Locations – Example One
For an example of how this numbering scheme is formulated, refer to TABLE A-4. 

In example one, the library is composed of two modules. The cell location of a cartridge 
on the rear wall of the Base Module at Column 5, Row 24, would translate to the 
following: 

LL = 00, PP = 12, RR = 24, CC = 05; or 00, 12, 24, 05 

HLI-PRC Storage Cell Locations – Example Two
Adding a module to the left of the library described in Example One illustrates the “left 
descending” numbering scheme. Refer to TABLE A-5 to see how this works. 

In this example, a CEM has been added to the left of the DEM. Its panels are now 
numbered 8 and 9. Add another module to the left of this library and its panels become 
6 & 7. 

Conversely, adding a module to the right of the Base Module would make that 
module’s panel numbers 14 & 15, and so forth. 

TABLE A-4 Host Library Interface Cell Locations – Example One

                Drive Expansion Module                       Base Module

Rear Wall = Panel 10 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 11 Front Wall = Panel 13

Note: Perspective is from the front of the library.

TABLE A-5 Host Library Interface Cell Locations – Example Two

Cartridge Expansion Module   Drive Expansion Module               Base Module

Rear Wall = Panel 
8

Rear Wall = Panel 10 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 
9

Front Wall = Panel 11 Front Wall = Panel 13

Note: Perspective is from the front of the library.
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HLI-PRC Storage Cell Locations – Example Three
For an exception to continuous panel numbering, a third example is presented in 
TABLE A-6. In this library, two CEMs have been added to the left of a Base Module. 
Notice that, without a DEM, panel numbering to the left of the Base Module is now 8 & 
9, instead of 10 & 11.

This illustrates:

■ The one exception to the consecutive panel numbering scheme

■ That if a DEM is installed in the future, no panel numbering will change for the 
existing modules

Note – This numbering scheme benefits customers greatly since adding a module does 
not require any change to their existing panel configurations.

Although the host tape management software follows a five-digit numbering scheme 
like that in the SL3000 address, there are significant differences in cell designations, 
rotational and AEM CAP behavior, and other operational considerations as described 
below.

If you need to locate a cartridge’s HLI-PRC location, see “Locate a Cartridge by 
VOLID” on page 134. This procedure displays the cartridge information in both library 
internal address and HLI-PRC address formats. 

TABLE A-6 Host Library Interface Cell Locations – Example Three

Cartridge Expansion Module Cartridge Expansion Module               Base Module

Rear Wall = Panel 
6

Rear Wall = Panel 8 Rear Wall = Panel 12

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

0 1 2 3 4 5 0 1 2 3 4 5 0 1 2 3 4 5

Cartridge Column Numbers Cartridge Column Numbers Cartridge Column Numbers

Front Wall = Panel 
7

Front Wall = Panel 9 Front Wall = Panel 13

Note: Perspective is from the front of the library.
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Drive Slots
For the drives, HLI-PRC locations are different from the notation you will see with 
cartridge storage cells. TABLE A-7 illustrates how this numbering scheme works, as 
viewed from the rear of the library. 

■ The standard numbers correspond with the physical numbering of the drives.

■ The superscript numbers (in bold) correspond with the HLI-PRC (Row) locations.

■ HLI-PRC numbering is sequential from right-to-left – from 0 to 3 – for the first (top) 
row of the first module.

■ HLI-PRC sequential numbering scheme restarts, right-to-left – from 0 to 3 – in the 
next module.

■ The Column number is always 0.

HLI-PRC Drive Locations – Example One
Drives use drive numbers in place of row and column locations. The drive number is 
assigned to the position taken by a cell’s row, and the position taken by a cell’s column 
is always “00”. For example, tape drive hardware number 20 is equivalent to this HLI-
PRC location:

Library = 00

Panel = 12

Drive = 16

Column = 00

TABLE A-7 Host Library Interface Tape Drive Locations

                                     Base Module                               Drive Expansion Module

                                   Rear Panel =12                                    Rear Panel = 10

        13         22         31         40         253         262         271         280

        57         66         75         84         297         306         315         324

        911         1010         119         128         3311         3410         359         368

        1315         1414         1513         1612         3715         3814         3913         4012

        1719         1818         1917         2016         4119         4218         4317         4416

        2123         2222         2321         2420         4523         4622         4721         4820

        4927         5026         5125         5224

        5331         5430         5529         5628

Notes: Perspective is from the rear of the library. 
      The superscript numbers (in bold) represent the HLI-PRC locations (which translate into the 
Row number).
      The standard number notation represents the drive hardware number. 
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HLI-PRC Drive Locations – Example Two
As a second example, going from an HLI-PRC location to a hardware location, tape 
drive 00, 10, 25, 00 is equivalent to tape drive hardware number 51.

CAP Cells 
CAP HLI-PRC locations are different from the notation used for cartridge storage cells. 
CAPs use CAP numbers in place of panel numbers. 

Rotational CAPs
■ Library = always 00

■ CAPs = 01–10, as follows:

■ Left side CEMs = 01 – 04, from left to right

■ DEM = 05

■ Base Module = 06

■ Right side CEMs = 06 – 10, from left to right

■ Rows = 00–25

■ Column = always 00

AEM CAPs
■ Library = always 00

■ AEM CAPs = 00 or 11, as follows:

■ Left side AEM = 00

■ Right side AEM = 11

■ Rows = 00–38

■ Columns = 00–05 
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FC-SCSI Element Locations
Since the SL3000 also offers a Fibre Channel control (library) interface, you must be 
aware of the cartridge/CAP/drive numbering according to FC-SCSI elements. 

TABLE A-8 on page 485 represents FC-SCSI element locations for the back walls of a 
library that has: 

■ Four modules

■ 166 licensed cartridge storage cells 
■ 36 tape drives 

TABLE A-9 on page 486 represents FC-SCSI elements for the front walls of the same 
library.

Note – Both tables below list the FC-SCSI elements for a native, non-partitioned 
library.
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TABLE A-8 and TABLE A-9 are examples only, presented for you to note that FC-SCSI 
element numbering is: 

■ For storage elements – top-to-bottom, left-to-right, beginning at the back wall (as 
viewed from the front, numbered 2000) and continuing with the same scheme at the 
front walls (as viewed from the front of the library. 

■ For rotational CAP elements (import/export elements) – top-to-bottom, left-to-right, 
beginning with element number 10 at the left-most module’s CAP

■ Tape drives (data transfer elements) –  left-to-right, top-to-bottom, beginning at the 
center line of the Base Module (element 1000) and continuing at the DEM. 

A vacant drive slot will not be included in the sequence. 

TABLE A-8 FC-SCSI Element Locations – Back Walls (as viewed from the front)) 

Cartridge 
Expansion 
Module

                Drive Expansion 
Module  
                         (Center Line) 

                    Base Module  
                   (Center Line)  Cartridge 

Expansion 
Module

2000 2010 1022 1023 1024 1025 1000 1001 1002 1003 2060 2070

2001 2011 1026 Empt
y

1027 1028 1004 1005 1006 1007 2061 2071

2002 2012 1029 1030 Empt
y

1031 1008 1009 1010 1011 2062 2072

2003 2013 1032 1033 1034 1035 1012 1013 1014 1015 2063 2073

2004 2014 2020 2026 2032 2038 1016 Empt
y

1017 1018 2064 2074

2005 2015 2021 2027 2033 2039 1019 1020 1021 Empt
y

2065 2075

2006 2016 2022 2028 2034 2040 2044 2048 2052 2056 2066 2076

2007 2017 2023 2029 2035 2041 2045 2049 2053 2057 2067 2077

2008 2018 2024 2030 2036 2042 2046 2050 2054 2058 2068 2078

2009 2019 2025 2031 2037 2043 2047 2051 2055 2059 2069 2079

Notes: Tape drives begin numbering from the center line (left wall of the Base Module).
            Empty tape drive slots are not counted.
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TABLE A-9 represents FC-SCSI element locations for the front walls of the same library, 
viewed through the front. 

TABLE A-9 FC-SCSI Element Locations – Front Walls (as viewed from the front) 

Cartridge 
Expansion 
Module

                Drive Expansion 
Module  
                         (Center Line) 

                       Base Module  
                      (Center Line) Cartridge 

Expansion 
Module

2080 2090 2100 2107   (CAP) 10 2123 2130   (CAP) 36 2146 2156

2081 2091 2101 2108              2124 2131               2147 2157

2082 2092 2102 2109               2125 2132               2148 2158

2083 2093 2103 2110             ~ 2126 2133             ~ 2149 2159

2084 2094 2104 2111               2127 2134               2150 2160

2085 2095  
 Doo
r 
 Latc
h

2112                
 Doo
r 
 Latc
h

2135               2151 2161

2086 2096 2113               35 2136              51 2152 2162

2087 2097 2114 2117 2120 2137 2140 2143 2153 2163

2088 2098 2105 2115 2118 2121 2128 2138 2141 2144 2154 2164

2089 2099 2106 2116 2119 2122 2129 2139 2142 2155 2155 2165

Notes: Perspective is looking through the front of the library. 
             Cartridge storage cell locations are consecutive, skipping locations for the door latches.
             CAP cells are unique and sequential, from the left-to-right, as viewed through the front of the 
library
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Drive Hardware Numbers
The hardware number of a drive is strictly internal to the library, defined by the 
electrical wiring to the drive slot. These numbers are printed on decals on the interior 
of the rear doors of the library modules.

TABLE A-10 illustrates this numbering scheme for the Base Module, as viewed from the 
rear of the module. TABLE A-11 on page 488 illustrates the numbering for the DEM.

TABLE A-10 Base Module Tape Drive Numbering – Hardware 

Array 
Number Drive Trays

1 Drive 1 Drive 2 Drive 3 Drive 4

Drive 5 Drive 6 Drive 7 Drive 8

Array 
Number Drive Trays

2 Drive 9 Drive 10 Drive 11 Drive 12

Drive 13 Drive 14 Drive 15 Drive 16

Array 
Number Drive Trays

3 Drive 17 Drive 18 Drive 19 Drive 20

Drive 21 Drive 22 Drive 23 Drive 24

Note – Numbers shown are referenced from the rear of the Base Module.
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Drive Dynamic World-Wide Names
Drive dynamic World-Wide Names (dWWN), or Fibre Channel addresses, are 
automatically generated by the library controller during library initialization. dWWNs 
are assigned to library drive slots rather than devices. If a drive is replaced, the new 
drive receives the same name as the one it replaced, thereby eliminating the need for 
system re-configuration There are three World Wide Names reserved for each drive 
slot: Node, Port A, and Port B.

Note – The dWWN feature is usually enabled at installation time. The library and tape 
drives all must have firmware that supports the dynamic World Wide Naming feature. 
When dWWN is enabled, all drives must be at the proper firmware level. If a drive has 
down-level firmware, it remains in the “configuring” state and is unavailable for host 
use.

TABLE A-11 Drive Expansion Module Tape Drive Numbering – Hardware

Array 
Number Drive Trays

1 Drive 25 Drive 26 Drive 27 Drive 28

Drive 29 Drive 30 Drive 31 Drive 32

Array 
Number Drive Trays

2 Drive 33 Drive 34 Drive 35 Drive 36

Drive 37 Drive 38 Drive 39 Drive 40

Array 
Number Drive Trays

3 Drive 41 Drive 42 Drive 43 Drive 44

Drive 45 Drive 46 Drive 47 Drive 48

  Array 
Number                                                    Drive Trays

            4 Drive 49 Drive 50 Drive 51 Drive 52

Drive 53 Drive 54 Drive 55 Drive 56

Note – Numbers shown are referenced from the rear of the DEM.
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APPENDIX B

Wall Diagrams 

This appendix provides diagrams and tables detailing the following:

■ “Base Module Walls” on page 490

■ “Drive Expansion Module Walls” on page 491

■ “Cartridge Expansion Module Walls” on page 492

■ “Parking Expansion Module Walls” on page 494

■ “Access Expansion Module Walls” on page 495

■ “Configuration Block” on page 496

■ “Row Numbering” on page 497

■ “Reserved/System Cells” on page 498
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Note – The light gray cells are not accessible unless an adjacent module is installed on 
that side. 

FIGURE B-1 Base Module Walls 

Base Module 

Fr
on

t 
W

al
l 

 ■ 140 data cartridge 
cells

■ With 26-cell 
rotational CAP 

■ With operator panel 
or window

■ 163 data cartridge 
cells 

■ With 26-cell rotational 
CAP 

■ With window 
cartridge array

R
ea

r 
W

al
l 

■ 8 tape drive slots 
■ 180 data cartridges 

■ 16 tape drive slots 
■ 125 data cartridges 

■ 24 tape drive slots 
■ 65 data cartridges 
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Note – The light gray cells are not accessible unless an adjacent module is installed on 
that side. 

FIGURE B-2 Drive Expansion Module Walls 

Drive Expansion Module 
Fr

on
t 

W
al

l 

■ 253 cartridge cells 
■ With window 

cartridge array 
■ No rotational CAP

■ 230 cartridge cells 
■ With operator panel 

or window 
■ No rotational CAP 

■ 176 cartridge cells 
■ With 26-cell 

rotational CAP 
■ With window 

cartridge array 

■ 153 cartridge cells 
■ With 26-cell 

rotational CAP 
■ With operator panel 

or window 

R
ea

r 
W

al
l 

■ 8 tape drive slots 
■ 180 data cartridges 

■ 16 tape drive slots 
■ 125 data cartridges 

■ 24 tape drive slots 
■ 65 data cartridges 

■ 32 tape drive slots 
■ 0 data cartridges 
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FIGURE B-3 Cartridge Expansion Module Walls 

Left Cartridge Expansion Module 

Front Wall 
■ 260 cartridge cells 

Front Wall 
■ 182 cartridge cells
■ With 26-cell 

rotational CAP 

Rear Wall 
■ 256 cartridge cells

Right Cartridge Expansion Module 

Rear Wall 
■ 308 cartridge cells 

Front Wall 
■ 234 cartridge cells 
■ With 26-cell 

rotational CAP 

Front Wall 
■ 312 cartridge cells 
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Note – The light gray cells are not accessible unless an adjacent module is installed on 
that side. 
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Note – Six columns of arrays – three rear-wall and three front-wall – on both the left 
and right sides – are not accessible to allow for a defective robotics unit. 

FIGURE B-4 Parking Expansion Module Walls 

Left Parking Expansion Module 

Front Wall 
■ 156 cartridge cells 

Rear Wall 
■ 152 cartridge cells 

Right Parking Expansion Module 

Rear Wall 
■ 156 cartridge cells 

Front Wall 
■ 156 cartridge cells 
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FIGURE B-5 Access Expansion Module Walls 

Left Access Expansion Module 

Front Wall 
■ 117 AEM CAP cells 

Rear Wall 
■ 117 AEM CAP cells

Right Access Expansion Module 

Rear Wall 
■ 117 AEM CAP cells 

Front Wall 
■ 117 AEM CAP cells 
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Configuration Block
Each module in the SL3000 library has a configuration block on the lower rear wall in 
column 4, rows 49, 50, 51, and 52. This block identifies the: 

■ Type of module 

■ Back wall configuration 

■ Front wall configuration 

■ Options for that module

During library initialization, the robotic assembly visits this configuration block to 
determine the configuration of the module.

FIGURE B-6 Configuration Block 

Module types: 

■ Base Module 
■ DEM 
■ CEM 

■ PEM
■ AEM 

Back wall configuration: 

Target 

Front wall configuration: 

Options: 

■ Local operator 
panel 

■ Window 
■ Cartridge arrays

I   I\I   I
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Row Numbering 
FIGURE B-7 Row Numbering 

Example 1  
Base Module 

Example 2  
CEM 

Rows indicate the vertical location of a cartridge 
or tape drive.

Rows are always positive numbers. 

Storage cell rows are numbered from the top (1) 
to bottom (52). 
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Reserved/System Cells 
Both the Base Module and the Drive Expansion Module have special slots on the lower 
rear wall. These slots provide special functions for the library and tape drives. 

FIGURE B-8 shows an example of these slots: 

1. Swap slots (2) in column 2, rows 49 and 50.

2. Diagnostic slot (1) in column 2, row 51. 

3. Diagnostic slot (4) in column 3, rows 49, 50, 51, and 52. 

4. Configuration block in column 4, rows 49, 50, 51, and 52.

5. Cleaning cartridges (4) in column 5, rows 49, 50, 51, and 52. 

6. Cleaning cartridges (4) in column 6, rows 49, 50, 51, and 52. 

FIGURE B-8 Reserved Slots 

Swap
Diagnostic

Diagnostic Configu-
ration 
Block

Cleaning Cleaning

Target
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APPENDIX C

Cartridge Handling 

This appendix provides information on labeling and handling tape cartridges used in 
Sun StorageTek libraries. 

Cartridge Requirements
Library cartridges must meet specifications defined in American National Standard 
Magnetic Tape and Cartridge for Information Interchange. Refer to your drive vendor’s 
publication and Web site for specific cartridge requirements and specifications.

Colored cartridges are approved only if the measured reflection density is greater than 
0.1 as measured by an X-rite 404G color reflection densitometer. For more information 
about colored cartridges, contact your Sun StorageTek representative. 

Colored measurements are:

For more information about colored cartridges, contact your Sun StorageTek 
representative.

Valid Cartridge Labels 
Library cartridges must be labeled with a valid external label. Several standard Code 39 
bar code labels are supported by the library. 

Notes: 

■ Unlabeled cartridges are not supported. See “Unlabeled Cartridges” on page 503.

Bandwidth ANSI Status T Wide band (380 to 780 nm)

Measuring range Density (0.00 to 2.50) D

Accuracy ±0.02 D

Repeatability ±0.01 D

Aperture diameter 3.4 mm (0.13in.)
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Pre-labeled cartridges are available from Sun StorageTek. For information on ordering 
these cartridges, see “Ordering Cartridges and Labels” on page 505.

If you do not order pre-labeled cartridges, see “Apply the Label on a Cartridge” on 
page 506 for detailed instructions on labeling the cartridges correctly. Sun StorageTek 
does not supply cartridge labels. For a supplier of labels only, see “Ordering Cartridges 
and Labels” on page 505. 

Media Domain and Media ID
The media domain and media ID together identify a cartridge’s media and usage to the 
library. They allow you to mix tape drive types and media types in a library. The media 
ID label corresponds to the tape drive or transport capable of using the cartridge. The 
media domain reflects the cartridge usage: data, cleaning, diagnostic.

Cleaning and Diagnostic Cartridges 
Cleaning cartridges have CLN in the VOLID; diagnostic cartridges have DG in the 
VOLID

Each cleaning and diagnostic kit includes one labeled cleaning cartridge and one 
labeled diagnostic cartridge, with a volume serial number of 0 (zero) for each. Extra 
cleaning and diagnostic labels are sent with each library. 

Cleaning and diagnostic cartridges cannot be used as scratch cartridges or initialized by 
software utilities.

Caution – PROCEDURE ERROR: When you enter a cleaning cartridge, the software 
considers it to be new, and sets the usage counter to zero. DO NOT RE-ENTER A 
CLEANING CARTRIDGE THAT LIBRARY EJECTS THROUGH THE CAP. 

Cartridge Codes
The SL3000 library supports three types of barcode labels: 

■ For T9x40 drives, 1/2-inch labels supplied by Trioptic (Engineered Data 
Products/Colorflex) or Tricode (American Eagle/Writeline). Both versions require a 
separate Media ID Type, which is one character. 

■ For T10000 drives, labels with eight characters, the last two of which are the required 
Media ID Domain and the Media ID Type characters.

■ For LTO® drives, labels with eight characters, the last two of which are the required 
Media ID Domain and the Media ID Type characters. 

■ For SDLT drives, labels with seven characters, the last of which is the required 
Media ID character. 
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Sun StorageTek Tape Drives and Cartridges
Cartridge labels for Sun StorageTek T9840 (models C and D) and T10000 tape drives are 
listed in TABLE C-1. These tape drives also support encryption. 

LTO Tape Drives and Cartridges

Note – LTO technology was initially developed by IBM, Hewlett-Packard, and 
Quantum. LTO is an “open format’ technology, which means that users have multiple 
sources of product and media. 

LTO cartridge labels have eight characters. The last two characters are the media ID 
(L3, L4, LT or LU). CLN or DG are the first characters on the cleaning or diagnostic 
labels. LTO 4 tape drives also support encryption. 

TABLE C-1 Sun StorageTek Cartridge Codes 

Media ID Type of Cartridge

VOLID + R T9840 data cartridge

VOLID + R (Green background) T9840C VolSafe data cartridge

VOLID + R (Purple background) T9840D VolSafe data cartridge

CLN (blank space) VOLID + U T9840 cleaning cartridge

CLN (blank space) VOLID + Y T9840D cleaning cartridge (Note: The 
T9840D has a unique cleaning cartridge.)

DG (blank space) VOLID + R T9840 diagnostic cartridge 

VOLID + T1 T10000 data cartridge

DG (blank space) VOLID + T1 T10000 diagnostic cartridge

CLN (blank space) VOLID + CT T10000 cleaning cartridge

VOLID + TS T10000 (sport) data cartridge

DG (blank space) VOLID + TS T10000 (sport) diagnostic cartridge

CLN (blank space) VOLID + CT T10000 (sport) cleaning cartridge

TABLE C-2 LTO Cartridge Codes  

Media ID Type of Cartridge

L3 Generation 3 data cartridge

L4 Generation 4 data cartridge

LT Write once read many times (WORM), 400 
GB
This feature prevents the user from altering 
or erasing information from the tape. For 
more information, go to your vendor Web 
site and do a search on WORM. 
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Handling Cartridges
Improper handling of cartridges can result in a loss of data or damage to a library 
component. To handle a cartridge correctly:

■ Do not carry several cartridges loosely in a container. The leader blocks can snag on 
other cartridges and become unlatched. 

Note – T9940 and LTO Ultrium cartridges have leader blocks. T9840 cartridges do not.

■ Make sure that the leader block is latched every time you pick up a cartridge. 

■ Keep cartridges clean. 

■ Inspect a cartridge before each use and never put a damaged cartridge into a drive 
or library. 

■ Never release a leader block and pull tape from a cartridge. 

■ Never open a cartridge. 

■ Do not handle tape that is outside the cartridge; the tape edge might be damaged. 

■ Do not expose the tape or cartridge to direct sunlight or moisture. 

■ Do not expose a recorded cartridge to magnetic fields; this might destroy data on the 
tape. 

Inserting a Cartridge in a Drive or Cell
A defective or dirty cartridge can damage a drive. Always inspect a cartridge before 
you insert it into a drive or into a tape library. Look for:

■ Cracked or broken cartridge

■ Broken leader

■ Broken tape access door

■ Damaged file-protect selector or write-protect switch

■ Liquid in the cartridge

LU Write once read many times (WORM), 800 
GB

CLN (blank space) + CU Universal cleaning cartridge
Sun recommends using the CLN + CU 
universal label instead of a vendor-unique 
label (CLN + C1 for Hewlett-Packard or 
CLN + C2 for IBM).

DG (blank space) + VOLID Diagnostic cartridge (apply a DG label to a 
blank data cartridge to be used for library 
diagnostic tests) 

TABLE C-2 LTO Cartridge Codes  (Continued)

Media ID Type of Cartridge
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■ Labels not firmly attached or extending over the cartridge edge

■ Any other obvious damage

A cartridge must be inserted in a storage cell, rotational or AEM CAP cell, or drive with 
the bar code on the bottom, and the VOLID readable from right to left. The cartridge 
hub must always be down. 

Unreadable Cartridges
Cartridges may be identified as unreadable for the following reasons:

■ Unlabeled Cartridges

■ Upside-Down Cartridges

HSC and ACSLS automatically eject unreadable cartridges from the library. FC-SCSI 
hosts may not; an unreadable cartridge may be moved automatically to a CAP during 
library initialization. 

Note – If a large number of cartridges are reported as unreadable, you may suspect a 
faulty TallBot camera or scanner. This could result in a large number of cartridges 
mistakenly ejected from the library. 

Unlabeled Cartridges
Cartridges without external labels are not fully supported in the SL3000. Unlabeled 
cartridges will not be mounted on drives; however, they can be moved between CAPs 
and storage cells. 

■ If an unlabeled cartridge is placed in a CAP, the TallBot will leave the cartridge 
there. The cartridge’s disposition depends on the host software. 

■ If an unlabeled cartridge is placed in a library storage cell, during an audit the 
cartridge will be reported as “unreadable, invalid media type.” Depending on the 
host software, the cartridge may not be recognized by the host, or it may be ejected 
through the CAP. 

Upside-Down Cartridges
Insertion of upside-down cartridges should never be attempted, especially for Sun 
StorageTek cartridges. How the library handles this situation depends upon the 
cartridge type.

Sun StorageTek Cartridges

Caution – Upside-down Sun StorageTek cartridges do not fit in library storage cells 
and may cause damage to the cartridge and the TallBot.
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■ If a Sun StorageTek cartridge is placed upside-down in a CAP magazine, the CAP 
will not be able to close. 

■ If a Sun StorageTek cartridge is placed upside-down in a library storage cell, the 
cartridge will extend from the storage cell may and damage the TallBot. 

LTO Cartridges
■ If an LTO cartridge is placed upside-down in a CAP magazine, the TallBot will leave 

the cartridge there. The cartridge’s disposition depends on the host software. 

■ If an LTO cartridge is placed upside-down in a library storage cell, during an audit 
the cartridge will be reported as “unreadable, invalid media type.” Depending on 
the host software, the cartridge may not be recognized by the host, or it may be 
ejected through the CAP. 

Maintaining Cartridges
The following section describes general maintenance guidelines for cartridges. 

Cleaning the Cartridge Exterior 

Caution – CARTRIDGE DAMAGE: Certain solvents can damage the cartridges. DO 
NOT USE ACETONE, TRICHLOROETHANE, TOLUENE, XYLENE, BENZENE, 
KETONE, METHYL ETHYL KETONE, METHYLENE CHLORIDE, 
ETHYLDICHLORIDE, ESTERS, ETHYL ACETATE, OR SIMILAR CHEMICALS TO 
REMOVE LABELS OR TO CLEAN CARTRIDGES. 

Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. 

Use StorageTek Tape Cleaner Wipes, PN 4046289-01 to clean the cartridges. These 
wipes are saturated with isopropyl alcohol. Do not let any solution touch the tape or 
get inside the cartridge. 

Repairing a Detached Leader Block 
When a T9940 or LTO Ultrium cartridge tape is damaged, use a backup tape if possible. 
If a cartridge leader block is detached, there is no backup tape, and the cartridge or tape 
has no obvious damage, you may repair the leader block using a repair kit provided by 
the tape supplier. You can use the tape one time to copy the data onto another tape. 

Storing Cartridges
Following are guidlines for cartridge storage:
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■ Do not take a cartridge out of its protective wrapping until you are ready to use it. 
Use the tear string, not a sharp instrument, to remove the wrapping. 

■ Store cartridges in a clean environment that duplicates the conditions of the room in 
which they are used. 

■ Before using a cartridge, make sure that it has been in its operating environment for 
at least 24 hours.

■ Archival storage is 1 to 10 years for 9x40 cartridge tapes and 15 to 30 years for LTO 
Ultrium cartridge tapes.

Ordering Cartridges and Labels
Contact your authorized Sun StorageTek Selling Agent for labeled cartridges.

For cartridge labels, contact EDP/Colorflex at:

■ Phone: 1.888.438.8362 (domestic and international)
■ Web site: http://www.colorflex.com

For technical questions, contact Sun StorageTek Sales Support at:

■ Phone: 1.800.275.4785
■ E-mail: sales_support@storagetek.com 

http://www.colorflex.com
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▼ Apply the Label on a Cartridge
1. Make sure that the cartridge has been at room temperature for at least 24 hours.

2. Clean the surface where the label will be placed using a cleaning solution made for 
this purpose. See “Cleaning the Cartridge Exterior” on page 504. 

3. Peel the backing from the VOLID label. 

4. Lay the cartridge flat, in the position you would use to insert the cartridge in a tape 
drive. 

5. Position the VOLID label with the bar-code characters below the alphanumeric 
characters. Press it into place.

Note – On LTO Ultrium VOLID labels, the alphanumeric characters can be either 
vertical or horizontal.

6. If the cartridge has a customer label, place the label in the area and press it into 
place. 

7. Repeat Steps 2 through 5 for the media ID label.

8. The label must be within the indented area of the cartridge so that the edges of the 
label are parallel to the edges of the cartridge. The label should be close to the inside 
edge of the indented area but must never overlap the edge of this area. 

Notes: 

■ Make sure that the label is not placed elsewhere on the cartridge surface. 

■ Make sure that the edges of the label do not curl up; curling causes the cartridge to 
stick in the drive loader. 

■ Use labels that do not leave a residue when they are removed. 

■ Make sure that the label contains a VOLID.
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Web-launched SL Console Server

The Web-launched SL Console is a standard feature of the SL3000 and is included on a 
CD shipped with each library. It enables the SL Console to be installed on a centralized 
Web server. Individual clients can then use a supported Web browser to download and 
log in to the Web-launched SL Console. 

The Web-launched SL Console is deployed as a Java WebARchive (.war) file. 

Security Considerations
The customer is responsible for implementing all appropriate security systems, 
including firewalls, user access, etc. 

Server Requirements
You can deploy the Web-launched SL Console on any Web server that is compliant 
with the J2EE (Java 2 Platform, Enterprise Edition) platform. It is recommended that 
you use the Java System Web Server. 

Note – All procedures in this document assume you are using the Java System Web 
Server. 
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Server Installation and Management
Installation and management of the Web-launched SL Console server involves the 
following procedures:

■ “Download the Java System Web Server” on page 508

■ “Install the Sun Java System Web Server” on page 512

■ “Log in to the Java System Web Server Administration Console” on page 516

■ “Install and Deploy the Web-launched SL Console” on page 519

■ “Start the Web-launched SL Console” on page 525

■ “Update the Web-launched SL Console” on page 527

▼ Download the Java System Web Server
Use this procedure to download the Java System Web Server, if it is not already 
installed on your server. 

Note – This procedure requires you to have a Sun Online Account username and 
password. 

1. Open a Web browser, and in the Location Bar or Address field enter the URL of the 
Sun Web Servers page:

http://www.sun.com/download/index.jsp?cat=Web%20%26%20Proxy%20Servers&tab=3&subcat=Web%20Servers 

2. On the Web Servers page, click the Web Server link that corresponds to your server 
platform. 
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3. On the Sun Java System Web Server screen (this will vary according to your selection 
in the previous step), scroll down to verify the list of supported platforms, and click 
Download. 

4. In the Sun Download Center Login screen, enter your Username and Password, and 
click Login.
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Note – If you do not already have an account, click Register Now and follow the 
instructions to create one. 

5. In the Sun Download Center screen, make the following selections:

■ Click the Accept License Agreement radio button.
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■ Click the Sun Java System Web Server link that corresponds to your server 
platform.

6. In the popup, click Save to Disk, to save the compressed archive file to a directory of 
your choice, and click OK. 

Note – This process may take several minutes.

7. Use the appropriate extraction utility (for example, gunzip, pkunzip) to extract the 
Sun Java System Web Server files to a directory of your choice. 
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▼ Install the Sun Java System Web Server 
Use this procedure to install the Java System Web Server, if it is not already installed on 
your server. 

1. In the directory where you have extracted the Sun Java System Web Server files, 
double-click or execute from a command line the setup file (setup or setup.exe, 
depending on your platform). 

If you are installing on a Solaris platform, you may need to invoke root or sudo 
permissions, depending on the directory you are installing to. If so, use the following 
steps:

a. cd extraction_directory

where extraction_directory is the directory to which you extracted the compressed 
Java Web Server files. 

b. xhost + 

c. sudo ./setup 

2. On the Welcome screen, click Next. 
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3. On the Software License Agreement screen, click the Yes radio button, and click 
Next. 

4. On the Select Installation Directory screen, specify the directory where you want the 
Web Server installed, and click Next.
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5. On the Type of Installation screen, click Express, and click Next.

6. On the Administration Server Settings screen, specify a secure password for the 
admin user, and click Next. 
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7. On the Ready to Install screen, review the installation information and click Install 
Now. 

The installation begins, and screen with a progress bar is displayed. 

8. On the Installation Complete screen, review the information and write down the 
Administration Console URL specified in #2 under “Next Steps. You will need this 
in the next procedure. 

9. Click Finish to exit the setup program. 
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▼ Log in to the Java System Web Server 
Administration Console

1. Start the Sun Java System Web Server, if it is not already running: 

■ On Windows – Click Start > All Programs > Sun Microsystems >Web Server 7.0 > 
Start Administration Server. 

■ On Solaris – Open a terminal window, and type the following:

sudo /opt/webserver7/admin-server/bin/startserv 

Note – Wait several minutes for the server to start. 

2. Open a Web browser, and in the Location Bar or Address field enter the URL you 
wrote down at the end of the previous procedure (“Install the Sun Java System Web 
Server”). This will start the Admin Console. 

3. In the popup, accept the server certificate, and click OK. 
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4. In the Web browser where you opened the Admin Console URL, enter the admin 
User Name and Password, and click Log in. 
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5. The Common Tasks screen appears. 
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▼ Install and Deploy the Web-launched SL Console 

Note – Before you perform this activity, you must obtain the Web-launched 
SL Console installation CD. 

1. On the server, insert the Web-launched SL Console installation CD in the CD drive. 

2. Log in to the Sun Java System Web Server administration console. See “Log in to the 
Java System Web Server Administration Console” on page 516 for details. 

3. On the Common Tasks screen, click Add Web Application.

4. On the Add Web Application screen, make the following entries:

■ Web Application Location: Click the Browse button and browse to the location of 
the opel.war file on the installation CD. 

■ URI: Type /opel

■ Leave all other fields as the defaults. 
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■ Click OK. 
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5. On the Web Applications screen, click Save.
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6. On the updated Web Applications screen, click the Deployment Pending link in the 
upper-right corner. 

7. On the Configuration Deployment screen, click Deploy. 



 

Server Installation and Management

316194401 • Revision AB Web-launched SL Console Server 523

8. On the Results screen, click Close. 
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9. The Web Applications screen displays a message that the application has been added 
successfully. 

You can click the Home button in the upper-right corner to return to the Common 
Tasks screen. 
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▼ Start the Web-launched SL Console 
1. Log in to the Sun Java System Web Server administration console. See “Log in to the 

Java System Web Server Administration Console” on page 516 for details. 

2. On the Common Tasks screen, click Start/Stop Instances. 
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3. On the Configuration Instances screen, click the checkbox next to the local instance 
of the Web-launched SL Console server, and click Start. 

The Web-launched SL Console application instances are started, and screen with a 
progress bar is displayed. 

4. On the Results screen, click Close. 
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▼ Update the Web-launched SL Console 
You can update the Web-launched SL Console while it is running. Updates are 
automatically propagated to the clients when they retrieve the Web-launched 
SL Console application from the server. 

Note – Before you perform this activity, you must obtain the Web-launched 
SL Console update CD. 

1. On the server, insert the Web-launched SL Console update CD in the CD drive. 

2. Log in to the Sun Java System Web Server administration console. See “Log in to the 
Java System Web Server Administration Console” on page 516 for details. 

3. On the Common Tasks screen, click Edit Virtual Server.
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4. On the General Properties screen, click the Web Applications tab.

5. On the Web Applications screen, click the checkbox next to the /opel URI, and click 
Update.

6. On the Update Web Application screen, make the following entries:
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■ Web Application Location: Click the Browse button and browse to the location of 
the opel.war file on the update CD. 

■ Leave all other fields as the defaults. 

■ Click OK. 

The server update begins, and screen with a progress bar is displayed. 
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7. On the Web Applications screen, click the Deployment Pending link in the upper 
right corner. 

8. On the Configuration Deployment screen, click Deploy. 

The deployment begins, and screen with a progress bar is displayed. 
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9. In the Results screen, click Close to return to the Web Applications screen. 
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Common Problems and Solutions
This section describes solutions to some common problems with the installation and 
maintenance of the Java System Web Server. 

Windows 2000 Sun Java System Web Server 

Installation Errors

Windows MSVCP60.dll Error 
If you are installing on a Windows 2000 platform that does not include the Microsoft 
Visual C v6 runtime DLL, MSVCP60.dll, during installation you will see errors similar 
to the following:
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The Web server installation log will include errors similar to the following:

▼ Remedy for Windows MSVCP60.dll Error 
Use this procedure to solve the Windows MSVCP60.dll error. 

1. Perform a Web search for the following string:

msvcp60.dll download 

2. Download the DLL file to the /winnt/system32 directory. 

3. Delete the directory where you partially installed the Java System Web Server on the 
failed installation.

4. Repeat the Java System Web Server installation from the beginning.

The installation should complete successfully with no recurrence of the error. 
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▼ Solaris 9 & 10 Sun Java System Web Server 

Installation Errors

Java Home Error
If you cannot start the server instance and you see errors claiming your HotSpot start 
failed and your JVM could not be found, you need to change the Java Home 
configuration of your Sun Java System Web Server. 

▼ Remedy for Solaris Java Home Error 
Use this procedure to solve the Java Home error. 

1. Log in to the Sun Java System Web Server administration console. See “Log in to the 
Java System Web Server Administration Console” on page 516 for details. 

2. Select Home > Common Tasks. 

3. Under Configuration Tasks, click Edit Java Settings. 
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4. In Java Home, enter the directory where your JDK/JRE is installed. For example:

/usr/java 

Note – You may also need to change permissions on the top-level directory where you 
installed the Sun Java System Web Server. In order for a non-root user to start a server 
instance, the user must be able to write to the server directory. For example, if you 
installed the server to the top-level directory /opt/webserver7, the user starting the 
server instance must be able to write to this directory and the https-server_name 
directory beneath it. For additional information see the Sun Java System Web Server 
site. 
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CAP cell 477
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storage cell 473–476

library management software 28–29
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allocating an AEM CAP 274
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CAP operations 256
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configuration requirements 247
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deleting the Partitioning feature 250
described 247
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ejecting cartridges from 307
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features of 247
hosts and 247, 249, 269, 287, 289, 291, 322, 324, 326
installing the Partitioning feature 248
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library resources and 253, 294, 357
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modifying summary information 284, 331
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planning 248–250
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SL Console workspace and 264, 293, 351
summary screen reference 313–332
task summary 265
using AEMs in 255–259
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verifying 276, 348

library power down 463
library power up 464–465
library reboot 406
library reports 67
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saving data to a file 106
searching 104
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performing 405

library status
displaying 88
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license expirations 182
license key file
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described 181
displaying contents of 186–188
file type 181
installing 183, 189–191, 196–198, 201
library serial number and 181, 187, 190, 197
licensed capacity and 203
overlaying 181
receiving 185

licensed capacity 203–246
active cells 204
active storage regions 204, 205

automatic assignment 205
committing 216–218, 234–236
defining 213–215, 226–233
displaying 245–246
printing reports 221
reports 219–220, 237–244
saving reports 222
SL Console workspace 225, 234
SL Console workspace and 210

cell activation rules 205, 249
changes and FC-SCSI connections 208
changes and HLI connections 207
de-activating 205
decreasing 209
inactive cells 204
increasing 209
increments of 203
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license key file and 203
management tasks 210–222
minimum and maximum 203
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orphaned cartridges and 206, 242–244
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screen reference 225–246
selected cells 204

licensed features
Capacity on Demand 203–246
deleting 250
displaying current 192, 194
installing 183, 248
Partitioning 247–384
redundant robot 21

licensing screen reference 193–202
licensing tasks 183–192
local operator panel

described 40–41
entering data 40
keypad 40
logging in 41
pen and stylus 40
touch-screen 40

log snapshot file
described 395
transfer process 414–416

login IDs 34
LTO

repairing detached leader block 504

M
main access door

audits and 388
automated mode and 64

maintenance mode (library) 30
Management Information Base. See MIB file.
manual CAP 70
manual cleaning (drive) 80, 170
manual mode (library) 30
manual operations

safety precautions 455–457
access door interlocks 456
access door release 457
general 455
physical restrictions 457
server power interrupt 456

tasks 458–467
media

domain labels 500
ID labels 500

Media Events Report 142
MIB file

described 395
transfer process 412–413

mixed-media support 5
modules 3

AEM 15
Base Module 7–8
capacity 5
CEM 13
DEM 10–11
PEM 14

mount operations 63

N
NDP. See non-disruptive partitioning.
NearLine Control Solution 28
non-disruptive capacity changes 207
non-disruptive partitioning

FC-SCSI partitions and 261
HLI partitions and 260

O
orphaned cartridges

non-partitioned libraries and 206
partitioned libraries and 253, 279, 369

P
Parking Expansion Module. See PEM.
partitioned library. See library partitions.
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partitioning
non-disruptive. See non-disruptive partitioning.

partitions. See library partitions
partitions. See library partitions.
passwords

modifying 36
PEM

described 14
physical capacity 6
wall diagrams 494

physical capacity 5, 204
of library modules 6

power down the library 463
power redundancy 22
power source options 22
power supplies 22, 82

cooling of 23
monitoring tasks 171–176
status of 176
summary information 175

power up the library 464–465

R
RealTimeGrowth 203
reboot

library 406
recovery moves 77
repairing detached leader block 504
reserved cells 476

diagram 498
result codes

listing 403
robot

bar code scanner 21
faulty 503

described 20–21, 81
diagnostic moves. See diagnostic moves.
monitoring tasks 171–176
properties 174
redundant 21
self-test 435
status of 173
summary information 172
utility tasks 434–450
varying offline 436
varying online 437

row numbering, diagram 497

S
safety door. See AEM safety door.
safety precautions 455–457

access door interlocks 456
access door release 457
general 455

physical restrictions 457
servo power interrupt 456

SCSI interface
displaying port status 94

self-tests
CAP 425
drive 431
library 386, 405
robot 435

SL Console
activation password 34
active storage region workspace and 210, 225, 234
communications failures 66
described 27, 33
first-time access 34
layout of screen 37
local operator panel. See local operator panel.
logging in 35
logging off 35
login IDs 34
modes 33
modifying passwords 36
modifying the screen display 39
partition workspace and 264, 293, 351
security 34
standalone. See standalone SL Console
Web-launched. See Web-launched SL Console

SL Console Help
accessing 60
described 60
navigation 60

SL Console reports
Drive Events 157
Drive Media Events 159
Energy Monitor 108, 110, 112
Media Events 142
Options Bar 67
types 67

SLC. See SL Console
SNMP

library support of 27
transferring the library MIB file 412–413

standalone SL Console
described 42–48
installing 43
installing updates 48
logging in 48

status alerts
clearing 91
described 68
displaying 89

Status Module. See status alerts.
storage cells

FC-SCSI address 484–486
HLI-PRC address 479–481
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library internal address 473–476
physical capacity 5
wall diagrams 489–498

StorageTek Library Console. See SL Console

T
T9940

repairing detached leader block 504
TallBot. See robot.
tape drives. See drives
tape drives. See drives.
TCP/IP interface 24–26
transferring the log snapshot file 414–416
troubleshooting 393

U
User’s Guide

Cautions xxx
conventions xxxi
Notes xxx
Warnings xxx

V
vary the library offline 459–460
vary the library online 461–462
VOP

displaying for T10000 drives 149

W
wall diagrams

AEM 495
Base Module 490
CEM 492
configuration block 496
DEM 491
PEM 494
reserved cells 498
row numbering 497

Web-launched SL Console
client requirements 49
described 49–59
downloading the Java System Web Server 508–511
installation errors 532
installing on the server 519–524
installing the Java System Web Server 512–515
Java WebArchive file 507
logging in to the Java System Web Server 516–518
logging in using a browser 50–55
logging in using an icon 56–59
security 49, 507
server described 507–535
server requirements 507
starting on a client 50
starting on the server 525–526
updating on a client 49

updating on the server 527–531
World Wide Name. See  dWWN
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